summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-11-11 20:29:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-11-11 20:29:31 +0000
commit94525572ffd1ec211a702dda3346dfe694bb01d5 (patch)
tree6576f994d3d5b744ed29d1637a466539acba07a1 /media-video/mpeg4ip
parentReplace eautoreconf with shorter eautomake (diff)
downloadgentoo-2-94525572ffd1ec211a702dda3346dfe694bb01d5.tar.gz
gentoo-2-94525572ffd1ec211a702dda3346dfe694bb01d5.tar.bz2
gentoo-2-94525572ffd1ec211a702dda3346dfe694bb01d5.zip
Adding a patch from mpeg4ip cvs to follow x264 api changes
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'media-video/mpeg4ip')
-rw-r--r--media-video/mpeg4ip/ChangeLog8
-rw-r--r--media-video/mpeg4ip/files/digest-mpeg4ip-1.5.0.1-r13
-rw-r--r--media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch67
-rw-r--r--media-video/mpeg4ip/mpeg4ip-1.5.0.1-r1.ebuild152
4 files changed, 229 insertions, 1 deletions
diff --git a/media-video/mpeg4ip/ChangeLog b/media-video/mpeg4ip/ChangeLog
index dd2c14e6e34e..e1aa64d1cdd9 100644
--- a/media-video/mpeg4ip/ChangeLog
+++ b/media-video/mpeg4ip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/mpeg4ip
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/ChangeLog,v 1.43 2006/10/23 16:05:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/ChangeLog,v 1.44 2006/11/11 20:29:31 aballier Exp $
+
+*mpeg4ip-1.5.0.1-r1 (11 Nov 2006)
+
+ 11 Nov 2006; Alexis Ballier <aballier@gentoo.org>
+ +files/mpeg4ip-1.5.0.1-x264.patch, +mpeg4ip-1.5.0.1-r1.ebuild:
+ Adding a patch from mpeg4ip cvs to follow x264 api changes
23 Oct 2006; Simon Stelling <blubb@gentoo.org> mpeg4ip-1.5.0.1.ebuild:
remove ugly x86? in DEPEND
diff --git a/media-video/mpeg4ip/files/digest-mpeg4ip-1.5.0.1-r1 b/media-video/mpeg4ip/files/digest-mpeg4ip-1.5.0.1-r1
new file mode 100644
index 000000000000..c15cf36b860f
--- /dev/null
+++ b/media-video/mpeg4ip/files/digest-mpeg4ip-1.5.0.1-r1
@@ -0,0 +1,3 @@
+MD5 f53b06c62e914ab724bda9d9af041e08 mpeg4ip-1.5.0.1.tar.gz 4826180
+RMD160 fee5c21c17a470e6de349e07d233a1eb46b2064a mpeg4ip-1.5.0.1.tar.gz 4826180
+SHA256 23535dd818898ec75ffa0df22d9f27189e77361ce8a500d58328073ee247bcb6 mpeg4ip-1.5.0.1.tar.gz 4826180
diff --git a/media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch b/media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch
new file mode 100644
index 000000000000..ff74651af4bd
--- /dev/null
+++ b/media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch
@@ -0,0 +1,67 @@
+--- mpeg4ip-1.5.0.1/server/mp4live/video_x264.cpp 2006-05-11 22:23:19.000000000 +0200
++++ /home/alexis/mpeg4ip/mpeg4ip/server/mp4live/video_x264.cpp 2006-09-29 21:55:42.000000000 +0200
+@@ -32,7 +32,9 @@
+
+ static config_index_t CFG_X264_FORCE_BASELINE;
+ static config_index_t CFG_X264_USE_CABAC;
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ static config_index_t CFG_X264_USE_CBR;
++#endif
+ static config_index_t CFG_X264_BIT_RATE_TOLERANCE;
+ static config_index_t CFG_X264_USE_VBV;
+ static config_index_t CFG_X264_VBV_BITRATE_MULT;
+@@ -44,7 +46,9 @@
+ static SConfigVariable X264EncoderVariables[] = {
+ CONFIG_BOOL(CFG_X264_FORCE_BASELINE, "x264ForceBaseline", false),
+ CONFIG_BOOL(CFG_X264_USE_CABAC, "x264UseCabac", true),
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ CONFIG_BOOL(CFG_X264_USE_CBR, "x264UseCbr", true),
++#endif
+ CONFIG_FLOAT(CFG_X264_BIT_RATE_TOLERANCE, "x264BitRateTolerance", 1.0),
+ CONFIG_BOOL(CFG_X264_USE_VBV, "x264UseVbv", false),
+ CONFIG_FLOAT(CFG_X264_VBV_BITRATE_MULT, "x264VbvBitRateMult", 1.0),
+@@ -56,7 +60,9 @@
+
+ GUI_BOOL(gui_baseline, CFG_X264_FORCE_BASELINE, "Force Baseline (overrides below)");
+ GUI_BOOL(gui_cabac, CFG_X264_USE_CABAC, "Use Cabac");
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ GUI_BOOL(gui_cbr, CFG_X264_USE_CBR, "Use CBR");
++#endif
+ GUI_BOOL(gui_bframe, CFG_VIDEO_USE_B_FRAMES, "Use B Frames");
+ GUI_INT_RANGE(gui_bframenum, CFG_VIDEO_NUM_OF_B_FRAMES, "Number of B frames", 1, 4);
+
+@@ -75,7 +81,9 @@
+ DECLARE_TABLE(x264_gui_options) = {
+ TABLE_GUI(gui_baseline),
+ TABLE_GUI(gui_cabac),
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ TABLE_GUI(gui_cbr),
++#endif
+ TABLE_GUI(gui_bframe),
+ TABLE_GUI(gui_bframenum),
+ TABLE_GUI(gui_brate),
+@@ -168,7 +176,11 @@
+ m_param.i_bframe = 0;
+ //debug_message("h264 b frames %d", m_param.i_bframe);
+ m_param.rc.i_bitrate = Profile()->GetIntegerValue(CFG_VIDEO_BIT_RATE);
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ m_param.rc.b_cbr = Profile()->GetBoolValue(CFG_X264_USE_CBR) ? 1 : 0;
++#else
++ m_param.rc.i_rc_method = X264_RC_ABR;
++#endif
+ m_param.rc.f_rate_tolerance = Profile()->GetFloatValue(CFG_X264_BIT_RATE_TOLERANCE);
+ if (Profile()->GetBoolValue(CFG_X264_USE_VBV)) {
+ if (Profile()->GetBoolValue(CFG_X264_FORCE_BASELINE)) {
+--- mpeg4ip-1.5.0.1/server/mp4live/video_x264.h.old 2006-11-11 20:56:48.000000000 +0100
++++ mpeg4ip-1.5.0.1/server/mp4live/video_x264.h 2006-11-11 20:57:49.000000000 +0100
+@@ -33,6 +33,10 @@
+ }
+ #endif
+
++#if X264_BUILD > 47
++#define HAVE_X264_PARAM_T_RC_I_RC_METHOD
++#endif
++
+ class CX264VideoEncoder : public CVideoEncoder {
+ public:
+ CX264VideoEncoder(CVideoProfile *vp,
diff --git a/media-video/mpeg4ip/mpeg4ip-1.5.0.1-r1.ebuild b/media-video/mpeg4ip/mpeg4ip-1.5.0.1-r1.ebuild
new file mode 100644
index 000000000000..2b7b6fa196a1
--- /dev/null
+++ b/media-video/mpeg4ip/mpeg4ip-1.5.0.1-r1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg4ip/mpeg4ip-1.5.0.1-r1.ebuild,v 1.1 2006/11/11 20:29:31 aballier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="MPEG 4 implementation library"
+
+HOMEPAGE="http://www.mpeg4ip.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-1.1 LGPL-2 GPL-2 LGPL-2.1 BSD UCL MPEG4"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ipv6 mmx v4l2 xvid nas alsa esd arts ffmpeg a52 mpeg2 lame aac id3 player mp4live x264"
+
+RDEPEND=" media-libs/libsdl
+ player? (
+ >=x11-libs/gtk+-2
+ ffmpeg? ( >=media-video/ffmpeg-0.4.7 )
+ mpeg2? ( media-libs/libmpeg2 )
+ id3? ( media-libs/libid3tag )
+ a52? ( media-libs/a52dec )
+ )
+ xvid? ( >=media-libs/xvid-0.9.8 )
+ mp4live? (
+ >=x11-libs/gtk+-2
+ lame? ( >=media-sound/lame-3.92 )
+ aac? ( >=media-libs/faac-1.24-r1 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.7 )
+ x264? ( media-libs/x264-svn )
+ )
+ nas? ( media-libs/nas || ( x11-libs/libXt virtual/x11 ) )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ =media-libs/libmp4v2-1.5.0.1
+ !<media-libs/faad2-2.0-r9 "
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake
+ player? ( mmx? ( >=dev-lang/nasm-0.98.19 ) )"
+
+pkg_setup() {
+ if ! built_with_use media-libs/libsdl X;
+ then
+ eerror "media-libs/libsdl does not has X support"
+ eerror "You need to rebuild media-libs/libsdl with USE=X"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/mpeg4ip-1.4.1-disable-faac-test.patch
+ epatch "${FILESDIR}/${P}-x264.patch"
+}
+
+src_compile() {
+ cd ${S}
+
+ local myconf
+ myconf=" --datadir=/usr/share/mpeg4ip
+ $(use_enable ipv6)
+ $(use_enable ppc)
+ $(use_enable player)
+ $(use_enable mp4live)
+ $(use_enable xvid)
+ $(use_enable nas)
+ $(use_enable esd)
+ $(use_enable alsa)
+ $(use_enable arts)
+ --disable-srtp" # need ot add libsrtp to portage
+
+
+ # Those are possible for both player and mp4live
+ if use player || use mp4live ; then
+ myconf="${myconf} --enable-gtk-glib
+ $(use_enable ffmpeg)"
+ fi
+
+ # Those are only relevant for the player
+ use player && myconf="${myconf}
+ $(use_enable mmx)
+ $(use_enable a52 a52dec)
+ $(use_enable mpeg2 mpeg2dec)
+ $(use_enable id3 id3tags)"
+ use player || myconf="${myconf}
+ --disable-a52
+ --disable-mmx
+ --disable-mpeg2dec
+ --disable-id3tags"
+
+
+ # those can only be used for mp4live
+ use mp4live && myconf="${myconf}
+ $(use_enable v4l2)
+ $(use_enable lame mp3lame)
+ $(use_enable aac faac)
+ $(use_enable x264)"
+ # $(use_enable alsa mp4live-alsa)
+ use mp4live || myconf="${myconf}
+ --disable-v4l2
+ --disable-mp3lame
+ --disable-faac
+ --disable-mp4live-alsa
+ --disable-x264"
+
+ ./bootstrap --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var/lib \
+ --disable-warns-as-err \
+ --enable-server \
+ ${EXTRA_ECONF} \
+ ${myconf} || die "configure failed"
+
+ sed -i -e 's:-Werror::' common/video/iso-mpeg4/src/Makefile || die "sed failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ cd ${S}
+ make install DESTDIR="${D}" || die "make install failed"
+
+ rm -f ${D}/usr/include/mp4.h
+ rm -f ${D}/usr/$(get_libdir)/libmp4v2*
+
+ dodoc doc/MPEG4IP_Guide.pdf doc/*txt AUTHORS TODO
+
+ dohtml doc/*.html FEATURES.html || die
+
+ docinto ietf
+ dodoc doc/ietf/*.txt || die
+
+ docinto mcast
+ dodoc doc/mcast/mcast.txt doc/mcast/mcast_example doc/mcast/playlist_example || die
+
+}