summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-08-03 02:29:29 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-08-03 02:29:29 +0000
commit28b52a1bbd0976ad6a0aa2679d7f0ed07f262465 (patch)
tree8c7d575154a4c35b665c5ca726a5da1fa89da9f3 /media-video/gxine/gxine-0.5.903.ebuild
parentRemove >=media-sound/pulseaudio-0.9.10-r50 added by flameeyes in October as 0... (diff)
downloadgentoo-2-28b52a1bbd0976ad6a0aa2679d7f0ed07f262465.tar.gz
gentoo-2-28b52a1bbd0976ad6a0aa2679d7f0ed07f262465.tar.bz2
gentoo-2-28b52a1bbd0976ad6a0aa2679d7f0ed07f262465.zip
Version bump.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-video/gxine/gxine-0.5.903.ebuild')
-rw-r--r--media-video/gxine/gxine-0.5.903.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/media-video/gxine/gxine-0.5.903.ebuild b/media-video/gxine/gxine-0.5.903.ebuild
new file mode 100644
index 000000000000..57cbef6a34a4
--- /dev/null
+++ b/media-video/gxine/gxine-0.5.903.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/gxine/gxine-0.5.903.ebuild,v 1.1 2008/08/03 02:29:29 chutzpah Exp $
+
+inherit eutils nsplugins fdo-mime libtool
+
+DESCRIPTION="GTK+ Front-End for libxine"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls hal lirc nsplugin xinerama xcb"
+
+RDEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1.1.8
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2.10
+ >=x11-libs/pango-1.12
+ >=dev-lang/spidermonkey-1.5_rc6-r1
+ lirc? ( app-misc/lirc )
+ nsplugin? ( dev-libs/nspr )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xcb? ( x11-libs/libxcb )
+ hal? ( sys-apps/hal )
+ xinerama? ( x11-libs/libXinerama )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ x11-libs/libXt
+ x11-libs/libXaw"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/ac_have_xinerama/ s:text:test:' \
+ "${S}/configure"{,.ac}
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable lirc) \
+ $(use_with nsplugin browser-plugin) \
+ $(use_with xcb) \
+ $(use_with hal) \
+ $(use_with xinerama) \
+ --disable-gtk-compat \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS ChangeLog NEWS README{,.{cs,de}_l10n TODO BUGS
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/gxine/gxineplugin.so
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}