summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-12 08:46:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-12 08:46:29 +0000
commitba4ae7fab3435f478e21b956d75d47547add7e2c (patch)
tree17ebfb9b6ac92455e00a529491694bd5b1507e7d /media-video/gpac
parenttidy (diff)
downloadgentoo-2-ba4ae7fab3435f478e21b956d75d47547add7e2c.tar.gz
gentoo-2-ba4ae7fab3435f478e21b956d75d47547add7e2c.tar.bz2
gentoo-2-ba4ae7fab3435f478e21b956d75d47547add7e2c.zip
fix build with ffmpeg 2.5, bug #536526
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/gpac')
-rw-r--r--media-video/gpac/ChangeLog8
-rw-r--r--media-video/gpac/files/ffmpeg25.patch43
-rw-r--r--media-video/gpac/gpac-0.5.1_pre5456.ebuild7
3 files changed, 53 insertions, 5 deletions
diff --git a/media-video/gpac/ChangeLog b/media-video/gpac/ChangeLog
index a3ab863c5583..6a0308dcd833 100644
--- a/media-video/gpac/ChangeLog
+++ b/media-video/gpac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/gpac
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/ChangeLog,v 1.124 2014/10/07 22:17:32 lu_zero Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/ChangeLog,v 1.125 2015/02/12 08:46:29 aballier Exp $
+
+ 12 Feb 2015; Alexis Ballier <aballier@gentoo.org> gpac-0.5.1_pre5456.ebuild,
+ +files/ffmpeg25.patch:
+ fix build with ffmpeg 2.5, bug #536526
07 Oct 2014; Luca Barbato <lu_zero@gentoo.org> gpac-0.5.1_pre5456.ebuild,
gpac-9999.ebuild:
diff --git a/media-video/gpac/files/ffmpeg25.patch b/media-video/gpac/files/ffmpeg25.patch
new file mode 100644
index 000000000000..5451b8e1199a
--- /dev/null
+++ b/media-video/gpac/files/ffmpeg25.patch
@@ -0,0 +1,43 @@
+Add proper versionned checks for avformat_close_input
+https://bugs.gentoo.org/show_bug.cgi?id=536526
+
+diff --git a/modules/ffmpeg_in/ffmpeg_demux.c b/modules/ffmpeg_in/ffmpeg_demux.c
+index a5202ee..975a945 100644
+--- a/modules/ffmpeg_in/ffmpeg_demux.c
++++ b/modules/ffmpeg_in/ffmpeg_demux.c
+@@ -301,7 +301,7 @@ static Bool FFD_CanHandleURL(GF_InputService *plug, const char *url)
+ }
+
+ exit:
+-#ifndef FF_API_CLOSE_INPUT_FILE
++#if LIBAVFORMAT_VERSION_MAJOR < 54
+ if (ctx) av_close_input_file(ctx);
+ #else
+ if (ctx) avformat_close_input(&ctx);
+@@ -680,7 +680,7 @@ static GF_Err FFD_ConnectService(GF_InputService *plug, GF_ClientService *serv,
+
+ ffd->seekable = (av_seek_frame(ffd->ctx, -1, 0, AVSEEK_FLAG_BACKWARD)<0) ? 0 : 1;
+ if (!ffd->seekable) {
+-#ifndef FF_API_CLOSE_INPUT_FILE
++#if LIBAVFORMAT_VERSION_MAJOR < 54
+ av_close_input_file(ffd->ctx);
+ #else
+ avformat_close_input(&ffd->ctx);
+@@ -699,7 +699,7 @@ static GF_Err FFD_ConnectService(GF_InputService *plug, GF_ClientService *serv,
+
+ err_exit:
+ GF_LOG(GF_LOG_ERROR, GF_LOG_CONTAINER, ("[FFMPEG] Error opening file %s: %s\n", url, gf_error_to_string(e)));
+-#ifndef FF_API_CLOSE_INPUT_FILE
++#if LIBAVFORMAT_VERSION_MAJOR < 54
+ if (ffd->ctx) av_close_input_file(ffd->ctx);
+ #else
+ if (ffd->ctx) avformat_close_input(&ffd->ctx);
+@@ -757,7 +757,7 @@ static GF_Err FFD_CloseService(GF_InputService *plug)
+
+ ffd->is_running = 0;
+
+-#ifndef FF_API_CLOSE_INPUT_FILE
++#if LIBAVFORMAT_VERSION_MAJOR < 54
+ if (ffd->ctx) av_close_input_file(ffd->ctx);
+ #else
+ if (ffd->ctx) avformat_close_input(&ffd->ctx);
diff --git a/media-video/gpac/gpac-0.5.1_pre5456.ebuild b/media-video/gpac/gpac-0.5.1_pre5456.ebuild
index f88b944c9205..e9a0001d100c 100644
--- a/media-video/gpac/gpac-0.5.1_pre5456.ebuild
+++ b/media-video/gpac/gpac-0.5.1_pre5456.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.1_pre5456.ebuild,v 1.2 2014/10/07 22:17:32 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.1_pre5456.ebuild,v 1.3 2015/02/12 08:46:29 aballier Exp $
EAPI=4
@@ -69,7 +69,8 @@ my_use() {
src_prepare() {
epatch "${FILESDIR}"/110_all_implicitdecls.patch \
- "${FILESDIR}"/${PN}-0.5.1-build-fixes.patch
+ "${FILESDIR}"/${PN}-0.5.1-build-fixes.patch \
+ "${FILESDIR}"/ffmpeg25.patch
sed -i -e "s:\(--disable-.*\)=\*):\1):" configure || die
}