summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-05-20 14:03:54 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-05-20 14:03:54 +0000
commit5441acaec59ddaf10c0abc6355de38e01ba72cb5 (patch)
tree5b83fe1ac9495a3ec1049054bfba75d11f84af6c /media-video/flumotion
parentNew version that should fix the perl file collisions in bug #82648 (diff)
downloadgentoo-2-5441acaec59ddaf10c0abc6355de38e01ba72cb5.tar.gz
gentoo-2-5441acaec59ddaf10c0abc6355de38e01ba72cb5.tar.bz2
gentoo-2-5441acaec59ddaf10c0abc6355de38e01ba72cb5.zip
New version
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog8
-rw-r--r--media-video/flumotion/Manifest3
-rw-r--r--media-video/flumotion/files/digest-flumotion-0.1.81
-rwxr-xr-xmedia-video/flumotion/files/flumotion-init-0.1.826
-rw-r--r--media-video/flumotion/flumotion-0.1.8.ebuild96
5 files changed, 133 insertions, 1 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
index df0d37e17ff0..c68c565efc20 100644
--- a/media-video/flumotion/ChangeLog
+++ b/media-video/flumotion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/flumotion
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.4 2005/05/10 15:25:28 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.5 2005/05/20 14:03:54 zaheerm Exp $
+
+*flumotion-0.1.8 (20 May 2005)
+
+ 20 May 2005; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +files/flumotion-init-0.1.8, +flumotion-0.1.8.ebuild:
+ New version
10 May 2005; Zaheer Abbas Merali <zaheerm@gentoo.org>
flumotion-0.1.6.ebuild:
diff --git a/media-video/flumotion/Manifest b/media-video/flumotion/Manifest
index c77fd1b2d46e..fe34da95d346 100644
--- a/media-video/flumotion/Manifest
+++ b/media-video/flumotion/Manifest
@@ -1,7 +1,10 @@
MD5 f431973f0793542a4cbe702bbdea37a4 flumotion-0.1.6.ebuild 2277
+MD5 4a73753008f5457db232dcfaecbf8342 flumotion-0.1.8.ebuild 2702
MD5 7a996e8c909a5c50999d49ed3b753eb8 flumotion-0.1.7.ebuild 2277
MD5 95bd2efbb45c1a05bb8715919a95721e ChangeLog 620
MD5 6050196ef420c3e4025029ebee5a813f metadata.xml 162
+MD5 64fe71faf82cc8e8ab2fd47c3dedb02b files/flumotion-init-0.1.8 952
MD5 580aa0b30c3ddad180dcf614364f9dbb files/flumotion-init 1019
MD5 f421d5bbf35e1bda4cde73c86517fbd3 files/digest-flumotion-0.1.6 68
MD5 423fb37f9e1c267e6d5836e73b651d73 files/digest-flumotion-0.1.7 68
+MD5 5ca0386f44527ee15b57cc2883c95815 files/digest-flumotion-0.1.8 68
diff --git a/media-video/flumotion/files/digest-flumotion-0.1.8 b/media-video/flumotion/files/digest-flumotion-0.1.8
new file mode 100644
index 000000000000..5d77a7acee16
--- /dev/null
+++ b/media-video/flumotion/files/digest-flumotion-0.1.8
@@ -0,0 +1 @@
+MD5 33367676b24fe3af328ae6cfca8b63ec flumotion-0.1.8.tar.bz2 637744
diff --git a/media-video/flumotion/files/flumotion-init-0.1.8 b/media-video/flumotion/files/flumotion-init-0.1.8
new file mode 100755
index 000000000000..ff040edc13b4
--- /dev/null
+++ b/media-video/flumotion/files/flumotion-init-0.1.8
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+flumotion_manager_pidfile=/var/run/flumotion/manager.planet.pid
+flumotion_worker_pidfile=/var/run/flumotion/worker.default.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Flumotion Manager"
+ HOME=/usr/share/flumotion start-stop-daemon --start --chuid flumotion:flumotion --pidfile ${flumotion_manager_pidfile} --exec /usr/bin/flumotion-manager -- -D /etc/flumotion/managers/default/planet.xml
+ eend $?
+ ebegin "Starting Flumotion Worker"
+ HOME=/usr/share/flumotion start-stop-daemon --start --chuid flumotion:flumotion --pidfile ${flumotion_worker_pidfile} --exec /usr/bin/flumotion-worker -- -D /etc/flumotion/workers/default.xml -ndefault
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Flumotion Worker"
+ start-stop-daemon --stop --pidfile ${flumotion_worker_pidfile}
+ eend $?
+ ebegin "Stopping Flumotion Manager"
+ start-stop-daemon --stop --pidfile ${flumotion_manager_pidfile}
+ eend $?
+}
diff --git a/media-video/flumotion/flumotion-0.1.8.ebuild b/media-video/flumotion/flumotion-0.1.8.ebuild
new file mode 100644
index 000000000000..f46a2ffc469e
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.1.8.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.1.8.ebuild,v 1.1 2005/05/20 14:03:54 zaheerm Exp $
+
+inherit eutils
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.fluendo.com"
+SRC_URI="http://www.flumotion.net/src/flumotion/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="v4l speex jpeg dv"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ >=gnome-base/libglade-2
+ >=media-libs/gstreamer-0.8.9-r2
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-gnomevfs-0.8.8
+ v4l? ( >=media-plugins/gst-plugins-v4l-0.8.8 )
+ >=media-plugins/gst-plugins-ogg-0.8.8
+ >=media-plugins/gst-plugins-theora-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8
+ >=media-plugins/gst-plugins-libpng-0.8.8
+ speex? ( >=media-plugins/gst-plugins-speex-0.8.8 )
+ dv? ( >=media-plugins/gst-plugins-dv-0.8.8
+ >=media-plugins/gst-plugins-raw1394-0.8.8 )
+ >=dev-python/pygtk-2.4.0
+ >=dev-python/gst-python-0.8.1
+ >=dev-python/twisted-1.3.0
+ dev-python/imaging
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ LICENCE.Flumotion LICENCE.GPL \
+ NEWS README TODO"
+
+src_compile() {
+ econf --localstatedir=/var || die
+
+ emake || die
+ # fix ${exec_prefix} not being expanded
+ cd ${S}/bin
+ cp flumotion-manager flumotion-manager.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-manager.orig \
+ > flumotion-manager
+ cp flumotion-worker flumotion-worker.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-worker.orig \
+ > flumotion-worker
+ cp flumotion-admin flumotion-admin.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-admin.orig \
+ > flumotion-admin
+}
+
+src_install() {
+ einstall
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ insinto /etc/flumotion/managers/default/flows
+ cd ${S}/conf
+ doins managers/default/flows/ogg-test-theora.xml
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+
+ insinto /etc/flumotion
+ doins default.pem
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/flumotion-init-0.1.8 flumotion
+
+ keepdir /var/run/flumotion
+ keepdir /var/log/flumotion
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 /bin/false /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion ${dir}
+ chmod -R 755 ${dir}
+ done
+}