summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-01 01:46:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-01 01:46:48 +0000
commitadfdc64e2772863c11fb5e7ee9ca3bee5e350a27 (patch)
tree2dfa3e799df90bc6a5a6dcefec44e8fb0348d3ce /media-video/ffmpeg/ffmpeg-9999.ebuild
parentversion bump (diff)
downloadgentoo-2-adfdc64e2772863c11fb5e7ee9ca3bee5e350a27.tar.gz
gentoo-2-adfdc64e2772863c11fb5e7ee9ca3bee5e350a27.tar.bz2
gentoo-2-adfdc64e2772863c11fb5e7ee9ca3bee5e350a27.zip
disable mmx and other asm if pic is requested on x86 only
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index ef69705baca6..0a6fdc7c7c45 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.21 2010/10/01 00:56:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.22 2010/10/01 01:46:48 aballier Exp $
EAPI="2"
@@ -158,8 +158,8 @@ src_configure() {
use 3dnow || myconf="${myconf} --disable-amd3dnow"
use 3dnowext || myconf="${myconf} --disable-amd3dnowext"
# disable mmx accelerated code if PIC is required
- # as the provided asm decidedly is not PIC.
- if gcc-specs-pie ; then
+ # as the provided asm decidedly is not PIC for x86.
+ if use pic && use x86 ; then
myconf="${myconf} --disable-mmx --disable-mmx2"
fi