summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-05 04:14:49 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-05 04:14:49 +0000
commit1df395489846016f2720ae7a4a7adb5473548b92 (patch)
tree2262147428398894cea7a332d04def94e4d99421 /media-video/camstream
parentAdded a patch to resolv a gcc-3.3.x multi-line string issue; Closes Bug #30292 (diff)
downloadgentoo-2-1df395489846016f2720ae7a4a7adb5473548b92.tar.gz
gentoo-2-1df395489846016f2720ae7a4a7adb5473548b92.tar.bz2
gentoo-2-1df395489846016f2720ae7a4a7adb5473548b92.zip
Added a patch to resolv a gcc-3.3.x multi-line string issue; Closes Bug #30292
Diffstat (limited to 'media-video/camstream')
-rw-r--r--media-video/camstream/ChangeLog12
-rw-r--r--media-video/camstream/Manifest4
-rw-r--r--media-video/camstream/camstream-0.26.2.ebuild11
-rw-r--r--media-video/camstream/files/camstream-0.26.2-gcc33-multiline-string-fix.patch34
4 files changed, 55 insertions, 6 deletions
diff --git a/media-video/camstream/ChangeLog b/media-video/camstream/ChangeLog
index 6ce1fdde2180..9ea5da55fe7c 100644
--- a/media-video/camstream/ChangeLog
+++ b/media-video/camstream/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for media-video/camstream
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/ChangeLog,v 1.2 2003/04/24 13:39:54 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/ChangeLog,v 1.3 2003/10/05 04:14:46 kumba Exp $
- 24 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> camstream-0.26.2.ebuild :
- marked as stable
*camstream-0.26.2 (19 Mar 2003)
+ 04 Oct 2003; Joshua Kinard <kumba@gentoo.org> camstream-0.26.2.ebuild,
+ files/camstream-0.26.2-gcc33-multiline-string-fix.patch:
+ Added a patch that fixes a multi-line string issue w/ gcc-3.3.x.
+ Closes Bug #30292.
+
+ 24 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> camstream-0.26.2.ebuild :
+ marked as stable
+
19 Mar 2003; Patrick Kursawe <phosphan@gentoo.org> ChangeLog,
camstream-0.26.2.ebuild, files/digest-camstream-0.26.2 :
Initial import. This closes bug #13059 - let's see if it has
diff --git a/media-video/camstream/Manifest b/media-video/camstream/Manifest
index b7a5adc73385..93e34e78cdba 100644
--- a/media-video/camstream/Manifest
+++ b/media-video/camstream/Manifest
@@ -1,5 +1,5 @@
-MD5 494623a816e7648e387dabc09e9852f9 ChangeLog 822
-MD5 1fce9def0374d33d74eaa248cfc58e17 camstream-0.26.2.ebuild 932
+MD5 a070e011c99a3b24fda8f95465a38cf8 ChangeLog 819
+MD5 d0d2003a7b592156dddad1b53669380d camstream-0.26.2.ebuild 929
MD5 5ef11878179d451985ee7157a416c27e metadata.xml 222
MD5 16c80fafcb4c0feffe28ec968596af68 files/digest-camstream-0.26.2 69
MD5 442c06ba3d78db581784e3f1e3410fce files/camstream-0.26.2-gcc33-multiline-string-fix.patch 922
diff --git a/media-video/camstream/camstream-0.26.2.ebuild b/media-video/camstream/camstream-0.26.2.ebuild
index 22614be09583..160debfe535b 100644
--- a/media-video/camstream/camstream-0.26.2.ebuild
+++ b/media-video/camstream/camstream-0.26.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/camstream-0.26.2.ebuild,v 1.3 2003/09/07 00:08:12 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/camstream-0.26.2.ebuild,v 1.4 2003/10/05 04:14:46 kumba Exp $
DESCRIPTION="Collection of tools for webcams and other video devices"
HOMEPAGE="http://www.smcc.demon.nl/camstream/"
@@ -14,6 +14,15 @@ DEPEND="virtual/x11
virtual/glibc
>=x11-libs/qt-2.2.2*
"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch to fix an instance of a multi-line string which gcc-3.3.x dislikes greatly.
+ # Closes Bug #30292
+ epatch ${FILESDIR}/${P}-gcc33-multiline-string-fix.patch
+}
+
src_install () {
dobin camstream/camstream camstream/caminfo camstream/ftpput
dodir /usr/share/${PN}/icons
diff --git a/media-video/camstream/files/camstream-0.26.2-gcc33-multiline-string-fix.patch b/media-video/camstream/files/camstream-0.26.2-gcc33-multiline-string-fix.patch
new file mode 100644
index 000000000000..ded6899887d2
--- /dev/null
+++ b/media-video/camstream/files/camstream-0.26.2-gcc33-multiline-string-fix.patch
@@ -0,0 +1,34 @@
+--- ./camstream-0.26.2/camstream/ftpput.cc 2002-05-01 01:23:20.000000000 +0100
++++ ./camstream-0.26.2/camstream/ftpput.cc.patched 2003-10-04 05:26:00.000000000 +0100
+@@ -35,18 +35,19 @@
+
+ void CFTPPut::Usage()
+ {
+- qDebug("
+-Not enough/wrong arguments. Syntax:
++ qDebug("\n"
++"Not enough/wrong arguments. Syntax:\n"
++"\n\t"
++"ftpput file [options] [file ...] user:password@server[/path]\n"
++"\n"
++"The file is uploaded to the server using the FTP protocol. Path can be\n"
++"relative to the user's directory or absolute (use a double /).\n"
++"\n"
++"Options:\n\t"
++"--passive Use passive FTP to upload data\n"
++"\n"
+
+- ftpput file [options] [file ...] user:password@server[/path]
+-
+-The file is uploaded to the server using the FTP protocol. Path can be
+-relative to the user's directory or absolute (use a double /).
+-
+-Options:
+- --passive Use passive FTP to upload data
+-
+-");
++);
+ }
+
+ /**
+