summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-10-21 21:48:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-10-21 21:48:41 +0000
commit74cd80d11d7cea3cd4c4c5f11bae3ad64630a649 (patch)
tree672effac70a72d56f517f3778b05695763592e34 /media-tv
parentpvr-firmware moved to ivtv-firmware (diff)
downloadgentoo-2-74cd80d11d7cea3cd4c4c5f11bae3ad64630a649.tar.gz
gentoo-2-74cd80d11d7cea3cd4c4c5f11bae3ad64630a649.tar.bz2
gentoo-2-74cd80d11d7cea3cd4c4c5f11bae3ad64630a649.zip
adding initial ivtv-utils package which is only the utilies portion of the ivtv package since the driver is fully in the kernel with 2.6.26
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv-utils/ChangeLog11
-rw-r--r--media-tv/ivtv-utils/Manifest4
-rw-r--r--media-tv/ivtv-utils/ivtv-utils-1.3.0.ebuild107
-rw-r--r--media-tv/ivtv-utils/metadata.xml17
4 files changed, 139 insertions, 0 deletions
diff --git a/media-tv/ivtv-utils/ChangeLog b/media-tv/ivtv-utils/ChangeLog
new file mode 100644
index 000000000000..83a27b1faaa6
--- /dev/null
+++ b/media-tv/ivtv-utils/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-tv/ivtv-utils
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ChangeLog,v 1.1 2008/10/21 21:48:41 cardoe Exp $
+
+*ivtv-1.3.0 (21 Oct 2008)
+
+ 21 Oct 2008; Doug Goldstein <cardoe@gentoo.org> +metadata.xml,
+ +ivtv-utils-1.3.0.ebuild:
+ adding initial ivtv-utils package which is only the utilies portion of the
+ ivtv package since the driver is fully in the kernel with 2.6.26
+
diff --git a/media-tv/ivtv-utils/Manifest b/media-tv/ivtv-utils/Manifest
new file mode 100644
index 000000000000..5b868db6d1cb
--- /dev/null
+++ b/media-tv/ivtv-utils/Manifest
@@ -0,0 +1,4 @@
+DIST ivtv-utils-1.3.0.tar.gz 173745 RMD160 b42572277babd840868adb641d8434b180d43315 SHA1 bc4d7003ce9fb75ee137e8f79c880e4fb45d1137 SHA256 66daf16ae2f124e31131451e52295072c2615d9931a95f7eccee58c5351af498
+EBUILD ivtv-utils-1.3.0.ebuild 3311 RMD160 595c636b9c337a879ef4e398f4dc832f04198ab2 SHA1 24c20974df3180ec12f9df49c9269a17a63ad9f2 SHA256 c8c5fe049043295b16b0858b9272a28e4d9b2355dc0135c07b0c0851d331a48d
+MISC ChangeLog 385 RMD160 5592d6e96f385d7996a09ace22c82a578cc14f32 SHA1 7f190638d6489719f6e4f70263837b4566a17702 SHA256 ab543e7650c6964510559c8613cf1eedfe3a729a2656103a6930b11a5763b78c
+MISC metadata.xml 494 RMD160 a8c45c9e2ad783198d04b68c755398d915270499 SHA1 1a04f1e7b3be80d5a875559fddbc5b681ba9254b SHA256 99e7a214b2abd11188552236eb67309ccde04d0a66209ed0fd48589eed258bb4
diff --git a/media-tv/ivtv-utils/ivtv-utils-1.3.0.ebuild b/media-tv/ivtv-utils/ivtv-utils-1.3.0.ebuild
new file mode 100644
index 000000000000..4db9293d0556
--- /dev/null
+++ b/media-tv/ivtv-utils/ivtv-utils-1.3.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ivtv-utils-1.3.0.ebuild,v 1.1 2008/10/21 21:48:41 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.3.x/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl"
+RDEPEND=">=sys-fs/udev-103"
+DEPEND="app-arch/unzip"
+PDEPEND=">=media-tv/ivtv-firmware-20070217
+ perl? (
+ dev-perl/Video-Frequencies
+ dev-perl/Video-ivtv
+ dev-perl/Config-IniFiles
+ virtual/perl-Getopt-Long
+ dev-perl/perl-tk )"
+
+pkg_setup() {
+
+ MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
+ VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
+
+ if ! ( kernel_is ge 2 6 26 ); then
+ eerror "This package is only for the fully in-kernel"
+ eerror "IVTV driver shipping with kernel 2.6.26 and higher"
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge ivtv"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ die "This only works on 2.6.26 and newer kernels"
+ fi
+
+ ewarn ""
+ ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
+ ewarn "modules, and not compiled into the kernel, or IVTV will not"
+ ewarn "work."
+ ewarn ""
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_compile() {
+ emake || die "failed to build"
+}
+
+src_install() {
+ make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install"
+ use perl && dobin perl/*.pl
+
+ cd "${S}"
+ dodoc README doc/* ChangeLog
+ use perl && dodoc utils/perl/README.ptune
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This version of the IVTV utils supports the following hardware:"
+ elog "Hauppauge WinTV PVR-250"
+ elog "Hauppauge WinTV PVR-350"
+ elog "Hauppauge WinTV PVR-150"
+ elog "Hauppauge WinTV PVR-500"
+ elog "AVerMedia M179"
+ elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
+ elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
+ elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
+ elog "Adaptec AVC-2410"
+ elog "Adaptec AVC-2010"
+ elog "Nagase Transgear 5000TV"
+ elog "AOpen VA2000MAX-STN6"
+ elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
+ elog "I/O Data GV-MVP/RX"
+ elog "I/O Data GV-MVP/RX2E"
+ elog "Gotview PCI DVD (preliminary support only)"
+ elog "Gotview PCI DVD2 Deluxe"
+ elog "Yuan MPC622"
+ elog ""
+ ewarn ""
+ ewarn "IMPORTANT: In case of problems first read this page:"
+ ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
+ ewarn ""
+ ewarn "If any of these conditions match your setup, you may want to look at the"
+ ewarn "README in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn " - Using MythTV, a PVR-350 and the ivtvfb module"
+ ewarn " - Using the ivtv X driver and the ivtvfb module"
+ ewarn " - You want to manually build ivtv against v4l-dvb"
+ ewarn ""
+ ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
+ ewarn "proper use and debugging utilities."
+ ewarn "They are also located in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn "For more information, see the IVTV driver homepage at:"
+ ewarn "http://www.ivtvdriver.org/"
+}
diff --git a/media-tv/ivtv-utils/metadata.xml b/media-tv/ivtv-utils/metadata.xml
new file mode 100644
index 000000000000..bc08cc5122ae
--- /dev/null
+++ b/media-tv/ivtv-utils/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>beandog@gentoo.org</email>
+ <name>Steve Dibb</name>
+ </maintainer>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <longdescription>
+ Driver for ivtv based tv tuner cards, currently supports Hauppauge
+ PVR-[23]50 cards
+ </longdescription>
+</pkgmetadata>