summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-18 16:46:36 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-18 16:46:36 +0000
commit621d69799b759a135357ab7c07959c198b6bebec (patch)
treef8402b760a339dc66e91f851d04dee994bfa2810 /media-tv
parentUpdate homepage url (diff)
downloadgentoo-2-621d69799b759a135357ab7c07959c198b6bebec.tar.gz
gentoo-2-621d69799b759a135357ab7c07959c198b6bebec.tar.bz2
gentoo-2-621d69799b759a135357ab7c07959c198b6bebec.zip
Punt older versions with random build problems.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xbmc/ChangeLog6
-rw-r--r--media-tv/xbmc/files/xbmc-9.04-gcc.patch80
-rw-r--r--media-tv/xbmc/xbmc-9.04.1.ebuild145
-rw-r--r--media-tv/xbmc/xbmc-9.04.ebuild144
4 files changed, 5 insertions, 370 deletions
diff --git a/media-tv/xbmc/ChangeLog b/media-tv/xbmc/ChangeLog
index 4b5a80b9c32f..82b45a9e0722 100644
--- a/media-tv/xbmc/ChangeLog
+++ b/media-tv/xbmc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/xbmc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.37 2009/12/15 12:41:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.38 2009/12/18 16:46:36 vapier Exp $
+
+ 18 Dec 2009; Mike Frysinger <vapier@gentoo.org> -xbmc-9.04.ebuild,
+ -xbmc-9.04.1.ebuild, -files/xbmc-9.04-gcc.patch:
+ Punt older versions with random build problems.
15 Dec 2009; Mike Frysinger <vapier@gentoo.org> xbmc-9999.ebuild:
Regen libbdnav autotools when needed #296792 by Martin Berkemeier.
diff --git a/media-tv/xbmc/files/xbmc-9.04-gcc.patch b/media-tv/xbmc/files/xbmc-9.04-gcc.patch
deleted file mode 100644
index f2adaca02b2a..000000000000
--- a/media-tv/xbmc/files/xbmc-9.04-gcc.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-fix build error with gcc-4.4
-
---- xbmc/visualizations/XBMCProjectM/libprojectM/BuiltinParams.cpp
-+++ xbmc/visualizations/XBMCProjectM/libprojectM/BuiltinParams.cpp
-@@ -1,3 +1,4 @@
-+#include <stdio.h>
-
- #include "fatal.h"
- #include "BuiltinParams.hpp"
-
-http://xbmc.org/trac/ticket/6627
-
---- xbmc/cores/DllLoader/exports/exports_msvcrt.cpp
-+++ xbmc/cores/DllLoader/exports/exports_msvcrt.cpp
-@@ -307,6 +307,14 @@
- extern "C" void* track_fopen();
- extern "C" void* track_freopen();
-
-+#if (__GNUC__ >= 4 && __GNUC_MINOR__ >= 4)
-+#define strchr __builtin_strchr
-+#define strrchr __builtin_strrchr
-+#define strpbrk __builtin_strpbrk
-+#define strstr __builtin_strstr
-+#define memchr __builtin_memchr
-+#endif
-+
- Export export_msvcrt[] =
- {
- { "_close", -1, (void*)dll_close, (void*)track_close},
-
---- tools/XBMCTex/XBMCTex.cpp
-+++ tools/XBMCTex/XBMCTex.cpp
-@@ -659,7 +659,7 @@
- valid = true;
- #ifdef _LINUX
- char *c = NULL;
-- while ((c = strchr(OutputFilename, '\\')) != NULL) *c = '/';
-+ while ((c = (char *)strchr(OutputFilename, '\\')) != NULL) *c = '/';
- #endif
- }
- else if (!stricmp(args[i], "-noprotect") || !stricmp(args[i], "-p"))
-
---- xbmc/cores/paplayer/MACDll/Source/MACLib/APELink.cpp
-+++ xbmc/cores/paplayer/MACDll/Source/MACLib/APELink.cpp
-@@ -55,10 +55,10 @@
- if (pData != NULL)
- {
- // parse out the information
-- char * pHeader = strstr(pData, APE_LINK_HEADER);
-- char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
-- char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
-- char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
-+ const char * pHeader = strstr(pData, APE_LINK_HEADER);
-+ const char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
-+ const char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
-+ const char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
-
- if (pHeader && pImageFile && pStartBlock && pFinishBlock)
- {
-@@ -73,7 +73,7 @@
-
- // get the path
- char cImageFile[MAX_PATH + 1]; int nIndex = 0;
-- char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
-+ const char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
- while ((*pImageCharacter != 0) && (*pImageCharacter != '\r') && (*pImageCharacter != '\n'))
- cImageFile[nIndex++] = *pImageCharacter++;
- cImageFile[nIndex] = 0;
-
---- xbmc/lib/cximage-6.0/CxImage/DllInterface.cpp
-+++ xbmc/lib/cximage-6.0/CxImage/DllInterface.cpp
-@@ -51,7 +51,7 @@
- // helper functions
- DWORD GetImageType(const char *file)
- { // determines based on file extension the type of file
-- char *ext = (char *)file + strlen(file) - 1;
-+ const char *ext = file + strlen(file) - 1;
- while (ext > file)
- {
- if (*ext == '.')
diff --git a/media-tv/xbmc/xbmc-9.04.1.ebuild b/media-tv/xbmc/xbmc-9.04.1.ebuild
deleted file mode 100644
index ba42ce20b7f1..000000000000
--- a/media-tv/xbmc/xbmc-9.04.1.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9.04.1.ebuild,v 1.3 2009/09/26 12:11:40 vapier Exp $
-
-# XXX: be nice to split out packages that come bundled and use the
-# system libraries ...
-
-EAPI="2"
-
-inherit eutils
-
-# Use XBMC_ESVN_REPO_URI to track a different branch
-ESVN_REPO_URI=${XBMC_ESVN_REPO_URI:-http://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk}
-ESVN_PROJECT=${ESVN_REPO_URI##*/svnroot/}
-ESVN_PROJECT=${ESVN_PROJECT%/*}
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- KEYWORDS=""
-else
- MY_P="${PV}_Babylon-linux-osx-win32"
- SRC_URI="mirror://sourceforge/${PN}/XBMC%20Source%20Code/Babylon%20-%209.04/${MY_P}-repack.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/${MY_P}/XBMC
-fi
-
-DESCRIPTION="XBMC is a free and open source media-player and entertainment hub"
-HOMEPAGE="http://xbmc.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="alsa debug joystick opengl profile pulseaudio vdpau"
-
-RDEPEND="opengl? ( virtual/opengl )
- app-arch/bzip2
- || ( app-arch/unrar app-arch/unrar-gpl )
- app-arch/unzip
- app-arch/zip
- app-i18n/enca
- >=dev-lang/python-2.4
- dev-libs/boost
- dev-libs/fribidi
- dev-libs/libcdio
- dev-libs/libpcre
- dev-libs/lzo
- >=dev-python/pysqlite-2
- media-libs/alsa-lib
- media-libs/faac
- media-libs/fontconfig
- media-libs/freetype
- media-libs/glew
- media-libs/jasper
- media-libs/libmad
- media-libs/libogg
- media-libs/libsamplerate
- media-libs/libsdl[alsa,audio,video,X]
- media-libs/libvorbis
- media-libs/sdl-gfx
- media-libs/sdl-image[gif,jpeg,png]
- media-libs/sdl-mixer
- media-libs/sdl-sound
- net-misc/curl
- sys-apps/dbus
- sys-apps/hal
- sys-apps/pmount
- virtual/mysql
- x11-apps/xdpyinfo
- x11-apps/mesa-progs
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender"
-DEPEND="${RDEPEND}
- x11-proto/xineramaproto
- dev-util/cmake
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-9.04-gcc.patch
-
- # Avoid help2man
- sed -i \
- -e '/HELP2MAN.*--output/s:.*:\ttouch $@:' \
- xbmc/lib/libcdio/libcdio/src/Makefile.in
-
- # Tweak autotool timestamps to avoid regeneration
- find . '(' -name configure -o -name configure2 -o -name '*.pl' ')' -exec chmod a+rx {} +
- find . -type f -exec touch -r configure {} +
-
- # Fix XBMC's final version string showing as "exported"
- # instead of the SVN revision number. Also cleanup flags.
- export SVN_REV=${ESVN_WC_REVISION:-exported}
- sed -i -r -e '/DEBUG_FLAGS/s:-(g|O2)::' configure
- sed -i -e 's:\<strip\>:echo:' xbmc/lib/libhdhomerun/Makefile.in
- # Avoid lsb-release dependency
- sed -i \
- -e 's:/usr/bin/lsb_release -d:cat /etc/gentoo-release:' \
- xbmc/utils/SystemInfo.cpp
-
- # Fix case sensitivity
- mv media/Fonts/{a,A}rial.ttf
- mv media/{S,s}plash.png
-
- # Do not use termcap #262822
- sed -i 's:-ltermcap::' xbmc/lib/libPython/Python/configure
-
- # Unzip web content
- cd web
- unpack ./Project_Mayhem_III_webserver_*.zip
-}
-
-src_configure() {
- # Disable documentation generation
- export ac_cv_path_LATEX=no
-
- econf \
- --disable-ccache \
- --disable-optimizations \
- $(use_enable debug) \
- $(use_enable joystick) \
- $(use_enable opengl gl) \
- $(use_enable profile profiling) \
- $(use_enable pulseaudio pulse) \
- $(use_enable vdpau)
-}
-
-src_install() {
- einstall || die "Install failed!"
-
- insinto /usr/share/applications
- doins tools/Linux/xbmc.desktop
- doicon tools/Linux/xbmc.png
-
- dodoc README.linux known_issues.txt
- rm "${D}"/usr/share/xbmc/{README.linux,LICENSE.GPL,*.txt}
-}
-
-pkg_postinst() {
- elog "Visit http://xbmc.org/wiki/?title=XBMC_Online_Manual"
-}
diff --git a/media-tv/xbmc/xbmc-9.04.ebuild b/media-tv/xbmc/xbmc-9.04.ebuild
deleted file mode 100644
index 603546086155..000000000000
--- a/media-tv/xbmc/xbmc-9.04.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9.04.ebuild,v 1.5 2009/09/26 12:11:40 vapier Exp $
-
-# XXX: be nice to split out packages that come bundled and use the
-# system libraries ...
-
-EAPI="2"
-
-inherit eutils
-
-# Use XBMC_ESVN_REPO_URI to track a different branch
-ESVN_REPO_URI=${XBMC_ESVN_REPO_URI:-http://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk}
-ESVN_PROJECT=${ESVN_REPO_URI##*/svnroot/}
-ESVN_PROJECT=${ESVN_PROJECT%/*}
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- KEYWORDS=""
-else
- MY_P="XBMC_${PV}_Babylon-linux-osx-win32"
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/${MY_P}
-fi
-
-DESCRIPTION="XBMC is a free and open source media-player and entertainment hub"
-HOMEPAGE="http://xbmc.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="alsa debug joystick opengl profile pulseaudio vdpau"
-
-RDEPEND="opengl? ( virtual/opengl )
- app-arch/bzip2
- || ( app-arch/unrar app-arch/unrar-gpl )
- app-arch/unzip
- app-arch/zip
- app-i18n/enca
- >=dev-lang/python-2.4
- dev-libs/boost
- dev-libs/fribidi
- dev-libs/libcdio
- dev-libs/libpcre
- dev-libs/lzo
- >=dev-python/pysqlite-2
- media-libs/alsa-lib
- media-libs/faac
- media-libs/fontconfig
- media-libs/freetype
- media-libs/glew
- media-libs/jasper
- media-libs/libmad
- media-libs/libogg
- media-libs/libsamplerate
- media-libs/libsdl[alsa,audio,video,X]
- media-libs/libvorbis
- media-libs/sdl-gfx
- media-libs/sdl-image[gif,jpeg,png]
- media-libs/sdl-mixer
- media-libs/sdl-sound
- net-misc/curl
- sys-apps/dbus
- sys-apps/hal
- sys-apps/pmount
- virtual/mysql
- x11-apps/xdpyinfo
- x11-apps/mesa-progs
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender"
-DEPEND="${RDEPEND}
- x11-proto/xineramaproto
- dev-util/cmake
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc.patch
-
- # Avoid help2man
- sed -i \
- -e '/HELP2MAN.*--output/s:.*:\ttouch $@:' \
- xbmc/lib/libcdio/libcdio/src/Makefile.in
-
- # Tweak autotool timestamps to avoid regeneration
- find . -type f -print0 | xargs -0 touch -r configure
-
- # Fix XBMC's final version string showing as "exported"
- # instead of the SVN revision number. Also cleanup flags.
- export SVN_REV=${ESVN_WC_REVISION:-exported}
- sed -i -r -e '/DEBUG_FLAGS/s:-(g|O2)::' configure
- sed -i -e 's:\<strip\>:echo:' xbmc/lib/libhdhomerun/Makefile.in
- # Avoid lsb-release dependency
- sed -i \
- -e 's:/usr/bin/lsb_release -d:cat /etc/gentoo-release:' \
- xbmc/utils/SystemInfo.cpp
-
- # Fix case sensitivity
- mv media/Fonts/{a,A}rial.ttf
- mv media/{S,s}plash.png
-
- # Do not use termcap #262822
- sed -i 's:-ltermcap::' xbmc/lib/libPython/Python/configure
-
- # Unzip web content
- cd web
- unpack ./Project_Mayhem_III_webserver_*.zip
-}
-
-src_configure() {
- # Disable documentation generation
- export ac_cv_path_LATEX=no
-
- econf \
- --disable-ccache \
- --disable-optimizations \
- $(use_enable debug) \
- $(use_enable joystick) \
- $(use_enable opengl gl) \
- $(use_enable profile profiling) \
- $(use_enable pulseaudio pulse) \
- $(use_enable vdpau)
-}
-
-src_install() {
- einstall || die "Install failed!"
-
- insinto /usr/share/applications
- doins tools/Linux/xbmc.desktop
- doicon tools/Linux/xbmc.png
-
- dodoc README.linux known_issues.txt
- rm "${D}"/usr/share/xbmc/{README.linux,LICENSE.GPL,*.txt}
-}
-
-pkg_postinst() {
- elog "Visit http://xbmc.org/wiki/?title=XBMC_Online_Manual"
-}