summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-04 05:21:56 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-04 05:21:56 +0000
commitf056b58f41a49bba0568e401efe66cd3cc4de2e4 (patch)
tree5700598194f9c85cbb90da5e0c4b788a442d2ecd /media-sound
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-f056b58f41a49bba0568e401efe66cd3cc4de2e4.tar.gz
gentoo-2-f056b58f41a49bba0568e401efe66cd3cc4de2e4.tar.bz2
gentoo-2-f056b58f41a49bba0568e401efe66cd3cc4de2e4.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rosegarden/ChangeLog9
-rw-r--r--media-sound/rosegarden/rosegarden-14.12.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/media-sound/rosegarden/ChangeLog b/media-sound/rosegarden/ChangeLog
index d2956b5bf25c..2d8ef5697b70 100644
--- a/media-sound/rosegarden/ChangeLog
+++ b/media-sound/rosegarden/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/rosegarden
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/ChangeLog,v 1.117 2014/03/08 23:23:05 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/ChangeLog,v 1.118 2015/01/04 05:21:56 radhermit Exp $
+
+*rosegarden-14.12 (04 Jan 2015)
+
+ 04 Jan 2015; Tim Harder <radhermit@gentoo.org> +rosegarden-14.12.ebuild:
+ Version bump.
08 Mar 2014; Tim Harder <radhermit@gentoo.org> -rosegarden-13.06.ebuild,
-rosegarden-13.10.ebuild:
diff --git a/media-sound/rosegarden/rosegarden-14.12.ebuild b/media-sound/rosegarden/rosegarden-14.12.ebuild
new file mode 100644
index 000000000000..0875dd609939
--- /dev/null
+++ b/media-sound/rosegarden/rosegarden-14.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/rosegarden-14.12.ebuild,v 1.1 2015/01/04 05:21:56 radhermit Exp $
+
+EAPI=5
+inherit autotools eutils fdo-mime gnome2-utils multilib
+
+DESCRIPTION="MIDI and audio sequencer and notation editor"
+HOMEPAGE="http://www.rosegardenmusic.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug lirc"
+
+RDEPEND="dev-qt/qtgui:4
+ media-libs/ladspa-sdk:=
+ x11-libs/libSM:=
+ media-sound/jack-audio-connection-kit:=
+ media-libs/alsa-lib:=
+ >=media-libs/dssi-1.0.0:=
+ media-libs/liblo:=
+ media-libs/liblrdf:=
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate:=[sndfile]
+ lirc? ( app-misc/lirc:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-misc/makedepend"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-12.12.25-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ export USER_CXXFLAGS="${CXXFLAGS}"
+
+ export ac_cv_header_lirc_lirc_client_h=$(usex lirc)
+ export ac_cv_lib_lirc_client_lirc_init=$(usex lirc)
+
+ econf \
+ $(use_enable debug) \
+ --with-qtdir=/usr \
+ --with-qtlibdir=/usr/$(get_libdir)/qt4
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}