summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-17 20:46:13 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-17 20:46:13 +0000
commit99b54ca3e2b7dba68df62bcfccdd07204f7a940c (patch)
tree71c1a882c1a39cb3a976d68b6ba9ae490e5b551f /media-sound
parentDrop epunt_cxx as this no longer needs it. (diff)
downloadgentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.tar.gz
gentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.tar.bz2
gentoo-2-99b54ca3e2b7dba68df62bcfccdd07204f7a940c.zip
Revision bump: EAPI 5, add missing lilypond tremolo export patch, wrt bug #437540 and #457400
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/nted/ChangeLog11
-rw-r--r--media-sound/nted/files/nted-1.10.18-lilypond-tremolo.patch45
-rw-r--r--media-sound/nted/nted-1.10.18-r2.ebuild50
3 files changed, 104 insertions, 2 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index 7b3c8a828ad7..84fc6531f73e 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/nted
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.29 2012/11/09 20:05:16 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.30 2013/02/17 20:46:13 pinkbyte Exp $
+
+*nted-1.10.18-r2 (17 Feb 2013)
+
+ 17 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +nted-1.10.18-r2.ebuild,
+ +files/nted-1.10.18-lilypond-tremolo.patch:
+ Revision bump: EAPI 5, add missing lilypond tremolo export patch, wrt bug
+ #437540 and #457400
*nted-1.10.18-r1 (09 Nov 2012)
diff --git a/media-sound/nted/files/nted-1.10.18-lilypond-tremolo.patch b/media-sound/nted/files/nted-1.10.18-lilypond-tremolo.patch
new file mode 100644
index 000000000000..a3c46c849a0e
--- /dev/null
+++ b/media-sound/nted/files/nted-1.10.18-lilypond-tremolo.patch
@@ -0,0 +1,45 @@
+From 161e7cf6d2f0f18e9b44ef9ce960efb07c210c79 Mon Sep 17 00:00:00 2001
+From: Christopher Harvey <chris@basementcode.com>
+Date: Sun, 7 Oct 2012 15:41:00 -0400
+Subject: [PATCH] Fix LilyPond tremolo dotted chord export
+
+For example, NtEd would export "< a f' >4:8.", but the correct syntax
+is "< a f' >4.:8"
+---
+ chordorrest.cpp | 13 ++++++-------
+ 1 files changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/chordorrest.cpp b/chordorrest.cpp
+index cd93dab..9367f32 100644
+--- a/chordorrest.cpp
++++ b/chordorrest.cpp
+@@ -3821,6 +3821,10 @@ void NedChordOrRest::exportLilyPond(FILE *fp, int *last_line, unsigned int *midi
+ fprintf(fp, " >");
+ }
+ if (duration != *midi_len || (m_status & TREMOLO_MASK)) {
++ sprintf(Str, "%d", WHOLE_NOTE / m_length);
++ for (i = 0; i < m_dot_count; i++) {
++ strcat(Str, ".");
++ }
+ if (m_status & TREMOLO_MASK) {
+ switch (m_status & TREMOLO_MASK) {
+ case STAT_TREMOLO1: tremolo = 8; break;
+@@ -3828,13 +3832,8 @@ void NedChordOrRest::exportLilyPond(FILE *fp, int *last_line, unsigned int *midi
+ case STAT_TREMOLO3: tremolo = 32; break;
+ case STAT_TREMOLO4: tremolo = 64; break;
+ }
+- sprintf(Str, "%d:%d", WHOLE_NOTE / m_length, tremolo);
+- }
+- else {
+- sprintf(Str, "%d", WHOLE_NOTE / m_length);
+- }
+- for (i = 0; i < m_dot_count; i++) {
+- strcat(Str, ".");
++ sprintf(Str2, ":%d", tremolo);
++ strcat(Str, &Str2[0]);
+ }
+ force_length = true;
+ }
+--
+1.7.8.6
+
diff --git a/media-sound/nted/nted-1.10.18-r2.ebuild b/media-sound/nted/nted-1.10.18-r2.ebuild
new file mode 100644
index 000000000000..9dc29eacf1e2
--- /dev/null
+++ b/media-sound/nted/nted-1.10.18-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18-r2.ebuild,v 1.1 2013/02/17 20:46:13 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2 NTED_FONT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug nls"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ >=media-libs/freetype-2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README )
+
+src_prepare() {
+ # bug #424291
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ # bug #437540
+ epatch "${FILESDIR}"/${P}-lilypond.patch
+ epatch "${FILESDIR}"/${P}-lilypond-tremolo.patch
+}
+
+src_configure() {
+ # Trick ./configure to believe we have gnome-extra/yelp installed.
+ has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with doc)
+}