summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-07-11 23:11:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-07-11 23:11:00 +0000
commit457101d94b1f67b1285ed64a88a269d8b2bff388 (patch)
treeaef1810f04f0d51648c387d5630476b7a974d727 /media-sound
parentTruckload of bug fixes. And wait until you see the GTKui. It had some work done. (diff)
downloadgentoo-2-457101d94b1f67b1285ed64a88a269d8b2bff388.tar.gz
gentoo-2-457101d94b1f67b1285ed64a88a269d8b2bff388.tar.bz2
gentoo-2-457101d94b1f67b1285ed64a88a269d8b2bff388.zip
New alpha release with a truckload of bug fixes.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-2.4_alpha3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 6fb63709947c..3ed08eb92f9a 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.204 2010/06/25 11:15:11 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.205 2010/07/11 23:11:00 chainsaw Exp $
+
+*audacious-2.4_alpha3 (11 Jul 2010)
+
+ 11 Jul 2010; <chainsaw@gentoo.org> +audacious-2.4_alpha3.ebuild:
+ New alpha release with a truckload of bug fixes.
*audacious-2.4_alpha2 (25 Jun 2010)
diff --git a/media-sound/audacious/audacious-2.4_alpha3.ebuild b/media-sound/audacious/audacious-2.4_alpha3.ebuild
new file mode 100644
index 000000000000..040da87fe2e5
--- /dev/null
+++ b/media-sound/audacious/audacious-2.4_alpha3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.4_alpha3.ebuild,v 1.1 2010/07/11 23:11:00 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet debug nls session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.4_alpha3"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}