summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-24 00:05:15 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-24 00:05:15 +0000
commit258bdfdb7bdc1070500f08e3bbfb10a068ba59d8 (patch)
treedf7b431b10c36072c109197742f383602f9d641a /media-sound
parentdigest (diff)
downloadgentoo-2-258bdfdb7bdc1070500f08e3bbfb10a068ba59d8.tar.gz
gentoo-2-258bdfdb7bdc1070500f08e3bbfb10a068ba59d8.tar.bz2
gentoo-2-258bdfdb7bdc1070500f08e3bbfb10a068ba59d8.zip
updated to latest version, added gnome to deps if gnome is in USE, fixed #267
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/files/digest-grip-2.96-r31
-rw-r--r--media-sound/grip/files/digest-grip-2.98.31
-rw-r--r--media-sound/grip/grip-2.96-r3.ebuild57
-rw-r--r--media-sound/grip/grip-2.98.3.ebuild53
4 files changed, 54 insertions, 58 deletions
diff --git a/media-sound/grip/files/digest-grip-2.96-r3 b/media-sound/grip/files/digest-grip-2.96-r3
deleted file mode 100644
index d5a072a5874d..000000000000
--- a/media-sound/grip/files/digest-grip-2.96-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 93bd9c4672a8d53daf32772812e624d8 grip-2.96.tgz 118784
diff --git a/media-sound/grip/files/digest-grip-2.98.3 b/media-sound/grip/files/digest-grip-2.98.3
new file mode 100644
index 000000000000..38bd0a93c51d
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-2.98.3
@@ -0,0 +1 @@
+MD5 d7bffaad244fc091f3e4eb3bb39a1e65 grip-2.98.3.tar.gz 782336
diff --git a/media-sound/grip/grip-2.96-r3.ebuild b/media-sound/grip/grip-2.96-r3.ebuild
deleted file mode 100644
index 388d21497f83..000000000000
--- a/media-sound/grip/grip-2.96-r3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Bruce A. Locke <blocke@shivan.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-2.96-r3.ebuild,v 1.1 2001/10/26 01:55:54 lordjoe Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GTK+ based Audio CD Ripper"
-SRC_URI="http://www.nostatic.org/grip/${P}.tgz"
-HOMEPAGE="http://www.nostatic.org/grip"
-
-DEPEND="media-sound/cdparanoia
- virtual/x11"
-
-src_compile() {
-
- # grip doesn't have a nice configure script and requires some
- # symlink love to build
-
- cd ${S}
-
- mkdir cdparanoia
- mkdir cdparanoia/interface
- mkdir cdparanoia/paranoia
- ln -s /usr/lib/libcdda* cdparanoia/interface/
- ln -s /usr/lib/libcdda* cdparanoia/paranoia/
- ln -s /usr/include/*cdda* cdparanoia/interface/
- ln -s /usr/include/*cdda* cdparanoia/paranoia/
- ln -s /usr/include/utils.h cdparanoia/utils.h
-
- # apply CFLAGS
- mv Makefile Makefile.old
- sed -e "s/-Wall/-Wall ${CFLAGS}/" Makefile.old > Makefile
-
- emake || die
-
-}
-
-src_install () {
- cd ${S}
-
- dodir /usr/bin
-
- cp ${S}/grip ${D}/usr/bin
- cp ${S}/gcd ${D}/usr/bin
-
- dodir /usr/man/man1
-
- gzip ${S}/grip.1
- cp ${S}/grip.1.gz ${D}/usr/man/man1
- cp ${S}/grip.1.gz ${D}/usr/man/man1/gcd.1.gz
-
- dodoc README LICENSE TODO CREDITS CHANGES
-
- insinto /usr/include/X11/pixmaps
- doins pixmaps/*.xpm
-
-}
diff --git a/media-sound/grip/grip-2.98.3.ebuild b/media-sound/grip/grip-2.98.3.ebuild
new file mode 100644
index 000000000000..5f385aad52ee
--- /dev/null
+++ b/media-sound/grip/grip-2.98.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-2.98.3.ebuild,v 1.1 2002/01/24 00:05:15 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based Audio CD Ripper"
+SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
+HOMEPAGE="http://www.nostatic.org/grip"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib
+ virtual/x11
+ gnome? ( gnome-base/gnome-libs
+ gnome-base/ORBit
+ gnome-base/libghttp )"
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # apply CFLAGS
+ mv Makefile.in Makefile.in.old
+ sed -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+ Makefile.in.old > Makefile.in
+
+ # fix cdparanoia libs not linking
+ mv src/Makefile.in src/Makefile.in.orig
+ sed -e "s/LDFLAGS =/LDFLAGS = -lcdda_interface -lcdda_paranoia/" \
+ src/Makefile.in.orig > src/Makefile.in
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS CREDITS LICENSE CHANGES README TODO
+}