summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-12-22 13:47:03 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-12-22 13:47:03 +0000
commit0ef005e6c1da3c0255b34e354feaad1e14d5a657 (patch)
treed8fded3ded3bce1aadd8d3e9db6248f57190b4c7 /media-sound
parentStable on ppc wrt bug 202458 (diff)
downloadgentoo-2-0ef005e6c1da3c0255b34e354feaad1e14d5a657.tar.gz
gentoo-2-0ef005e6c1da3c0255b34e354feaad1e14d5a657.tar.bz2
gentoo-2-0ef005e6c1da3c0255b34e354feaad1e14d5a657.zip
version bump thanks to Geert Lamers <biert85@gmail.com> in bug 202861
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lastfmplayer/ChangeLog8
-rw-r--r--media-sound/lastfmplayer/files/digest-lastfmplayer-1.4.1.574863
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-mad-asneeded.patch11
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.4.1.57486.ebuild89
4 files changed, 110 insertions, 1 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index a78aa12597ab..d394aa26bff4 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.24 2007/11/16 08:42:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.25 2007/12/22 13:47:02 genstef Exp $
+
+*lastfmplayer-1.4.1.57486 (22 Dec 2007)
+
+ 22 Dec 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/lastfmplayer-mad-asneeded.patch, +lastfmplayer-1.4.1.57486.ebuild:
+ version bump thanks to Geert Lamers <biert85@gmail.com> in bug 202861
*lastfmplayer-1.3.2.13 (16 Nov 2007)
diff --git a/media-sound/lastfmplayer/files/digest-lastfmplayer-1.4.1.57486 b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.4.1.57486
new file mode 100644
index 000000000000..ee12c43b38ca
--- /dev/null
+++ b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.4.1.57486
@@ -0,0 +1,3 @@
+MD5 a400524adb4dfac28495669d8ff17379 last.fm-1.4.1.57486.src.tar.bz2 7300175
+RMD160 358e2967773db790143ff5fd13485fc7e9351543 last.fm-1.4.1.57486.src.tar.bz2 7300175
+SHA256 2e75d8526f50ae076d93768a378a2a7bb82714159704701cc754a52c71628760 last.fm-1.4.1.57486.src.tar.bz2 7300175
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-mad-asneeded.patch b/media-sound/lastfmplayer/files/lastfmplayer-mad-asneeded.patch
new file mode 100644
index 000000000000..b55548ec8433
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-mad-asneeded.patch
@@ -0,0 +1,11 @@
+--- last.fm-1.4.1.57486/src/libFingerprint/libFingerprint.pro.orig 2007-12-22 13:08:59.000000000 +0100
++++ last.fm-1.4.1.57486/src/libFingerprint/libFingerprint.pro 2007-12-22 13:09:23.000000000 +0100
+@@ -40,7 +40,7 @@
+
+ unix:!mac {
+ LIBPATH += $$BUILD_DIR/../fplib
+- LIBS += $$ROOT_DIR/build/fplib/libfplib$${EXT}.a -lsamplerate -lfftw3f
++ LIBS += $$ROOT_DIR/build/fplib/libfplib$${EXT}.a -lsamplerate -lfftw3f -lmad
+ }
+
+ win32 {
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.4.1.57486.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.4.1.57486.ebuild
new file mode 100644
index 000000000000..796c51d67fdb
--- /dev/null
+++ b/media-sound/lastfmplayer/lastfmplayer-1.4.1.57486.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.4.1.57486.ebuild,v 1.1 2007/12/22 13:47:02 genstef Exp $
+
+inherit eutils qt4
+
+MY_P="${P/lastfmplayer/last.fm}"
+
+DESCRIPTION="The player allows you to listen to last.fm radio streams"
+HOMEPAGE="http://www.last.fm/help/player"
+SRC_URI="http://cdn.last.fm/client/src/${MY_P}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND="$(qt4_min_version 4.2)
+ media-libs/libsamplerate
+ sci-libs/fftw
+ media-libs/libmad
+ media-libs/libgpod
+ media-libs/alsa-lib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/lastfmplayer-mad-asneeded.patch
+}
+
+src_compile() {
+# eqmake4 LastFM.pro
+# for subdir in src src/httpinput src/mp3transcode \
+# src/output/alsa-playback src/output/portAudio ; do
+# eqmake4 "${subdir}/${subdir##*/}.pro" -o ${subdir}/Makefile
+# done
+ ./configure
+ emake || die "emake failed"
+}
+
+src_install() {
+ # Docs
+ dodoc ChangeLog README
+
+ # The root at which the player, data, and cache
+ # are to be installed
+ local destination="/usr/share/lastfm"
+ cd bin
+
+ # Make ${destination} writable by audio group
+ diropts -m0775 -g audio
+ dodir ${destination}
+
+ # Install the player
+ cp -R * "${D}"/${destination}
+
+ # Make a folder such that album art cache works
+ diropts -m0775 -g audio
+ dodir ${destination}/cache
+ keepdir ${destination}/cache
+
+ # Icon, menu, protcol
+ make_wrapper lastfm ./last.fm ${destination} ${destination}
+ newicon data/icons/as.png lastfm.png
+ make_desktop_entry lastfm "Last.fm Player" lastfm.png
+
+ # make sure no hanging instance of lastfm is running
+ sed -i -e 's:exec:if ! ps aux | grep "^$USER.*last.fm.app" | grep Sl >/dev/null 2>\&1; \
+ then killall -u $USER last.fm.app >/dev/null 2>\&1; fi\nexec:' \
+ "${D}"/usr/bin/lastfm
+
+ insinto /usr/share/services
+ doins "${FILESDIR}"/lastfm.protocol
+}
+
+pkg_postinst() {
+ elog "To use the Last.fm player with a mozilla based browser:"
+ elog " 1. Go to about:config in the browser"
+ elog " 2. Right-click on the page"
+ elog " 3. Select New and then String"
+ elog " 4. For the name: network.protocol-handler.app.lastfm"
+ elog " 5. For the value: /usr/bin/lastfm"
+ elog
+ elog "If you experience awkward fonts or widgets, try running qtconfig."
+}