summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-21 15:00:52 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-21 15:00:52 +0000
commit091c0eb4e16d19694141e6b51b0a1dcba16c7ef5 (patch)
tree64752115baccce58cf8fca8ba87322b980e906b6 /media-sound
parentamd64 stable, bug 194923 (diff)
downloadgentoo-2-091c0eb4e16d19694141e6b51b0a1dcba16c7ef5.tar.gz
gentoo-2-091c0eb4e16d19694141e6b51b0a1dcba16c7ef5.tar.bz2
gentoo-2-091c0eb4e16d19694141e6b51b0a1dcba16c7ef5.zip
Version bump to latest BMPX release.
(Portage version: 2.1.3.15)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/bmpx/ChangeLog7
-rw-r--r--media-sound/bmpx/bmpx-0.40.13.ebuild86
-rw-r--r--media-sound/bmpx/files/digest-bmpx-0.40.133
3 files changed, 95 insertions, 1 deletions
diff --git a/media-sound/bmpx/ChangeLog b/media-sound/bmpx/ChangeLog
index 22161219b1a2..5474ae5720a9 100644
--- a/media-sound/bmpx/ChangeLog
+++ b/media-sound/bmpx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/bmpx
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/ChangeLog,v 1.70 2007/10/06 13:52:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/ChangeLog,v 1.71 2007/10/21 15:00:51 drac Exp $
+
+*bmpx-0.40.13 (21 Oct 2007)
+
+ 21 Oct 2007; Samuli Suominen <drac@gentoo.org> +bmpx-0.40.13.ebuild:
+ Version bump.
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> bmpx-0.40.10.ebuild:
Added ~ppc, bug #187529
diff --git a/media-sound/bmpx/bmpx-0.40.13.ebuild b/media-sound/bmpx/bmpx-0.40.13.ebuild
new file mode 100644
index 000000000000..8ffb662e424a
--- /dev/null
+++ b/media-sound/bmpx/bmpx-0.40.13.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/bmpx-0.40.13.ebuild,v 1.1 2007/10/21 15:00:51 drac Exp $
+
+inherit fdo-mime gnome2-utils versionator
+
+MY_PR="$(get_version_component_range 1-2 ${PV})"
+
+DESCRIPTION="Next generation Beep Media Player"
+HOMEPAGE="http://www.beep-media-player.org"
+SRC_URI="http://files.beep-media-player.org/releases/${MY_PR}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc hal modplug networkmanager sid startup-notification"
+
+RDEPEND=">=net-libs/libsoup-2.2.100
+ >=dev-db/sqlite-3.3.11
+ >=dev-libs/glib-2.10
+ >=dev-cpp/glibmm-2.12
+ >=dev-libs/libsigc++-2
+ >=x11-libs/gtk+-2.12
+ >=gnome-base/librsvg-2.14
+ >=dev-cpp/gtkmm-2.12
+ >=dev-cpp/libglademm-2.6
+ >=dev-cpp/cairomm-0.6
+ >=dev-cpp/libsexymm-0.1.9
+ >=dev-libs/libxml2-2.6.1
+ >=media-libs/gst-plugins-base-0.10.14
+ >=dev-libs/dbus-glib-0.61
+ >=media-libs/taglib-1.4
+ media-sound/cdparanoia
+ app-arch/zip
+ media-libs/alsa-lib
+ >=dev-libs/boost-1.33.1
+ >=media-libs/libofa-0.9.3
+ hal? ( >=sys-apps/hal-0.5.7.1 )
+ sid? ( =media-libs/libsidplay-1* )
+ modplug? ( >=media-libs/libmodplug-0.8 )
+ startup-notification? ( x11-libs/startup-notification )
+ networkmanager? ( >=net-misc/networkmanager-0.6 )
+ || ( media-plugins/gst-plugins-alsa media-plugins/gst-plugins-oss )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.10
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )"
+
+src_compile() {
+ econf --with-tr1 --enable-ld-workaround \
+ $(use_enable modplug) \
+ $(use_enable hal) \
+ $(use_enable sid) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug) \
+ $(use_with networkmanager nm) \
+ $(use_enable doc)
+
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ einfo
+ elog "Install gst-plugins -mad, -flac, -ogg, -vorbis, -ffmpeg and"
+ elog "others you want to use for playing yourself as we don't add"
+ elog "USE flags for optional runtime depends because of long"
+ elog "compile time BMPx has."
+ einfo
+
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/bmpx/files/digest-bmpx-0.40.13 b/media-sound/bmpx/files/digest-bmpx-0.40.13
new file mode 100644
index 000000000000..2269b3185926
--- /dev/null
+++ b/media-sound/bmpx/files/digest-bmpx-0.40.13
@@ -0,0 +1,3 @@
+MD5 11da3d4c63e77dc15a53d0c6c25ddadb bmpx-0.40.13.tar.bz2 1820642
+RMD160 6eab5edf1ffce8c7226db59281c79c2165886d05 bmpx-0.40.13.tar.bz2 1820642
+SHA256 cf44d0fe1d273f6f29c4a73040b5a182f86d7547685161587afe4ea9af9636f4 bmpx-0.40.13.tar.bz2 1820642