summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-16 10:00:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-16 10:00:34 +0000
commit099f60e4f9eeed72f52d36bcc3c7f4c425ac996f (patch)
tree4fb05d46763083fa7a92f9efc7695ee522ca26d5 /media-sound/zinf/zinf-2.2.5-r1.ebuild
parentinherits to top for bug #47775. (Manifest recommit) (diff)
downloadgentoo-2-099f60e4f9eeed72f52d36bcc3c7f4c425ac996f.tar.gz
gentoo-2-099f60e4f9eeed72f52d36bcc3c7f4c425ac996f.tar.bz2
gentoo-2-099f60e4f9eeed72f52d36bcc3c7f4c425ac996f.zip
Bump to include cdplaying bugfix reported by Anatoly <aanatoly@users.sf.net> in bug #47808.
Diffstat (limited to 'media-sound/zinf/zinf-2.2.5-r1.ebuild')
-rw-r--r--media-sound/zinf/zinf-2.2.5-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-sound/zinf/zinf-2.2.5-r1.ebuild b/media-sound/zinf/zinf-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..ec8f529c99cc
--- /dev/null
+++ b/media-sound/zinf/zinf-2.2.5-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.5-r1.ebuild,v 1.1 2004/04/16 10:00:34 eradicator Exp $
+
+inherit kde-functions eutils flag-o-matic
+
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support, previously called FreeAmp"
+HOMEPAGE="http://www.zinf.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64 -sparc"
+IUSE="debug esd X gtk oggvorbis gnome arts alsa nls ipv6"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ sys-libs/zlib
+ >=sys-libs/ncurses-5.2
+ >=media-libs/musicbrainz-1.0.1
+ X? ( virtual/x11 )
+ esd? ( media-sound/esound )
+ gtk? ( >=x11-libs/gtk+-2.0.0 )
+ gnome? ( >=gnome-base/ORBit-0.5.0 )
+ oggvorbis? ( media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9.8 )
+ arts? ( kde-base/arts )"
+
+# When updating next, check boost to see if the newer versions fix compilation
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ nls? ( sys-devel/gettext )
+ >=media-libs/id3lib-3.8.0
+ dev-libs/boost
+ dev-db/metakit
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-cdplay.patch
+}
+
+src_compile() {
+ local myconf="--enable-cmdline"
+
+ myconf="${myconf} `use_enable debug`"
+ myconf="${myconf} `use_enable esd`"
+ myconf="${myconf} `use_enable arts`"
+ myconf="${myconf} `use_enable alsa`"
+ myconf="${myconf} `use_enable gnome corba`"
+ myconf="${myconf} `use_enable ipv6`"
+
+ if [ $ARCH == "amd64" ]; then
+ replace-flags -O? -O
+ append-flags -frerun-cse-after-loop
+ fi
+
+ if use arts; then
+ set-kdedir 3
+ export ARTSCCONFIG="$KDEDIR/bin/artsc-config"
+ fi
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ into /usr
+ dobin base/zinf
+
+ exeinto /usr/lib/zinf/plugins
+ doexe plugins/*
+
+ insinto /usr/share/zinf/themes
+ doins themes/*
+
+ dodoc AUTHORS ChangeLog NEWS README
+}