summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-12 13:51:35 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-12 13:51:35 +0000
commit5d25343b3dd45691f3022a56a7d631b74d8b0eff (patch)
treefa148d48837c12e7874a4694a15ce948a88459f6 /media-sound/xnoise
parentVersion bump. (diff)
downloadgentoo-2-5d25343b3dd45691f3022a56a7d631b74d8b0eff.tar.gz
gentoo-2-5d25343b3dd45691f3022a56a7d631b74d8b0eff.tar.bz2
gentoo-2-5d25343b3dd45691f3022a56a7d631b74d8b0eff.zip
Version bump
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/xnoise')
-rw-r--r--media-sound/xnoise/ChangeLog9
-rw-r--r--media-sound/xnoise/xnoise-0.2.3.ebuild64
-rw-r--r--media-sound/xnoise/xnoise-9999.ebuild4
3 files changed, 73 insertions, 4 deletions
diff --git a/media-sound/xnoise/ChangeLog b/media-sound/xnoise/ChangeLog
index 43617fd68b46..02e79ad4de32 100644
--- a/media-sound/xnoise/ChangeLog
+++ b/media-sound/xnoise/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xnoise
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/ChangeLog,v 1.19 2012/05/26 20:44:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/ChangeLog,v 1.20 2012/07/12 13:51:35 angelos Exp $
+
+*xnoise-0.2.3 (12 Jul 2012)
+
+ 12 Jul 2012; Christoph Mende <angelos@gentoo.org> +xnoise-0.2.3.ebuild,
+ xnoise-9999.ebuild:
+ Version bump
*xnoise-0.2.2 (26 May 2012)
@@ -93,4 +99,3 @@
07 May 2011; Christoph Mende <angelos@gentoo.org> +xnoise-0.1.22.ebuild,
+metadata.xml:
Initial import
-
diff --git a/media-sound/xnoise/xnoise-0.2.3.ebuild b/media-sound/xnoise/xnoise-0.2.3.ebuild
new file mode 100644
index 000000000000..02bd4213fec3
--- /dev/null
+++ b/media-sound/xnoise/xnoise-0.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-0.2.3.ebuild,v 1.1 2012/07/12 13:51:35 angelos Exp $
+
+EAPI=4
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of
+features"
+HOMEPAGE="http://www.xnoise-media-player.com/"
+SRC_URI="mirror://github/shuerhaaken/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lastfm libnotify +lyrics"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.30:2
+ dev-libs/libxml2:2
+ media-libs/gst-plugins-base:0.10
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ lastfm? ( net-libs/libsoup:2.4 )
+ libnotify? ( x11-libs/libnotify )
+ lyrics? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ econf \
+ $(use_enable lyrics lyricwiki) \
+ $(use_enable lastfm) \
+ $(use_enable libnotify notifications) \
+ --enable-soundmenu2 \
+ $(use_enable lyrics chartlyrics) \
+ $(use_enable lyrics azlyrics)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+ rm -rf "${ED}"/usr/share/${PN}/license || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/xnoise/xnoise-9999.ebuild b/media-sound/xnoise/xnoise-9999.ebuild
index b91c6712398b..a51bc7c702ad 100644
--- a/media-sound/xnoise/xnoise-9999.ebuild
+++ b/media-sound/xnoise/xnoise-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-9999.ebuild,v 1.8 2012/05/26 20:44:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-9999.ebuild,v 1.9 2012/07/12 13:51:35 angelos Exp $
EAPI=4
inherit fdo-mime gnome2-utils git-2
@@ -16,7 +16,7 @@ KEYWORDS=""
IUSE="+lastfm libnotify +lyrics"
RDEPEND="dev-db/sqlite:3
- >=dev-libs/glib-2.28:2
+ >=dev-libs/glib-2.30:2
dev-libs/libxml2:2
media-libs/gst-plugins-base:0.10
media-libs/gstreamer:0.10