summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-03 22:09:30 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-03 22:09:30 +0000
commitd3c58101989b3c5b3469c69534f9cc2b564d3846 (patch)
treed035fe0482baaa36da3570af81bea32b649fd9cc /media-sound/tomahawk
parentVersion bump. (diff)
downloadgentoo-2-d3c58101989b3c5b3469c69534f9cc2b564d3846.tar.gz
gentoo-2-d3c58101989b3c5b3469c69534f9cc2b564d3846.tar.bz2
gentoo-2-d3c58101989b3c5b3469c69534f9cc2b564d3846.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/ChangeLog8
-rw-r--r--media-sound/tomahawk/tomahawk-0.7.0.ebuild77
-rw-r--r--media-sound/tomahawk/tomahawk-9999.ebuild4
3 files changed, 87 insertions, 2 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index 958201cca464..5e510eaa13ce 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.26 2013/05/01 11:53:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.27 2013/05/03 22:09:30 johu Exp $
+
+*tomahawk-0.7.0 (03 May 2013)
+
+ 03 May 2013; Johannes Huber <johu@gentoo.org> +tomahawk-0.7.0.ebuild,
+ tomahawk-9999.ebuild:
+ Version bump.
01 May 2013; Johannes Huber <johu@gentoo.org> tomahawk-9999.ebuild:
Raise dep on media-libs/libechonest for live.
diff --git a/media-sound/tomahawk/tomahawk-0.7.0.ebuild b/media-sound/tomahawk/tomahawk-0.7.0.ebuild
new file mode 100644
index 000000000000..d17fedf21154
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.7.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-0.7.0.ebuild,v 1.1 2013/05/03 22:09:30 johu Exp $
+
+EAPI=5
+
+QT_MINIMAL="4.7.0"
+
+CMAKE_MIN_VERSION="2.8.6"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.tomahawk-player.org/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ GIT_ECLASS="git-2"
+ EGIT_REPO_URI="git://github.com/tomahawk-player/${PN}.git"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils qt4-r2 ${GIT_ECLASS}
+
+DESCRIPTION="Qt playdar social music player"
+HOMEPAGE="http://tomahawk-player.org/"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+IUSE="debug jabber twitter"
+
+DEPEND="
+ app-crypt/qca:2
+ >=dev-cpp/clucene-2.3.3.4
+ >=dev-libs/boost-1.41
+ >=dev-libs/libattica-0.4.0
+ dev-libs/qjson
+ dev-libs/quazip
+ >=dev-qt/qtcore-${QT_MINIMAL}:4
+ >=dev-qt/qtdbus-${QT_MINIMAL}:4
+ >=dev-qt/qtgui-${QT_MINIMAL}:4
+ >=dev-qt/qtsql-${QT_MINIMAL}:4[sqlite]
+ >=dev-qt/qtsvg-${QT_MINIMAL}:4
+ >=dev-qt/qtwebkit-${QT_MINIMAL}:4
+ >=media-libs/liblastfm-1.0.1
+ >=media-libs/libechonest-2.0.3
+ >=media-libs/phonon-4.5.0
+ >=media-libs/taglib-1.6.0
+ x11-libs/libX11
+ jabber? ( >=net-libs/jreen-1.1.1 )
+ twitter? ( net-libs/qtweetlib )
+"
+RDEPEND="${DEPEND}
+ app-crypt/qca-ossl
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with jabber Jreen)
+ $(cmake-utils_use_with twitter QTweetLib)
+ )
+
+ mycmakeargs+=( -DBUILD_WITH_QT4=ON )
+
+ if [[ ${PV} != *9999* ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/media-sound/tomahawk/tomahawk-9999.ebuild b/media-sound/tomahawk/tomahawk-9999.ebuild
index 4ebc4332546f..a3c2824726dc 100644
--- a/media-sound/tomahawk/tomahawk-9999.ebuild
+++ b/media-sound/tomahawk/tomahawk-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.13 2013/05/01 11:53:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.14 2013/05/03 22:09:30 johu Exp $
EAPI=5
@@ -59,6 +59,8 @@ src_configure() {
$(cmake-utils_use_with twitter QTweetLib)
)
+ mycmakeargs+=( -DBUILD_WITH_QT4=ON )
+
if [[ ${PV} != *9999* ]]; then
mycmakeargs+=( -DBUILD_RELEASE=ON )
fi