summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 15:16:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 15:16:49 +0000
commit42c66f483ba7ed65cb1cf0183810f45733d8306b (patch)
tree8e2c8fe1ee42a665043958d535e331b1a78a34ed /media-sound/timidity++
parentRemove mask for net-www/adobesvg; package has been removed, bug 265066. (diff)
downloadgentoo-2-42c66f483ba7ed65cb1cf0183810f45733d8306b.tar.gz
gentoo-2-42c66f483ba7ed65cb1cf0183810f45733d8306b.tar.bz2
gentoo-2-42c66f483ba7ed65cb1cf0183810f45733d8306b.zip
Revision bump for init script changes.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/timidity++')
-rw-r--r--media-sound/timidity++/ChangeLog18
-rw-r--r--media-sound/timidity++/files/init.d.timidity.320
-rw-r--r--media-sound/timidity++/timidity++-2.13.2-r8.ebuild173
3 files changed, 203 insertions, 8 deletions
diff --git a/media-sound/timidity++/ChangeLog b/media-sound/timidity++/ChangeLog
index 6cd24e379d81..5bd3d714b0cd 100644
--- a/media-sound/timidity++/ChangeLog
+++ b/media-sound/timidity++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/timidity++
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity++/ChangeLog,v 1.109 2009/03/08 22:11:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity++/ChangeLog,v 1.110 2009/05/12 15:16:48 ssuominen Exp $
+
+*timidity++-2.13.2-r8 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +timidity++-2.13.2-r8.ebuild, +files/init.d.timidity.3:
+ For init script, use chdir and change group to audio wrt #204727.
08 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+files/timidity++-2.13.2-protos.patch, timidity++-2.13.2-r7.ebuild:
@@ -34,17 +40,13 @@
*timidity++-2.13.2-r7 (21 May 2008)
- 21 May 2008; Samuli Suominen <drac@gentoo.org>
+ 21 May 2008; Samuli Suominen <ssuominen@gentoo.org>
+timidity++-2.13.2-r7.ebuild:
Revision bump to remove USE portaudio wrt #222841.
- 15 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ 15 Feb 2008; Samuli Suominen <ssuominen@gentoo.org>
timidity++-2.13.2-r5.ebuild:
- Allow slang-2.
-
- 09 Feb 2008; Samuli Suominen <drac@gentoo.org>
- timidity++-2.13.2-r6.ebuild:
- Fix timidity++ to work with slang 2.1.3.
+ Make slang depend unstrict so >=2.1.3 is allowed.
25 Nov 2007; Brent Baude <ranger@gentoo.org> timidity++-2.13.2-r6.ebuild:
Marking timidity++-2.13.2-r6 ~ppc for bug 200205
diff --git a/media-sound/timidity++/files/init.d.timidity.3 b/media-sound/timidity++/files/init.d.timidity.3
new file mode 100644
index 000000000000..444a914567ab
--- /dev/null
+++ b/media-sound/timidity++/files/init.d.timidity.3
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+depend() {
+ after alsasound esound
+}
+
+start() {
+ ebegin "Starting TiMidity++ Virtual Midi Sequencer"
+ test -n "$TIMIDITY_PCM_NAME" && export TIMIDITY_PCM_NAME
+ start-stop-daemon --start --background --chdir /usr/share/timidity \
+ --chuid timidity:audio --make-pidfile --pidfile /var/run/timidity.pid \
+ --exec /usr/bin/timidity -- -iA ${TIMIDITY_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping TiMidity++"
+ start-stop-daemon --stop --quiet --pidfile /var/run/timidity.pid
+ eend $?
+}
diff --git a/media-sound/timidity++/timidity++-2.13.2-r8.ebuild b/media-sound/timidity++/timidity++-2.13.2-r8.ebuild
new file mode 100644
index 000000000000..fb671c370bf5
--- /dev/null
+++ b/media-sound/timidity++/timidity++-2.13.2-r8.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity++/timidity++-2.13.2-r8.ebuild,v 1.1 2009/05/12 15:16:48 ssuominen Exp $
+
+inherit eutils elisp-common
+
+MY_PV=${PV/_/-}
+MY_P=TiMidity++-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A handy MIDI to WAV converter with OSS and ALSA output support"
+HOMEPAGE="http://timidity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/timidity/${MY_P}.tar.bz2 mirror://gentoo/${P}-exiterror.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="oss nas esd motif X gtk vorbis tk slang alsa arts jack emacs ao speex flac ncurses"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5 )
+ emacs? ( virtual/emacs )
+ gtk? ( >=x11-libs/gtk+-2 )
+ tk? ( >=dev-lang/tk-8.1 )
+ motif? ( x11-libs/openmotif )
+ esd? ( >=media-sound/esound-0.2.22 )
+ nas? ( >=media-libs/nas-1.4 )
+ alsa? ( media-libs/alsa-lib )
+ slang? ( sys-libs/slang )
+ arts? ( kde-base/arts )
+ jack? ( media-sound/jack-audio-connection-kit )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ speex? ( media-libs/speex )
+ ao? ( >=media-libs/libao-0.8.5 )"
+RDEPEND="${DEPEND}
+ alsa? ( media-sound/alsa-utils )
+ app-admin/eselect-timidity"
+
+PDEPEND="|| ( media-sound/timidity-eawpatches media-sound/timidity-shompatches media-sound/timidity-freepats )"
+
+SITEFILE=50${PN}-gentoo.el
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build TiMidity++ with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+
+ enewgroup audio 18 # Just make sure it exists
+ enewuser timidity -1 -1 /var/lib/timidity audio
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${DISTDIR}/${P}-exiterror.patch"
+ epatch "${FILESDIR}/${P}-gtk26.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-flac.patch"
+ epatch "${FILESDIR}/${P}-flac113.patch"
+ epatch "${FILESDIR}"/${P}-protos.patch
+
+ # fix header location of speex
+ sed -i -e "s:#include <speex:#include <speex/speex:g" configure* timidity/speex_a.c
+}
+
+src_compile() {
+ local myconf
+ local audios
+
+ use flac && audios="${audios},flac"
+ use speex && audios="${audios},speex"
+ use vorbis && audios="${audios},vorbis"
+
+ use oss && audios="${audios},oss"
+ use esd && audios="${audios},esd"
+ use arts && audios="${audios},arts"
+ use jack && audios="${audios},jack"
+ use ao && audios="${audios},ao"
+
+ if use nas; then
+ audios="${audios},nas"
+ myconf="${myconf} --with-nas-library=/usr/$(get_libdir)/libaudio.so --with-x"
+ use X || ewarn "Basic X11 support will be enabled because required by nas."
+ fi
+
+ if use alsa; then
+ audios="${audios},alsa"
+ myconf="${myconf} --with-default-output=alsa --enable-alsaseq"
+ fi
+
+ # We disable motif by default and then only enable it if it's requested.
+ if use motif; then
+ myconf="${myconf} --enable-motif --with-x"
+ use X || ewarn "Basic X11 support will be enabled because required by motif."
+ fi
+
+ econf \
+ --localstatedir=/var/state/timidity++ \
+ --with-lispdir="${SITELISP}/${PN}" \
+ --with-elf \
+ --enable-audio=${audios} \
+ --enable-server \
+ --enable-network \
+ --enable-dynamic \
+ --enable-vt100 \
+ --enable-spline=cubic \
+ $(use_enable emacs) \
+ $(use_enable slang) \
+ $(use_enable ncurses) \
+ $(use_with X x) \
+ $(use_enable X spectrogram) \
+ $(use_enable X wrd) \
+ $(use_enable X xskin) \
+ $(use_enable X xaw) \
+ $(use_enable gtk) \
+ $(use_enable tk tcltk) \
+ --disable-motif \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog*
+ dodoc NEWS README* "${FILESDIR}/timidity.cfg-r1"
+
+ # these are only for the ALSA sequencer mode
+ if use alsa; then
+ newconfd "${FILESDIR}/conf.d.timidity" timidity
+ newinitd "${FILESDIR}/init.d.timidity.3" timidity
+ fi
+
+ insinto /etc
+ newins "${FILESDIR}/timidity.cfg-r1" timidity.cfg
+
+ dodir /usr/share/timidity
+ dosym /etc/timidity.cfg /usr/share/timidity/timidity.cfg
+
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ diropts -o timidity -g nobody -m 0700
+ keepdir /var/lib/timidity
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "A timidity config file has been installed in /etc/timidity.cfg."
+ elog "Do not edit this file as it will interfere with the eselect timidity tool."
+ elog "The tool 'eselect timidity' can be used to switch between installed patchsets."
+
+ if use alsa; then
+ elog "An init script for the alsa timidity sequencer has been installed."
+ elog "If you wish to use the timidity virtual sequencer, edit /etc/conf.d/timidity"
+ elog "and run 'rc-update add timidity <runlevel> && /etc/init.d/timidity start'"
+ fi
+
+ if use sparc; then
+ ewarn "sparc support is experimental. oss, alsa, and esd do not work."
+ ewarn "-Ow (save to wave file) does..."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}