summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 14:28:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 14:28:30 +0000
commit7fcb09b8c39388efc44462f6941571dea6c1ac24 (patch)
tree14dd0cb9f497037a0dc91b3ecb05ecf57d9b5aed /media-sound/specimen
parentBuild against xulrunner, bug 239209 (diff)
downloadgentoo-2-7fcb09b8c39388efc44462f6941571dea6c1ac24.tar.gz
gentoo-2-7fcb09b8c39388efc44462f6941571dea6c1ac24.tar.bz2
gentoo-2-7fcb09b8c39388efc44462f6941571dea6c1ac24.zip
fix build with not so recent jack, bug #251254
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/specimen')
-rw-r--r--media-sound/specimen/ChangeLog8
-rw-r--r--media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch22
-rw-r--r--media-sound/specimen/specimen-0.5.2_rc3.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/media-sound/specimen/ChangeLog b/media-sound/specimen/ChangeLog
index 5338a777e31d..d9528743cdf2 100644
--- a/media-sound/specimen/ChangeLog
+++ b/media-sound/specimen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/specimen
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/ChangeLog,v 1.18 2007/11/07 17:24:00 armin76 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/ChangeLog,v 1.19 2008/12/19 14:28:30 aballier Exp $
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/specimen-0.5.2_rc3-jackmidi.patch, specimen-0.5.2_rc3.ebuild:
+ fix build with not so recent jack, bug #251254
07 Nov 2007; Raúl Porcel <armin76@gentoo.org> specimen-0.5.2_rc3.ebuild:
sparc stable wrt #159465, thanks to Alex Maclean for testing
diff --git a/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch b/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
new file mode 100644
index 000000000000..2e3cf2ba9125
--- /dev/null
+++ b/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
@@ -0,0 +1,22 @@
+Index: specimen-0.5.2-rc3/src/jackdriver.c
+===================================================================
+--- specimen-0.5.2-rc3.orig/src/jackdriver.c
++++ specimen-0.5.2-rc3/src/jackdriver.c
+@@ -81,7 +81,7 @@ static int process (jack_nframes_t frame
+ jack_midi_event_t jack_midi_event;
+ jack_nframes_t event_index = 0;
+ #ifdef HAVE_JACK_MIDI
+- jack_nframes_t event_count = jack_midi_get_event_count(midi_buf, frames);
++ jack_nframes_t event_count = jack_midi_get_event_count(midi_buf);
+ #endif /* HAVE_JACK_MIDI */
+ #ifdef HAVE_OLD_JACK_MIDI
+ jack_nframes_t event_count = jack_midi_port_get_info(midi_buf, frames)->event_count;
+@@ -123,7 +123,7 @@ static int process (jack_nframes_t frame
+ /* send the JACK MIDI events to the mixer */
+ while (event_index < event_count) {
+
+- jack_midi_event_get(&jack_midi_event, midi_buf,event_index, frames);
++ jack_midi_event_get(&jack_midi_event, midi_buf,event_index);
+ midi_data = jack_midi_event.buffer;
+
+ /* TODO: handle 14-bit controllers and RPNs and NRPNs */
diff --git a/media-sound/specimen/specimen-0.5.2_rc3.ebuild b/media-sound/specimen/specimen-0.5.2_rc3.ebuild
index 3cc1045278f9..1ced5d0b6127 100644
--- a/media-sound/specimen/specimen-0.5.2_rc3.ebuild
+++ b/media-sound/specimen/specimen-0.5.2_rc3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/specimen-0.5.2_rc3.ebuild,v 1.4 2007/11/07 17:24:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/specimen-0.5.2_rc3.ebuild,v 1.5 2008/12/19 14:28:30 aballier Exp $
inherit eutils
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc sparc x86"
IUSE="lash"
-RDEPEND="media-sound/jack-audio-connection-kit
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
>=media-libs/alsa-lib-0.9
media-libs/libsamplerate
media-libs/libsndfile
@@ -33,6 +33,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -e "s:-Werror::" -e "s:-O3:${CFLAGS}:" -i configure
+ epatch "${FILESDIR}/${P}-jackmidi.patch"
}
src_compile() {