summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-23 19:32:23 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-23 19:32:23 +0000
commit901d7a54b92f56488c6cb2ec03393c3f545319b0 (patch)
tree89fb47a7ae42ea037282e18ac6ce15624147c7a1 /media-sound/shnflacverify
parentRemove old. (diff)
downloadgentoo-2-901d7a54b92f56488c6cb2ec03393c3f545319b0.tar.gz
gentoo-2-901d7a54b92f56488c6cb2ec03393c3f545319b0.tar.bz2
gentoo-2-901d7a54b92f56488c6cb2ec03393c3f545319b0.zip
initial commit
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/shnflacverify')
-rw-r--r--media-sound/shnflacverify/ChangeLog10
-rw-r--r--media-sound/shnflacverify/Manifest4
-rw-r--r--media-sound/shnflacverify/metadata.xml13
-rw-r--r--media-sound/shnflacverify/shnflacverify-0.3.ebuild41
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/shnflacverify/ChangeLog b/media-sound/shnflacverify/ChangeLog
new file mode 100644
index 000000000000..71cfd5c232c7
--- /dev/null
+++ b/media-sound/shnflacverify/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/shnflacverify
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shnflacverify/ChangeLog,v 1.1 2011/10/23 19:32:23 sbriesen Exp $
+
+*shnflacverify-0.3 (23 Oct 2011)
+
+ 23 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org>
+ +shnflacverify-0.3.ebuild, +metadata.xml:
+ initial commit
+
diff --git a/media-sound/shnflacverify/Manifest b/media-sound/shnflacverify/Manifest
new file mode 100644
index 000000000000..9cc220824483
--- /dev/null
+++ b/media-sound/shnflacverify/Manifest
@@ -0,0 +1,4 @@
+DIST shnflacverify-0.3.zip 11845 RMD160 55f4ff2333ff824392e9619c60245b6fbf7f6f4a SHA1 cc9c1b385697a4fc05955dc5721d18871f25e2fd SHA256 ce57b0b4bd707dff34b975557e7cc3705c6662a342202128342191a9077e7b5a
+EBUILD shnflacverify-0.3.ebuild 905 RMD160 d8b33957b24a595e980a7f9962ba445f678b0a2d SHA1 8611864254c5aeb68941ae4d7bd1879349bd39ed SHA256 2b33775b4541e181208659cff74c39f7aed1f63b56b04b9716a434e9446d4151
+MISC ChangeLog 277 RMD160 949fc56c4286d505f7ba73067220756dbaf4b8fa SHA1 d34b113021bde4eea04d10baac5b0c04eab36780 SHA256 f8c003d394f69851c605fbcc868b65196ed68c4801e27d47e27c71b1eea9dcf2
+MISC metadata.xml 469 RMD160 05121dc1ead0ba9a5334f1b43a2772f1e1b69997 SHA1 1e01b75d059c112aa0a284e2c601c66ed21efc84 SHA256 ffe3ed7286e6d600db31e78ff7297647293e3bb6dfaf1a6cc5adbc6f3cf4f904
diff --git a/media-sound/shnflacverify/metadata.xml b/media-sound/shnflacverify/metadata.xml
new file mode 100644
index 000000000000..9bc371b15d5d
--- /dev/null
+++ b/media-sound/shnflacverify/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+ <longdescription lang="en">
+ This program helps manage the verification of checksums related to
+ Shorten (SHN) and FLAC audio files. This script provides a convenient
+ way to verify shn/flac files in bulk.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/shnflacverify/shnflacverify-0.3.ebuild b/media-sound/shnflacverify/shnflacverify-0.3.ebuild
new file mode 100644
index 000000000000..8ac0fbb95101
--- /dev/null
+++ b/media-sound/shnflacverify/shnflacverify-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shnflacverify/shnflacverify-0.3.ebuild,v 1.1 2011/10/23 19:32:23 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="This program helps manage the verification of checksums related to Shorten and FLAC files"
+HOMEPAGE="http://sourceforge.net/projects/shnflacverify/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ app-arch/unzip
+ media-libs/flac
+ media-sound/shntool
+ sys-apps/coreutils"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local X
+ edos2unix *.txt
+ for X in flac md5sum shntool metaflac; do
+ einfo "setting \$${X}_cmd to $(type -p ${X})"
+ sed -i -e "s|^\(\$${X}_cmd\s*=\s*'\)[^']*\('.*\)|\1$(type -p ${X})\2|g" shnflac*
+ done
+}
+
+src_install() {
+ local X
+ for X in *.pl; do newbin "${X}" "${X%.*}"; done
+ newdoc README.txt README
+}