summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-04-08 03:36:20 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-04-08 03:36:20 +0000
commit356bae50a1de409ea0035138c1dc6889112709d5 (patch)
tree11ffd9b6f81812ac7e44dd4b1272937068caeb6b /media-sound/rip
parentAdded perl modules needed for media-sound/rip. (diff)
downloadgentoo-2-356bae50a1de409ea0035138c1dc6889112709d5.tar.gz
gentoo-2-356bae50a1de409ea0035138c1dc6889112709d5.tar.bz2
gentoo-2-356bae50a1de409ea0035138c1dc6889112709d5.zip
Added new ebuild:
rip - perl script to rip and mp3/ogg encode trecks on audio CDs. depende on dev-prel/CDDB_get, dev-perl/MP3-Info
Diffstat (limited to 'media-sound/rip')
-rw-r--r--media-sound/rip/ChangeLog25
-rw-r--r--media-sound/rip/files/digest-rip-1.011
-rw-r--r--media-sound/rip/files/digest-rip-1.01-r11
-rw-r--r--media-sound/rip/rip-1.01-r1.ebuild35
-rw-r--r--media-sound/rip/rip-1.01.ebuild67
5 files changed, 129 insertions, 0 deletions
diff --git a/media-sound/rip/ChangeLog b/media-sound/rip/ChangeLog
new file mode 100644
index 000000000000..30faf0d7dc9c
--- /dev/null
+++ b/media-sound/rip/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for dev-perl/CDDB_get
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rip/ChangeLog,v 1.1 2002/04/08 03:36:20 george Exp $
+
+*rip-1.01 (7 Apr 2002)
+
+ 7 Apr 2002; G. Shapovalov <george@gentoo.org> Changelog:
+
+ Initial release of this ebuild. Contains rip-1.01 and rip-1.01-r1
+ rip-1.01.ebuild:
+ installs two perl modules in addition to the script itself
+ (because of the way script is packaged: modules were included and
+ author claims they are hard to find)
+ DEPRECATED! use rip-1.01-r1 instead!
+ rip-1.01-r1.ebuild:
+ installs script only, necessary modules are installed separately and listed as RDEPEND
+
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-sound/rip/files/digest-rip-1.01 b/media-sound/rip/files/digest-rip-1.01
new file mode 100644
index 000000000000..48c4d184b064
--- /dev/null
+++ b/media-sound/rip/files/digest-rip-1.01
@@ -0,0 +1 @@
+MD5 e29fe8cf0b0f0d855a77a7b9ad228d66 rip-1.01.tar.gz 101680
diff --git a/media-sound/rip/files/digest-rip-1.01-r1 b/media-sound/rip/files/digest-rip-1.01-r1
new file mode 100644
index 000000000000..48c4d184b064
--- /dev/null
+++ b/media-sound/rip/files/digest-rip-1.01-r1
@@ -0,0 +1 @@
+MD5 e29fe8cf0b0f0d855a77a7b9ad228d66 rip-1.01.tar.gz 101680
diff --git a/media-sound/rip/rip-1.01-r1.ebuild b/media-sound/rip/rip-1.01-r1.ebuild
new file mode 100644
index 000000000000..90564f9ff3e0
--- /dev/null
+++ b/media-sound/rip/rip-1.01-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/media-sound/rip/rip-1.01-r1.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A command-line based audio CD ripper and mp3 encoder"
+SRC_URI="http://rip.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://rip.sourceforge.net"
+
+DEPEND=""
+
+RDEPEND="media-sound/cdparanoia
+ sys-devel/perl
+ >=dev-perl/CDDB_get-1.66
+ >=dev-perl/MP3-Info-0.91"
+
+
+
+src_compile() {
+ #the thing itself is just a perl script
+ #so we need an empty method here
+ echo "nothing to be done"
+
+}
+
+src_install () {
+
+ chmod 755 rip
+ dobin rip || die
+
+ # Install documentation.
+ dodoc COPYING FAQ README
+}
diff --git a/media-sound/rip/rip-1.01.ebuild b/media-sound/rip/rip-1.01.ebuild
new file mode 100644
index 000000000000..59cd55433e75
--- /dev/null
+++ b/media-sound/rip/rip-1.01.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A command-line based audio CD ripper and mp3 encoder"
+SRC_URI="http://rip.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://rip.sourceforge.net"
+
+DEPEND=""
+
+RDEPEND="media-sound/cdparanoia
+ media-sound/lame"
+
+# Use this function to unpack your sources and apply patches, and run
+# autoconf/automake/etc. if necessary. By default, this function unpacks
+# the packages in ${A} and applies ${PF}-gentoo.diff. The default
+# starting directory is ${WORKDIR}.
+#
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+ #we need to unpack supplementary perl modules
+ tar xzf CDDB_get-1.66.tar.gz
+ tar xzf MP3-Info-0.91.tar.gz
+}
+
+src_compile() {
+ #the thing itself is just a perl script
+ #but we need to make suppl perl modules
+
+ cd CDDB_get-1.66
+ perl Makefile.PL && make || die "could not prepare CDDB access perl module"
+ cd ..
+
+ cd MP3-Info-0.91
+ perl Makefile.PL && make || die "could not prepare CDDB access perl module"
+ cd ..
+
+}
+
+src_install () {
+
+ chmod 755 rip
+ dobin rip || die
+
+ #now we need to install perl modules
+ cd CDDB_get-1.66
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+
+ cd ../MP3-Info-0.91
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ # Install documentation.
+ dodoc COPYING FAQ README
+}