summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-02-12 17:01:22 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-02-12 17:01:22 +0000
commit95147b1f8b2622a0a01535552c005ada2ef601cb (patch)
tree89e57e944e534da8b46b1646e17e185e19ea41d3 /media-sound/rhythmbox
parentUse the proper menu icon (Manifest recommit) (diff)
downloadgentoo-2-95147b1f8b2622a0a01535552c005ada2ef601cb.tar.gz
gentoo-2-95147b1f8b2622a0a01535552c005ada2ef601cb.tar.bz2
gentoo-2-95147b1f8b2622a0a01535552c005ada2ef601cb.zip
Patch to make it compile with gcc-2. Copyright date fixes..
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch18
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild4
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.3.ebuild4
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.5.ebuild3
5 files changed, 29 insertions, 6 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index f835c87e7e16..2935e5d25546 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.27 2004/01/22 19:21:05 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.28 2004/02/12 17:01:22 leonardop Exp $
+
+ 12 Feb 2004; L. Boshell <leonardop@gentoo.org> rhythmbox-0.6.5.ebuild,
+ files/rhythmbox-0.6.5-gcc2_fix.patch:
+ Added patch to make it compile with gcc-2.
*rhythmbox-0.6.5 (22 Jan 2004)
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch b/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch
new file mode 100644
index 000000000000..0492f0765545
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch
@@ -0,0 +1,18 @@
+diff -NurB rhythmbox-0.6.5-orig/shell/rb-shell.c rhythmbox-0.6.5/shell/rb-shell.c
+--- rhythmbox-0.6.5-orig/shell/rb-shell.c 2004-02-12 11:34:12.000000000 -0500
++++ rhythmbox-0.6.5/shell/rb-shell.c 2004-02-12 11:34:45.000000000 -0500
+@@ -608,12 +608,13 @@
+ const CORBA_char *uri,
+ CORBA_Environment *ev)
+ {
++ GnomeVFSURI *vfsuri;
+ RBShell *shell = RB_SHELL (bonobo_object (_servant));
+ RBPlaylist *parser;
+
+ rb_debug ("handling uri: %s", uri);
+
+- GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
++ vfsuri = gnome_vfs_uri_new (uri);
+ if (!vfsuri) {
+ rb_error_dialog (_("Unable to parse URI \"%s\"\n"), uri);
+ return;
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
index 00aa0f01c012..a4c1145dcd9a 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.2 2003/12/23 14:19:36 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.3 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
index e44c8786ce07..6fe8bc6a77de 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild,v 1.1 2003/12/23 14:19:36 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild,v 1.2 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
index 09999650aa20..ac1fee6e33bb 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.1 2004/01/22 19:21:05 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.2 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
@@ -61,6 +61,7 @@ src_unpack( ) {
# sandbox errors work around
gnome2_omf_fix ${S}/help/C/Makefile.in
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
}
DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \