summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-03-22 10:54:37 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-03-22 10:54:37 +0000
commit08748bb45ad0f13095e2dc52e41cea73d61088fe (patch)
tree0228fe707732f3a8ab03e0182de095eaadb4d9ac /media-sound/pympd/pympd-0.06.1.ebuild
parentcosmetics: change text summary to info for newer vdr-versions (diff)
downloadgentoo-2-08748bb45ad0f13095e2dc52e41cea73d61088fe.tar.gz
gentoo-2-08748bb45ad0f13095e2dc52e41cea73d61088fe.tar.bz2
gentoo-2-08748bb45ad0f13095e2dc52e41cea73d61088fe.zip
Version bump.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'media-sound/pympd/pympd-0.06.1.ebuild')
-rw-r--r--media-sound/pympd/pympd-0.06.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/pympd/pympd-0.06.1.ebuild b/media-sound/pympd/pympd-0.06.1.ebuild
new file mode 100644
index 000000000000..47930ce089cf
--- /dev/null
+++ b/media-sound/pympd/pympd-0.06.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pympd/pympd-0.06.1.ebuild,v 1.1 2006/03/22 10:54:37 ticho Exp $
+
+inherit eutils python
+
+DESCRIPTION="a Rhythmbox-like PyGTK+ client for Music Player Daemon"
+HOMEPAGE="http://sourceforge.net/projects/pympd"
+SRC_URI="http://pympd.sourceforge.net/files/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="gnome"
+RDEPEND=">=virtual/python-2.4
+ >=dev-python/pygtk-2.6
+ gnome? ( dev-python/gnome-python-extras )"
+
+DOCS="README"
+
+src_compile() {
+ make PREFIX="/usr" DESTDIR="${D}"
+}
+
+src_install() {
+ make PREFIX="/usr" DESTDIR="${D}" install
+
+ use gnome || cd ${D} && find -iname trayicon.* | xargs rm
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+
+ cd ${S}
+ newins src/glade/pixmaps/icon.png pympd.png
+ make_desktop_entry "pympd" "pympd" "pympd.png" "Audio"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/pympd
+
+ echo
+ ewarn
+ ewarn "You need to remove the .pympd directory from your home directory, as new version uses different settings format"
+ ewarn
+ echo
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}