summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:55:49 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:55:49 +0000
commitb6d44b00c36b29fdae1cfe1d1e1ae5ce0537d42d (patch)
tree3b8e710c895c46eb0a43bd4ef91616eea4b16db8 /media-sound/pulseaudio
parentReplace multilib_build_binaries with multilib_is_native_abi, in order to put ... (diff)
downloadgentoo-2-b6d44b00c36b29fdae1cfe1d1e1ae5ce0537d42d.tar.gz
gentoo-2-b6d44b00c36b29fdae1cfe1d1e1ae5ce0537d42d.tar.bz2
gentoo-2-b6d44b00c36b29fdae1cfe1d1e1ae5ce0537d42d.zip
Replace multilib_build_binaries with multilib_is_native_abi, in order to put an end to the confusion introduced by having two functions, the proper one suggesting it is just for binaries.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/ChangeLog8
-rw-r--r--media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild10
-rw-r--r--media-sound/pulseaudio/pulseaudio-5.0.ebuild10
3 files changed, 17 insertions, 11 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index bad07b8a70ce..324609508293 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.332 2014/04/27 08:03:30 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.333 2014/04/28 17:55:49 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org> pulseaudio-5.0-r1.ebuild,
+ pulseaudio-5.0.ebuild:
+ Replace multilib_build_binaries with multilib_is_native_abi, in order to put
+ an end to the confusion introduced by having two functions, the proper one
+ suggesting it is just for binaries.
*pulseaudio-5.0-r1 (27 Apr 2014)
diff --git a/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild
index 604b3d60b906..11dea63236af 100644
--- a/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild,v 1.1 2014/04/27 08:03:30 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-5.0-r1.ebuild,v 1.2 2014/04/28 17:55:49 mgorny Exp $
EAPI="5"
inherit autotools eutils flag-o-matic linux-info readme.gentoo systemd user versionator udev multilib-minimal
@@ -191,7 +191,7 @@ multilib_src_configure() {
--with-udev-rules-dir="${EPREFIX}/$(udev_get_udevdir)"/rules.d
)
- if ! multilib_build_binaries; then
+ if ! multilib_is_native_abi; then
# disable all the modules and stuff
myconf+=(
--disable-oss-output
@@ -229,7 +229,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake
else
emake -C src libpulse{,-simple,-mainloop-glib}.la
@@ -250,13 +250,13 @@ multilib_src_test() {
# We avoid running the toplevel check target because that will run
# po/'s tests too, and they are broken. Officially, it should work
# with intltool 0.41, but that doesn't look like a stable release.
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake -C src check
fi
}
multilib_src_install() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake -j1 DESTDIR="${D}" install
else
emake DESTDIR="${D}" install-pkgconfigDATA
diff --git a/media-sound/pulseaudio/pulseaudio-5.0.ebuild b/media-sound/pulseaudio/pulseaudio-5.0.ebuild
index ed8d4241ad7d..7eb48866f652 100644
--- a/media-sound/pulseaudio/pulseaudio-5.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-5.0.ebuild,v 1.8 2014/04/26 19:05:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-5.0.ebuild,v 1.9 2014/04/28 17:55:49 mgorny Exp $
EAPI="5"
inherit autotools eutils flag-o-matic linux-info readme.gentoo systemd user versionator udev multilib-minimal
@@ -183,7 +183,7 @@ multilib_src_configure() {
--with-udev-rules-dir="${EPREFIX}/$(udev_get_udevdir)"/rules.d
)
- if ! multilib_build_binaries; then
+ if ! multilib_is_native_abi; then
# disable all the modules and stuff
myconf+=(
--disable-oss-output
@@ -221,7 +221,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake
else
emake -C src libpulse{,-simple,-mainloop-glib}.la
@@ -242,13 +242,13 @@ multilib_src_test() {
# We avoid running the toplevel check target because that will run
# po/'s tests too, and they are broken. Officially, it should work
# with intltool 0.41, but that doesn't look like a stable release.
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake -C src check
fi
}
multilib_src_install() {
- if multilib_build_binaries; then
+ if multilib_is_native_abi; then
emake -j1 DESTDIR="${D}" install
else
emake DESTDIR="${D}" install-pkgconfigDATA