summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-17 22:26:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-17 22:26:36 +0000
commit58b07054867ca24133c8d0f2a9ab959b22899c2c (patch)
tree491f7d72ac9b655f256fbc18e1af2e30a003dafc /media-sound/potamus
parentBump. Thanks to proxy-maintainer Erik Falor (fadein) ewfalor at gmail dot com . (diff)
downloadgentoo-2-58b07054867ca24133c8d0f2a9ab959b22899c2c.tar.gz
gentoo-2-58b07054867ca24133c8d0f2a9ab959b22899c2c.tar.bz2
gentoo-2-58b07054867ca24133c8d0f2a9ab959b22899c2c.zip
Version bump. This fixes build with latest ffmpeg, bug #443432
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound/potamus')
-rw-r--r--media-sound/potamus/ChangeLog9
-rw-r--r--media-sound/potamus/potamus-14.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-sound/potamus/ChangeLog b/media-sound/potamus/ChangeLog
index 02557f83a127..e88d401d4136 100644
--- a/media-sound/potamus/ChangeLog
+++ b/media-sound/potamus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/potamus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/ChangeLog,v 1.12 2012/09/07 22:11:56 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/ChangeLog,v 1.13 2013/01/17 22:26:36 aballier Exp $
+
+*potamus-14 (17 Jan 2013)
+
+ 17 Jan 2013; Alexis Ballier <aballier@gentoo.org> +potamus-14.ebuild:
+ Version bump. This fixes build with latest ffmpeg, bug #443432
07 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
diff --git a/media-sound/potamus/potamus-14.ebuild b/media-sound/potamus/potamus-14.ebuild
new file mode 100644
index 000000000000..7b02885d4176
--- /dev/null
+++ b/media-sound/potamus/potamus-14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/potamus-14.ebuild,v 1.1 2013/01/17 22:26:36 aballier Exp $
+
+EAPI=4
+
+inherit gnome2
+
+DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality."
+HOMEPAGE="http://offog.org/code/potamus.html"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audiofile flac mad modplug vorbis +ao jack"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ media-libs/libsamplerate
+ virtual/ffmpeg
+ audiofile? ( media-libs/audiofile )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ modplug? ( media-libs/libmodplug )
+ vorbis? ( media-libs/libvorbis )
+ ao? ( media-libs/libao )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable audiofile input-audiofile) \
+ $(use_enable flac input-flac) \
+ $(use_enable mad input-mad) \
+ $(use_enable modplug input-modplug) \
+ $(use_enable vorbis input-vorbis) \
+ $(use_enable ao output-ao) \
+ $(use_enable jack output-jack)
+
+}
+
+src_install() {
+ default
+}