summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-01-23 11:46:20 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-01-23 11:46:20 +0000
commit348b6a57e11a5c62f6140d4b92844eac3578560b (patch)
tree41abda05876bb242c27d35b69d8a4a13a3c8167a /media-sound/pms
parentFix qt packages category (diff)
downloadgentoo-2-348b6a57e11a5c62f6140d4b92844eac3578560b.tar.gz
gentoo-2-348b6a57e11a5c62f6140d4b92844eac3578560b.tar.bz2
gentoo-2-348b6a57e11a5c62f6140d4b92844eac3578560b.zip
Revision bump: EAPI 5, compatibility with automake 1.14, add subslot operator to boost dependency, add epatch_user
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-sound/pms')
-rw-r--r--media-sound/pms/ChangeLog10
-rw-r--r--media-sound/pms/pms-0.42-r1.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/media-sound/pms/ChangeLog b/media-sound/pms/ChangeLog
index ad92dea8047a..26b5ad1612ae 100644
--- a/media-sound/pms/ChangeLog
+++ b/media-sound/pms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pms
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pms/ChangeLog,v 1.8 2012/11/20 19:17:12 wired Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pms/ChangeLog,v 1.9 2014/01/23 11:46:20 pinkbyte Exp $
+
+*pms-0.42-r1 (23 Jan 2014)
+
+ 23 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> +pms-0.42-r1.ebuild:
+ Revision bump: EAPI 5, compatibility with automake 1.14, add subslot operator
+ to boost dependency, add epatch_user
20 Nov 2012; Alex Alexander <wired@gentoo.org> pms-0.42.ebuild,
pms-9999.ebuild:
diff --git a/media-sound/pms/pms-0.42-r1.ebuild b/media-sound/pms/pms-0.42-r1.ebuild
new file mode 100644
index 000000000000..2d981213e3c4
--- /dev/null
+++ b/media-sound/pms/pms-0.42-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pms/pms-0.42-r1.ebuild,v 1.1 2014/01/23 11:46:20 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( dev-libs/boost:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # bug #424717
+ sed -i -e "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die 'sed on Makefile.am failed'
+
+ # Compatibility with automake 1.14
+ sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror/subdir-objects/' configure.ac || die 'sed on configure.ac failed'
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex)
+}