summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-07-11 22:21:52 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-07-11 22:21:52 +0000
commitb9dce3a63f49b7decf7ab4cf15a276537432a14a (patch)
tree3bc297b3cd02d0642533c4012a10227968239389 /media-sound/museseq/museseq-0.6.2-r1.ebuild
parentversionbump (Manifest recommit) (diff)
downloadgentoo-2-b9dce3a63f49b7decf7ab4cf15a276537432a14a.tar.gz
gentoo-2-b9dce3a63f49b7decf7ab4cf15a276537432a14a.tar.bz2
gentoo-2-b9dce3a63f49b7decf7ab4cf15a276537432a14a.zip
Fixes to get MuSE running on amd64. Thanks to Andreas Pokorny <diemumiee@gmx.org> for the hard work in QT and the memory allocator. Closes bug #54569.
Diffstat (limited to 'media-sound/museseq/museseq-0.6.2-r1.ebuild')
-rw-r--r--media-sound/museseq/museseq-0.6.2-r1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/museseq/museseq-0.6.2-r1.ebuild b/media-sound/museseq/museseq-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..34156db82688
--- /dev/null
+++ b/media-sound/museseq/museseq-0.6.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.2-r1.ebuild,v 1.1 2004/07/11 22:21:52 fvdpol Exp $
+
+inherit virtualx eutils kde-functions
+need-qt 3
+
+MY_P=muse-${PV}
+DESCRIPTION="The Linux (midi) MUSic Editor (a sequencer)"
+HOMEPAGE="http://muse.seh.de"
+SRC_URI="mirror://sourceforge/lmuse/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="jack fluidsynth ladcca"
+
+DEPEND="media-libs/alsa-lib \
+ >=media-libs/libsndfile-1.0.4 \
+ >=x11-libs/qt-3.1.0
+ ladcca? ( >=media-libs/ladcca-0.4.0 ) \
+ jack? ( media-sound/jack-audio-connection-kit ) \
+ fluidsynth? ( media-sound/fluidsynth )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s/HAVE_JACK_JACK_H/HAVE_JACK/" widgets/audioconf.cpp
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" driver/alsaaudio.cpp
+ epatch ${FILESDIR}/${P}-fPIC.patch
+ epatch ${FILESDIR}/${P}-int2ptr.patch
+ epatch ${FILESDIR}/${P}-memory.patch
+ epatch ${FILESDIR}/${P}-drumport.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="--disable-suid-build"
+ use ladcca || myconf="${myconf} --disable-ladcca"
+ use jack || myconf="${myconf} --disable-jack"
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+ Xeconf ${myconf} || die "configure failed"
+
+ ### borrowed from kde.eclass #
+ #
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox,
+ # so that the build process can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ #addwrite "${QTDIR}/etc/settings"
+ # commented this out, proper fix is need-qt 3 from
+ # kde-functions.
+ # Danny van Dyk <kugelfang@gentoo.org> 2004/05/26
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
+ # Allow access to /dev/dri/card*
+ addpredict /dev/dri/card*
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING INSTALL README README.softsynth SECURITY TODO
+
+ # Name conflict with media-sound/muse. See bug #34973
+ mv ${D}/usr/bin/muse ${D}/usr/bin/lmuse
+ if [ ! -f /usr/bin/muse -o -L /usr/bin/muse ]; then
+ dosym /usr/bin/lmuse /usr/bin/muse
+ fi
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Muse has been installed normally. If,"
+ einfo "you would like to use muse with real time"
+ einfo "time capabilities for the sequencer then do"
+ einfo "chmod 4755 /usr/bin/lmuse"
+ einfo ""
+ einfo "Muse can use /dev/rtc if it is compiled in"
+ einfo "to your kernel, or available as a module."
+ einfo ""
+}