summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 17:46:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 17:46:49 +0000
commit584246d0ff5529ecb4bfba24155b785e0ec3cb98 (patch)
treeda567b03020e3fce98e0f32bb36627e79876d672 /media-sound/musepack-tools
parentfix rdep (add pygame) bug #130378 (diff)
downloadgentoo-2-584246d0ff5529ecb4bfba24155b785e0ec3cb98.tar.gz
gentoo-2-584246d0ff5529ecb4bfba24155b785e0ec3cb98.tar.bz2
gentoo-2-584246d0ff5529ecb4bfba24155b785e0ec3cb98.zip
Add patch to fix executable stack. Bug #118168.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'media-sound/musepack-tools')
-rw-r--r--media-sound/musepack-tools/ChangeLog8
-rw-r--r--media-sound/musepack-tools/files/musepack-tools-1.15v-execstack.patch44
-rw-r--r--media-sound/musepack-tools/musepack-tools-1.15v.ebuild7
3 files changed, 55 insertions, 4 deletions
diff --git a/media-sound/musepack-tools/ChangeLog b/media-sound/musepack-tools/ChangeLog
index 9dda1b70246e..be4538cf6bfa 100644
--- a/media-sound/musepack-tools/ChangeLog
+++ b/media-sound/musepack-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/musepack-tools
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/ChangeLog,v 1.27 2005/10/18 21:46:37 chainsaw Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/ChangeLog,v 1.28 2006/04/18 17:46:49 flameeyes Exp $
+
+ 18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/musepack-tools-1.15v-execstack.patch, musepack-tools-1.15v.ebuild:
+ Add patch to fix executable stack. Bug #118168.
18 Oct 2005; Tony Vroon <chainsaw@gentoo.org> musepack-tools-1.15v.ebuild:
Do not attempt to redirect output to /dev/tty, this makes no sense. Closes
diff --git a/media-sound/musepack-tools/files/musepack-tools-1.15v-execstack.patch b/media-sound/musepack-tools/files/musepack-tools-1.15v-execstack.patch
new file mode 100644
index 000000000000..075fad3efe5c
--- /dev/null
+++ b/media-sound/musepack-tools/files/musepack-tools-1.15v-execstack.patch
@@ -0,0 +1,44 @@
+Index: sv7/cpu_feat.nas
+===================================================================
+--- sv7.orig/cpu_feat.nas
++++ sv7/cpu_feat.nas
+@@ -140,3 +140,6 @@ proc Init_FPU2
+ endproc
+
+ end
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+Index: sv7/fft4gasm.nas
+===================================================================
+--- sv7.orig/fft4gasm.nas
++++ sv7/fft4gasm.nas
+@@ -422,3 +422,6 @@ lbl5:
+
+
+ ;##################################################################
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+Index: sv7/list_korr_asm.nas
+===================================================================
+--- sv7.orig/list_korr_asm.nas
++++ sv7/list_korr_asm.nas
+@@ -98,3 +98,6 @@ lbl2:
+ fstp tword [eax+ 8] ; x
+ ret
+ ;
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+Index: sv7/synthasm.nas
+===================================================================
+--- sv7.orig/synthasm.nas
++++ sv7/synthasm.nas
+@@ -2225,3 +2225,6 @@ endproc
+ ;
+ ; end of synthasm.nas
+ ;
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
diff --git a/media-sound/musepack-tools/musepack-tools-1.15v.ebuild b/media-sound/musepack-tools/musepack-tools-1.15v.ebuild
index d4a4ed3d8a8b..3897f2377947 100644
--- a/media-sound/musepack-tools/musepack-tools-1.15v.ebuild
+++ b/media-sound/musepack-tools/musepack-tools-1.15v.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/musepack-tools-1.15v.ebuild,v 1.6 2005/10/18 21:46:37 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musepack-tools/musepack-tools-1.15v.ebuild,v 1.7 2006/04/18 17:46:49 flameeyes Exp $
IUSE="static 16bit esd"
@@ -47,6 +47,8 @@ src_unpack() {
# Bug #109699; console redirection to /dev/tty makes no sense
sed -i -e 's/$(LDADD) &> $(LOGFILE)/$(LDADD)/' Makefile
+
+ epatch "${FILESDIR}/${P}-execstack.patch"
}
src_compile() {
@@ -55,6 +57,7 @@ src_compile() {
use static && export BLD_STATIC=1
append-flags -I${S}
+
ARCH= emake mppenc mppdec replaygain || die
}