summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-28 23:30:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-28 23:30:46 +0000
commit99fd2b26e97c58ac46d338de663cb6b09c72b926 (patch)
tree3caf278c96dac0e2844a58d9796a8303acd2841c /media-sound/mup
parentunmask mozilla-launcher-1.33 (diff)
downloadgentoo-2-99fd2b26e97c58ac46d338de663cb6b09c72b926.tar.gz
gentoo-2-99fd2b26e97c58ac46d338de663cb6b09c72b926.tar.bz2
gentoo-2-99fd2b26e97c58ac46d338de663cb6b09c72b926.zip
fix use invocation
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/mup')
-rw-r--r--media-sound/mup/mup-5.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-sound/mup/mup-5.0.ebuild b/media-sound/mup/mup-5.0.ebuild
index 44d3fe546ec0..d1f6d5e71f5e 100644
--- a/media-sound/mup/mup-5.0.ebuild
+++ b/media-sound/mup/mup-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-5.0.ebuild,v 1.2 2005/05/15 14:44:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-5.0.ebuild,v 1.3 2005/06/28 23:30:46 mr_bones_ Exp $
inherit eutils toolchain-funcs
@@ -34,14 +34,14 @@ src_compile() {
echo $(tc-getCC) ${CFLAGS} -o mkmupfnt *.c
$(tc-getCC) ${CFLAGS} -o mkmupfnt *.c || die "mkmupfnt compile failed"
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
cd ${S}/mupdisp
- if [ `use X` ] ; then
+ if use X ; then
param="-lX11 -L/usr/X11R6/lib"
else
sed -i '/XWINDOW/s:.*::' dispttyp.h
fi
- if [ `use svga` ] ; then
+ if use svga ; then
param="${param} -lvga"
else
param="${param} -DNO_VGA_LIB"
@@ -53,7 +53,7 @@ src_compile() {
src_install() {
dobin mup/mup mkmupfnt/mkmupfnt mupprnt || die
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
dobin mupdisp/mupdisp || die
fi
@@ -61,7 +61,7 @@ src_install() {
cd docs
dodoc *.txt README1
doman mup.1 mkmupfnt.1 mupprnt.1
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
doman mupdisp.1
fi
dohtml uguide/*
@@ -70,7 +70,7 @@ src_install() {
}
pkg_postinst() {
- if [ `use svga` ] ; then
+ if use svga ; then
einfo "Please note that using mupdisp in SVGA mode on the console"
einfo "requires that it can write to the console device. To allow"
einfo "this, make mupdisp setuid to root, like this:"
@@ -78,7 +78,7 @@ pkg_postinst() {
einfo "\tchown root:root /usr/bin/mupdisp"
einfo "\tchmod u+s /usr/bin/mupdisp"
fi
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
echo
einfo "If you want to use mupdisp, make sure you also install ghostscript."
fi