summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-08 00:39:06 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-08 00:39:06 +0000
commit13869c93af398b101e9bba9c87b307517647d292 (patch)
tree7e73ea922beedd4c275b3c5a1eb35b469ba0cf61 /media-sound/mup
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-13869c93af398b101e9bba9c87b307517647d292.tar.gz
gentoo-2-13869c93af398b101e9bba9c87b307517647d292.tar.bz2
gentoo-2-13869c93af398b101e9bba9c87b307517647d292.zip
Fix use invocation and add DEPEND on >=sed-4
Diffstat (limited to 'media-sound/mup')
-rw-r--r--media-sound/mup/ChangeLog6
-rw-r--r--media-sound/mup/mup-4.4.ebuild25
-rw-r--r--media-sound/mup/mup-4.6.ebuild17
3 files changed, 26 insertions, 22 deletions
diff --git a/media-sound/mup/ChangeLog b/media-sound/mup/ChangeLog
index cb4c05968620..d90da628279e 100644
--- a/media-sound/mup/ChangeLog
+++ b/media-sound/mup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mup
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/ChangeLog,v 1.6 2004/04/01 07:45:42 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/ChangeLog,v 1.7 2004/06/08 00:39:06 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mup-4.4.ebuild,
+ mup-4.6.ebuild:
+ Fix use invocation and add DEPEND on >=sed-4
31 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> mup-4.6.ebuild:
Stable x86.
diff --git a/media-sound/mup/mup-4.4.ebuild b/media-sound/mup/mup-4.4.ebuild
index fdeaa8f80ae6..855d2f80ad62 100644
--- a/media-sound/mup/mup-4.4.ebuild
+++ b/media-sound/mup/mup-4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-4.4.ebuild,v 1.5 2004/03/01 05:37:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-4.4.ebuild,v 1.6 2004/06/08 00:39:06 agriffis Exp $
MY_P="${PN}44"
@@ -13,6 +13,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X svga"
+DEPEND=">=sys-apps/sed-4"
RDEPEND="X? ( virtual/x11 )
svga? ( >=media-libs/svgalib-1.4.3 )"
@@ -31,26 +32,24 @@ src_compile() {
local param
cd mup
- cc -O2 -o mup *.c -lm
+ cc -O2 -o mup *.c -lm || die "compile mup failed"
cd ../mkmupfnt
- cc -o mkmupfnt *.c
+ cc -o mkmupfnt *.c || die "compile mkmupfnt failed"
- if [ -n "`use X`" -o -n "`use svga`" ] ; then
+ if use X || use svga; then
cd ../mupdisp
- if [ -n "`use X`" ] ; then
+ if use X ; then
param="-lX11 -L/usr/X11R6/lib"
else
- mv dispttyp.h dispttyp.h.orig
- sed <dispttyp.h.orig >dispttyp.h \
- -e '/^#define XWINDOW/ d'
+ sed -i '/^#define XWINDOW/d' dispttyp.h || die "sed failed"
fi
- if [ -n "`use svga`" ] ; then
+ if use svga ; then
param="${param} -lvga"
else
param="${param} -DNO_VGA_LIB"
fi
- cc -o mupdisp *.c -lm ${param}
+ cc -o mupdisp *.c -lm ${param} || die "compile mupdisp failed"
fi
}
@@ -68,7 +67,7 @@ src_install () {
mkmupfnt.ps mupdisp.ps mupprnt.ps mup.ps mupqref.ps oddeven.ps uguide.ps
doman mup.1 mupprnt.1 mkmupfnt.1
- if [ -n "`use X`" -o -n "`use svga`" ] ; then
+ if use X || use svga; then
doman mupdisp.1
fi
@@ -79,7 +78,7 @@ src_install () {
}
pkg_postinst() {
- if [ "`use svga`" ] ; then
+ if use svga ; then
einfo "Please note that using mupdisp in SVGA mode on the console"
einfo "requires that it can write to the console device. To allow"
einfo "this, make mupdisp setuid to root, like this:"
@@ -87,7 +86,7 @@ pkg_postinst() {
einfo "\tchown root:root /usr/bin/mupdisp"
einfo "\tchmod u+s /usr/bin/mupdisp"
fi
- if [ -n "`use X`" -o -n "`use svga`" ] ; then
+ if use X || use svga; then
echo
einfo "If you want to use mupdisp, make sure you also install ghostscript."
fi
diff --git a/media-sound/mup/mup-4.6.ebuild b/media-sound/mup/mup-4.6.ebuild
index fdd51e3d3efe..6a4bbb59a260 100644
--- a/media-sound/mup/mup-4.6.ebuild
+++ b/media-sound/mup/mup-4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-4.6.ebuild,v 1.3 2004/04/01 07:45:42 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mup/mup-4.6.ebuild,v 1.4 2004/06/08 00:39:06 agriffis Exp $
inherit eutils gcc
@@ -14,6 +14,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X svga"
+DEPEND=">=sys-apps/sed-4"
RDEPEND="X? ( virtual/x11 )
svga? ( >=media-libs/svgalib-1.4.3 )"
@@ -34,14 +35,14 @@ src_compile() {
echo $(gcc-getCC) ${CFLAGS} -o mkmupfnt *.c
$(gcc-getCC) ${CFLAGS} -o mkmupfnt *.c || die "mkmupfnt compile failed"
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
cd ${S}/mupdisp
- if [ `use X` ] ; then
+ if use X ; then
param="-lX11 -L/usr/X11R6/lib"
else
sed -i '/XWINDOW/s:.*::' dispttyp.h
fi
- if [ `use svga` ] ; then
+ if use svga ; then
param="${param} -lvga"
else
param="${param} -DNO_VGA_LIB"
@@ -53,7 +54,7 @@ src_compile() {
src_install() {
dobin mup/mup mkmupfnt/mkmupfnt mupprnt || die
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
dobin mupdisp/mupdisp || die
fi
@@ -61,7 +62,7 @@ src_install() {
cd docs
dodoc *.txt README1
doman mup.1 mkmupfnt.1 mupprnt.1
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
doman mupdisp.1
fi
dohtml uguide/*
@@ -70,7 +71,7 @@ src_install() {
}
pkg_postinst() {
- if [ `use svga` ] ; then
+ if use svga ; then
einfo "Please note that using mupdisp in SVGA mode on the console"
einfo "requires that it can write to the console device. To allow"
einfo "this, make mupdisp setuid to root, like this:"
@@ -78,7 +79,7 @@ pkg_postinst() {
einfo "\tchown root:root /usr/bin/mupdisp"
einfo "\tchmod u+s /usr/bin/mupdisp"
fi
- if [ `use X` ] || [ `use svga` ] ; then
+ if use X || use svga ; then
echo
einfo "If you want to use mupdisp, make sure you also install ghostscript."
fi