summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-10-21 15:27:15 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-10-21 15:27:15 +0000
commit2fd3520a36f48fde0559b24217fa582dee05c8d3 (patch)
tree4b3b5c4b9c645fa5ee895b41cd3f7a70f844bcf1 /media-sound/mpg123/mpg123-0.59s-r11.ebuild
parentamd64 stable (diff)
downloadgentoo-2-2fd3520a36f48fde0559b24217fa582dee05c8d3.tar.gz
gentoo-2-2fd3520a36f48fde0559b24217fa582dee05c8d3.tar.bz2
gentoo-2-2fd3520a36f48fde0559b24217fa582dee05c8d3.zip
GCC 4.2.2 really hates the -faltivec this build system wants to specify, remove it so USE=altivec can actually be used. Quote some vars in an older ebuild to make repoman happy.
(Portage version: 2.1.3.15)
Diffstat (limited to 'media-sound/mpg123/mpg123-0.59s-r11.ebuild')
-rw-r--r--media-sound/mpg123/mpg123-0.59s-r11.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/media-sound/mpg123/mpg123-0.59s-r11.ebuild b/media-sound/mpg123/mpg123-0.59s-r11.ebuild
index 6f0ab87ce78a..092e3616f9a8 100644
--- a/media-sound/mpg123/mpg123-0.59s-r11.ebuild
+++ b/media-sound/mpg123/mpg123-0.59s-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59s-r11.ebuild,v 1.12 2007/03/02 12:47:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59s-r11.ebuild,v 1.13 2007/10/21 15:27:14 chainsaw Exp $
inherit eutils toolchain-funcs
@@ -34,21 +34,21 @@ PATCHDIR="${WORKDIR}/patches"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
EPATCH_SUFFIX="patch"
epatch ${PATCHDIR}
# Bug #70592; terminal line settings should only be set once; not everytime a new song starts
- epatch ${FILESDIR}/${PV}-set-terminal-line-settings-once.patch
+ epatch "${FILESDIR}/${PV}-set-terminal-line-settings-once.patch"
# Bug #87539; user CFLAGS are not respected on amd64
- epatch ${FILESDIR}/${PN}-respectusercflags.patch
+ epatch "${FILESDIR}/${PN}-respectusercflags.patch"
if use ppc-macos;
then
einfo "Patching for OSX build"
- epatch ${FILESDIR}/${PN}-osx.diff
+ epatch "${FILESDIR}/${PN}-osx.diff"
fi
sed -i "s:${PV}-mh4:${PVR}:" version.h
@@ -139,7 +139,7 @@ src_compile() {
src_install() {
dodir /usr
- cp -R gentoo-bin ${D}/usr/bin
+ cp -R gentoo-bin "${D}/usr/bin"
doman mpg123.1
dodoc BENCHMARKING BUGS CHANGES JUKEBOX README* TODO
}