summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-11 19:13:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-11 19:13:39 +0000
commitff2aa6d1c5b53646b8af6ce2557b40f864b15c69 (patch)
tree2143684845a51281507a7c62f62aca170e81a4e1 /media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild
parentversion bump (diff)
downloadgentoo-2-ff2aa6d1c5b53646b8af6ce2557b40f864b15c69.tar.gz
gentoo-2-ff2aa6d1c5b53646b8af6ce2557b40f864b15c69.tar.bz2
gentoo-2-ff2aa6d1c5b53646b8af6ce2557b40f864b15c69.zip
version bump
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild')
-rw-r--r--media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild b/media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild
new file mode 100644
index 000000000000..b6fb472f7a8d
--- /dev/null
+++ b/media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/mhwaveedit-1.4.15.ebuild,v 1.1 2008/05/11 19:13:39 aballier Exp $
+
+inherit eutils
+
+IUSE="alsa arts esd jack ladspa libsamplerate nls oss portaudio sdl sndfile sox"
+
+DESCRIPTION="GTK2 Sound file editor (wav, and a few others.)"
+HOMEPAGE="https://gna.org/projects/mhwaveedit/"
+SRC_URI="http://download.gna.org/mhwaveedit/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2
+ sndfile? ( >=media-libs/libsndfile-1.0.10 )
+ sdl? ( >=media-libs/libsdl-1.2.3 )
+ alsa? ( media-libs/alsa-lib )
+ portaudio? ( >=media-libs/portaudio-18 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98.0 )
+ esd? ( >=media-sound/esound-0.2.0 )
+ libsamplerate? ( media-libs/libsamplerate )
+ ladspa? ( media-libs/ladspa-sdk )
+ sox? ( media-sound/sox )
+ arts? ( >=kde-base/arts-3.4.1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with sndfile libsndfile) \
+ $(use_with libsamplerate) \
+ $(use_with portaudio) \
+ $(use_with sdl) \
+ $(use_with alsa alsalib) \
+ $(use_with oss) \
+ $(use_with jack) \
+ $(use_with esd esound) \
+ $(use_with arts) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README TODO
+}