summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-01 06:24:47 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-01 06:24:47 +0000
commit6137c6463db8998f51e7b523c99043708f9f869d (patch)
treeae791e4b58b04a0dbd3e33ca0e9c7efd038d7f09 /media-sound/longplayer/files
parentadd description (diff)
downloadgentoo-2-6137c6463db8998f51e7b523c99043708f9f869d.tar.gz
gentoo-2-6137c6463db8998f51e7b523c99043708f9f869d.tar.bz2
gentoo-2-6137c6463db8998f51e7b523c99043708f9f869d.zip
Version bump already.
Diffstat (limited to 'media-sound/longplayer/files')
-rw-r--r--media-sound/longplayer/files/digest-longplayer-0.99.31
-rw-r--r--media-sound/longplayer/files/longplayer-0.99.3-gentoo.patch68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/longplayer/files/digest-longplayer-0.99.3 b/media-sound/longplayer/files/digest-longplayer-0.99.3
new file mode 100644
index 000000000000..decbe7c4cf3d
--- /dev/null
+++ b/media-sound/longplayer/files/digest-longplayer-0.99.3
@@ -0,0 +1 @@
+MD5 d7d965bae3cd6a14ee058bd386bc334c lplayer-0.99.3_src.tgz 1352672
diff --git a/media-sound/longplayer/files/longplayer-0.99.3-gentoo.patch b/media-sound/longplayer/files/longplayer-0.99.3-gentoo.patch
new file mode 100644
index 000000000000..aea194e276a2
--- /dev/null
+++ b/media-sound/longplayer/files/longplayer-0.99.3-gentoo.patch
@@ -0,0 +1,68 @@
+diff -Naur lplayer-0.99.3.orig/configure.in.in lplayer-0.99.3/configure.in.in
+--- lplayer-0.99.3.orig/configure.in.in 2004-04-01 01:31:59.000000000 +0200
++++ lplayer-0.99.3/configure.in.in 2004-04-01 01:34:15.000000000 +0200
+@@ -19,16 +19,16 @@
+ [if test "$enableval" = yes; then
+ use_berkeleydb=yes
+ BERKELEYOBJS='lpberkeleydbreader.$(OBJEXT)'
++ BERKELEYLIBS='-ldb_cxx-4.1'
+ fi],
+ [])
+
+ if test "$use_berkeleydb" = yes; then
+- AC_CHECK_LIB([db_cxx], [main], [],
+- AC_MSG_ERROR([Berkeley DB library not found]))
+- AC_CHECK_HEADER([db_cxx.h],[],
++ AC_CHECK_HEADER([db4.1/db_cxx.h],[],
+ AC_MSG_ERROR([Berkeley DB includes not found]))
+ fi
+
+ AC_SUBST(BERKELEYOBJS)
++AC_SUBST(BERKELEYLIBS)
+
+ AC_CONFIG_FILES([src/longplayer])
+diff -Naur lplayer-0.99.3.orig/src/Makefile.am lplayer-0.99.3/src/Makefile.am
+--- lplayer-0.99.3.orig/src/Makefile.am 2004-04-01 01:31:58.000000000 +0200
++++ lplayer-0.99.3/src/Makefile.am 2004-04-01 01:35:35.000000000 +0200
+@@ -17,8 +17,8 @@
+ #lplayer_LDFLAGS = $(KDE_RPATH) $(all_libraries) $(XMMS_LIBS)
+
+ # the libraries to link against.
+-lplayer_LDADD = @BERKELEYOBJS@ $(LIB_QT) $(LIB_X11)
+-lplayer_DEPENDENCIES = @BERKELEYOBJS@
++lplayer_LDADD = $(BERKELEYOBJS) $(BERKELEYLIBS) $(LIB_QT) $(LIB_X11)
++lplayer_DEPENDENCIES = $(BERKELEYOBJS)
+ # for kde...
+ #lplayer_LDADD = $(LIB_KFILE) $(LIB_KDEPRINT)
+
+diff -Naur lplayer-0.99.3.orig/src/Makefile.in lplayer-0.99.3/src/Makefile.in
+--- lplayer-0.99.3.orig/src/Makefile.in 2004-04-01 01:31:58.000000000 +0200
++++ lplayer-0.99.3/src/Makefile.in 2004-04-01 01:37:47.000000000 +0200
+@@ -48,6 +48,7 @@
+ AUTOMAKE = @AUTOMAKE@
+ AWK = @AWK@
+ BERKELEYOBJS = @BERKELEYOBJS@
++BERKELEYLIBS = @BERKELEYLIBS@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+@@ -213,8 +214,8 @@
+ #lplayer_LDFLAGS = $(KDE_RPATH) $(all_libraries) $(XMMS_LIBS)
+
+ # the libraries to link against.
+-lplayer_LDADD = @BERKELEYOBJS@ $(LIB_QT) $(LIB_X11)
+-lplayer_DEPENDENCIES = @BERKELEYOBJS@
++lplayer_LDADD = $(BERKELEYOBJS) $(BERKELEYLIBS) $(LIB_QT) $(LIB_X11)
++lplayer_DEPENDENCIES = $(BERKELEYOBJS)
+
+ # for kde...
+ #lplayer_LDADD = $(LIB_KFILE) $(LIB_KDEPRINT)
+diff -Naur lplayer-0.99.3.orig/src/lpberkeleydbreader.cpp lplayer-0.99.3/src/lpberkeleydbreader.cpp
+--- lplayer-0.99.3.orig/src/lpberkeleydbreader.cpp 2004-04-01 01:31:58.000000000 +0200
++++ lplayer-0.99.3/src/lpberkeleydbreader.cpp 2004-04-01 01:38:26.000000000 +0200
+@@ -1,4 +1,4 @@
+-#include <db_cxx.h>
++#include <db4.1/db_cxx.h>
+ #include <cstring>
+ #include <iostream>//FIXME: temporary
+ #include <sstream>