summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-08 10:07:28 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-08 10:07:28 +0000
commit61dbafcd3cab37bb07186d611dc37624df7dc51f (patch)
tree394a44375b0c791f6b1a8c20d4bf3bd09aabb3f2 /media-sound/lame
parentFix flag-o-matic usage. Closes #20400. (diff)
downloadgentoo-2-61dbafcd3cab37bb07186d611dc37624df7dc51f.tar.gz
gentoo-2-61dbafcd3cab37bb07186d611dc37624df7dc51f.tar.bz2
gentoo-2-61dbafcd3cab37bb07186d611dc37624df7dc51f.zip
Fix flag-o-matic usage. Closes #20400.
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog5
-rw-r--r--media-sound/lame/Manifest4
-rw-r--r--media-sound/lame/lame-3.93.1-r1.ebuild8
3 files changed, 10 insertions, 7 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 8feb22686597..604321454266 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.20 2003/03/13 18:19:22 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.21 2003/05/08 10:07:11 jje Exp $
+
+ 08 May 2003; jje <jje@gentoo.org> lame-3.93.1-r1.ebuild:
+ Fix flag striping. Was using strip-flags when it should have been filter-flags.
13 Mar 2003; Olivier Reisch <doctomoe@gentoo.org> lame-3.93.1-r1.ebuild
Marked ppc stable
diff --git a/media-sound/lame/Manifest b/media-sound/lame/Manifest
index 982828500cf1..89a80e8c93d5 100644
--- a/media-sound/lame/Manifest
+++ b/media-sound/lame/Manifest
@@ -1,6 +1,6 @@
-MD5 03c4ea569707da29b0b9c4950c57db2a ChangeLog 3750
+MD5 305467918f7da2f9d91abbd0a99c2312 ChangeLog 3745
MD5 322253260f0ae7aed4b1770f9e16164c lame-3.92.ebuild 1572
-MD5 a4c108035cbef4af86f3a854277e2075 lame-3.93.1-r1.ebuild 1505
+MD5 bd5637572a0143953a99d7bb547bf0a5 lame-3.93.1-r1.ebuild 1500
MD5 2b1af4843f5ca4107de793b7a584db34 files/digest-lame-3.92 61
MD5 aefad4480f6888fcee536e08205804b1 files/digest-lame-3.93.1-r1 64
MD5 1dfbfacec1d8f89bf39620c15becb6bc files/lame-3.91-gcc3.diff 383
diff --git a/media-sound/lame/lame-3.93.1-r1.ebuild b/media-sound/lame/lame-3.93.1-r1.ebuild
index 3d726852d425..41e2c5eb02f3 100644
--- a/media-sound/lame/lame-3.93.1-r1.ebuild
+++ b/media-sound/lame/lame-3.93.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1-r1.ebuild,v 1.4 2003/03/13 18:19:22 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1-r1.ebuild,v 1.5 2003/05/08 10:07:11 jje Exp $
inherit flag-o-matic
@@ -26,9 +26,9 @@ src_compile() {
sed -e "s:gtk12-config:gtk-config:" < configure.orig > configure
# take out -fomit-frame-pointer from CFLAGS if k6-2
- is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
- is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
- is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
local myconf=""
if [ "`use gtk`" ] ; then