summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 21:08:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 21:08:01 +0000
commit9451eb2892eea279cb763ca59984f582c11c4a89 (patch)
treed1d3403f8aa9f2ca271e5f71018fc78270bf5a33 /media-sound/jack
parentBug #266157: Update deblob max version. (diff)
downloadgentoo-2-9451eb2892eea279cb763ca59984f582c11c4a89.tar.gz
gentoo-2-9451eb2892eea279cb763ca59984f582c11c4a89.tar.bz2
gentoo-2-9451eb2892eea279cb763ca59984f582c11c4a89.zip
Use Python 2 (bug #313951).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/jack')
-rw-r--r--media-sound/jack/ChangeLog8
-rw-r--r--media-sound/jack/jack-3.0.0.ebuild22
-rw-r--r--media-sound/jack/jack-3.1.1.ebuild29
3 files changed, 35 insertions, 24 deletions
diff --git a/media-sound/jack/ChangeLog b/media-sound/jack/ChangeLog
index 2e3d064063de..e67c647696d6 100644
--- a/media-sound/jack/ChangeLog
+++ b/media-sound/jack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/jack
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/ChangeLog,v 1.18 2007/06/02 16:16:02 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/ChangeLog,v 1.19 2010/05/28 21:08:01 arfrever Exp $
+
+ 28 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ jack-3.0.0.ebuild, jack-3.1.1.ebuild:
+ Use Python 2 (bug #313951).
02 Jun 2007; nixnut <nixnut@gentoo.org> jack-3.1.1.ebuild:
Stable on ppc wrt bug 172952
diff --git a/media-sound/jack/jack-3.0.0.ebuild b/media-sound/jack/jack-3.0.0.ebuild
index 341250c39519..7f128165f7cd 100644
--- a/media-sound/jack/jack-3.0.0.ebuild
+++ b/media-sound/jack/jack-3.0.0.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-3.0.0.ebuild,v 1.13 2009/08/03 13:04:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-3.0.0.ebuild,v 1.14 2010/05/28 21:08:01 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils
@@ -13,8 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-DEPEND="dev-lang/python
- sys-libs/ncurses"
+DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}
dev-python/cddb-py
dev-python/id3-py
@@ -24,6 +26,11 @@ RDEPEND="${DEPEND}
media-sound/lame
media-sound/cdparanoia"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_compile() {
python setup-cursesmodule.py build || die "compilation failed"
}
@@ -34,10 +41,9 @@ src_install() {
dobin jack || die "dobin failed"
- distutils_python_version
- dodir /usr/$(get_libdir)/python${PYVER}/site-packages
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doins jack_*py
+ insinto $(python_get_sitedir)
+ PYTHON_MODNAME="$(ls jack_*.py)"
+ doins ${PYTHON_MODNAME}
newman jack.man jack.1
diff --git a/media-sound/jack/jack-3.1.1.ebuild b/media-sound/jack/jack-3.1.1.ebuild
index 1084d31c44d4..d86f2e9c5bdd 100644
--- a/media-sound/jack/jack-3.1.1.ebuild
+++ b/media-sound/jack/jack-3.1.1.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-3.1.1.ebuild,v 1.7 2009/08/03 13:04:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-3.1.1.ebuild,v 1.8 2010/05/28 21:08:01 arfrever Exp $
-inherit distutils multilib
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
DESCRIPTION="A frontend for several cd-rippers and mp3 encoders"
HOMEPAGE="http://www.home.unix-ag.org/arne/jack/"
@@ -13,8 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-DEPEND="dev-lang/python
- sys-libs/ncurses"
+DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}
dev-python/cddb-py
dev-python/id3-py
@@ -24,20 +26,19 @@ RDEPEND="${DEPEND}
media-sound/lame
media-sound/cdparanoia"
-src_compile() {
- python setup.py build || die "compilation failed"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
}
src_install() {
- python setup.py install --root="${D}" \
- || die "installation failed"
+ distutils_src_install
- dobin jack
+ dobin jack || die "dobin failed"
- distutils_python_version
- dodir /usr/$(get_libdir)/python${PYVER}/site-packages
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doins jack_*py
+ insinto $(python_get_sitedir)
+ PYTHON_MODNAME="$(ls jack_*.py)"
+ doins ${PYTHON_MODNAME}
newman jack.man jack.1