summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-13 01:04:44 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-13 01:04:44 +0000
commit3826d7bafadc4052f376ad7ac917cd823053f810 (patch)
treedaa2978f2675fc4a083f21ff2295b87f1a31983a /media-sound/grip/grip-3.3.0.ebuild
parentrollback to ~x86 (diff)
downloadgentoo-2-3826d7bafadc4052f376ad7ac917cd823053f810.tar.gz
gentoo-2-3826d7bafadc4052f376ad7ac917cd823053f810.tar.bz2
gentoo-2-3826d7bafadc4052f376ad7ac917cd823053f810.zip
new upstream version, fixes #84223. added a patch to fix a buffer overflow, see #84704
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/grip/grip-3.3.0.ebuild')
-rw-r--r--media-sound/grip/grip-3.3.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/grip/grip-3.3.0.ebuild b/media-sound/grip/grip-3.3.0.ebuild
new file mode 100644
index 000000000000..7c162b40bf21
--- /dev/null
+++ b/media-sound/grip/grip-3.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.3.0.ebuild,v 1.1 2005/03/13 01:04:44 luckyduck Exp $
+
+inherit gnuconfig flag-o-matic eutils
+
+IUSE="nls oggvorbis"
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper."
+HOMEPAGE="http://www.nostatic.org/grip"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~ppc64"
+
+RDEPEND=">=x11-libs/gtk+-2.2
+ x11-libs/vte
+ =sys-libs/db-1*
+ media-sound/lame
+ media-sound/cdparanoia
+ >=media-libs/id3lib-3.8.3
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/orbit-2
+ gnome-base/libghttp
+ net-misc/curl
+ oggvorbis? ( media-sound/vorbis-tools )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # see #84704
+ epatch ${FILESDIR}/${PV}-crashfix.patch
+
+ gnuconfig_update
+}
+
+src_compile() {
+ # Bug #69536
+ use x86 && append-flags "-mno-sse"
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CREDITS ChangeLog README TODO
+}