summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-05 09:50:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-05 09:50:05 +0000
commitc37225399f261b703e3e66903b12edb1e6f3a792 (patch)
tree770dcb8503d020e210a92ad3679e8c66c51cd8e3 /media-sound/giada
parentVersion bump. Add debug, openmp, and sse2 use flags. (diff)
downloadgentoo-2-c37225399f261b703e3e66903b12edb1e6f3a792.tar.gz
gentoo-2-c37225399f261b703e3e66903b12edb1e6f3a792.tar.bz2
gentoo-2-c37225399f261b703e3e66903b12edb1e6f3a792.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/giada')
-rw-r--r--media-sound/giada/ChangeLog7
-rw-r--r--media-sound/giada/giada-0.6.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/media-sound/giada/ChangeLog b/media-sound/giada/ChangeLog
index 6e840b00e873..19986d8cc6e9 100644
--- a/media-sound/giada/ChangeLog
+++ b/media-sound/giada/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/giada
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.9 2013/03/30 05:10:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.10 2013/04/05 09:50:05 radhermit Exp $
+
+*giada-0.6.2 (05 Apr 2013)
+
+ 05 Apr 2013; Tim Harder <radhermit@gentoo.org> +giada-0.6.2.ebuild:
+ Version bump.
30 Mar 2013; Tim Harder <radhermit@gentoo.org> -giada-0.5.8.ebuild,
-giada-0.6.0.ebuild:
diff --git a/media-sound/giada/giada-0.6.2.ebuild b/media-sound/giada/giada-0.6.2.ebuild
new file mode 100644
index 000000000000..321404901b47
--- /dev/null
+++ b/media-sound/giada/giada-0.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/giada-0.6.2.ebuild,v 1.1 2013/04/05 09:50:05 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A free, minimal, hardcore audio tool for djs and live performers"
+HOMEPAGE="http://www.giadamusic.com/"
+SRC_URI="http://www.giadamusic.com/download-action.php?os=source&version=${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack pulseaudio"
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="media-libs/libsndfile
+ >=media-libs/libsamplerate-0.1.8
+ media-libs/rtaudio[alsa?,jack?,pulseaudio?]
+ x11-libs/fltk:1
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.4-flags.patch
+ epatch "${FILESDIR}"/${PN}-0.5.8-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -I/usr/include/fltk-1
+ append-ldflags -L/usr/$(get_libdir)/fltk-1
+
+ econf \
+ --target=linux \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable pulseaudio pulse)
+}