summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-15 12:22:23 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-15 12:22:23 +0000
commitb08f9730a2a39842695e652d2dfa6cff8819a573 (patch)
tree5858f4b89d75e9930c64c1a638467b1212dbc8b4 /media-sound/ecasound
parentVersion bump wrt security #180436 (diff)
downloadgentoo-2-b08f9730a2a39842695e652d2dfa6cff8819a573.tar.gz
gentoo-2-b08f9730a2a39842695e652d2dfa6cff8819a573.tar.bz2
gentoo-2-b08f9730a2a39842695e652d2dfa6cff8819a573.zip
Version bump for bug 169371. Thanks to Risto Paju.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog9
-rw-r--r--media-sound/ecasound/ecasound-2.4.5.ebuild99
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.4.53
3 files changed, 109 insertions, 2 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index a323823b69e1..de6f47d21ecd 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ecasound
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.38 2006/07/08 23:25:54 fvdpol Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.39 2007/06/15 12:22:23 drac Exp $
+
+*ecasound-2.4.5 (15 Jun 2007)
+
+ 15 Jun 2007; Samuli Suominen <drac@gentoo.org> +ecasound-2.4.5.ebuild:
+ Version bump for bug 169371. Thanks to Risto Paju.
*ecasound-2.4.4 (08 Jul 2006)
diff --git a/media-sound/ecasound/ecasound-2.4.5.ebuild b/media-sound/ecasound/ecasound-2.4.5.ebuild
new file mode 100644
index 000000000000..731355b693aa
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.4.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.5.ebuild,v 1.1 2007/06/15 12:22:23 drac Exp $
+
+inherit multilib
+
+DESCRIPTION="a package for multitrack audio processing"
+SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )
+ sys-libs/readline"
+DEPEND="${RDEPEND}"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_compile () {
+ local myconf
+
+ myconf="${myconf} --enable-shared --with-largefile --enable-sys-readline"
+
+ if use python; then
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ local python_version python_prefix python_includes python_modules
+ if use userland_Darwin ; then
+ myconf="$myconf --enable-pyecasound=python"
+ else
+ myconf="$myconf --enable-pyecasound=c"
+ fi
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/$(get_libdir)/python$python_version"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ econf \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ ${myconf}
+
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ if use python; then
+ cd pyecasound
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc BUGS NEWS README TODO Documentation/*.txt
+ use doc && dohtml Documentation/*.html
+}
+
+pkg_postinst() {
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.4.5 b/media-sound/ecasound/files/digest-ecasound-2.4.5
new file mode 100644
index 000000000000..5ba066946140
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.4.5
@@ -0,0 +1,3 @@
+MD5 b5a4f39245e505941f26c5c2c3b80e1c ecasound-2.4.5.tar.gz 946918
+RMD160 fec2a974d8014b1530b51044678b76540ba1f9aa ecasound-2.4.5.tar.gz 946918
+SHA256 462f5c395ead6559ba17f4bde113084fa543660bd8637cc9d686cedc481d4768 ecasound-2.4.5.tar.gz 946918