summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-06-07 19:36:01 +0000
committerSteve Dibb <beandog@gentoo.org>2010-06-07 19:36:01 +0000
commitde281d883296db9e9ab1c4d568d7bcfd533f90f6 (patch)
treef42a14cdc040410068c4e94cf6ec8440c0af9e13 /media-sound/decibel-audio-player
parentnasty hack to fix buildsystem's and portage variable collision, wrt bug #322527 (diff)
downloadgentoo-2-de281d883296db9e9ab1c4d568d7bcfd533f90f6.tar.gz
gentoo-2-de281d883296db9e9ab1c4d568d7bcfd533f90f6.tar.bz2
gentoo-2-de281d883296db9e9ab1c4d568d7bcfd533f90f6.zip
Version bump, bug 320093
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/decibel-audio-player')
-rw-r--r--media-sound/decibel-audio-player/ChangeLog8
-rw-r--r--media-sound/decibel-audio-player/decibel-audio-player-1.04.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/media-sound/decibel-audio-player/ChangeLog b/media-sound/decibel-audio-player/ChangeLog
index eb359bac5456..d92c621ee1f9 100644
--- a/media-sound/decibel-audio-player/ChangeLog
+++ b/media-sound/decibel-audio-player/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/decibel-audio-player
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/decibel-audio-player/ChangeLog,v 1.20 2010/05/09 17:35:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/decibel-audio-player/ChangeLog,v 1.21 2010/06/07 19:36:01 beandog Exp $
+
+*decibel-audio-player-1.04 (07 Jun 2010)
+
+ 07 Jun 2010; Steve Dibb <beandog@gentoo.org>
+ +decibel-audio-player-1.04.ebuild:
+ Version bump, bug 320093
09 May 2010; Raúl Porcel <armin76@gentoo.org>
decibel-audio-player-1.00.ebuild:
diff --git a/media-sound/decibel-audio-player/decibel-audio-player-1.04.ebuild b/media-sound/decibel-audio-player/decibel-audio-player-1.04.ebuild
new file mode 100644
index 000000000000..7e45ca124232
--- /dev/null
+++ b/media-sound/decibel-audio-player/decibel-audio-player-1.04.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/decibel-audio-player/decibel-audio-player-1.04.ebuild,v 1.1 2010/06/07 19:36:01 beandog Exp $
+
+DESCRIPTION="A GTK+ audio player which aims at being very straightforward to use."
+HOMEPAGE="http://decibel.silent-blade.org"
+SRC_URI="http://decibel.silent-blade.org/uploads/Main/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="aac cdda gnome gnome-keyring libnotify musepack wavpack"
+
+RDEPEND="media-libs/mutagen
+ dev-python/dbus-python
+ dev-python/gst-python
+ dev-python/imaging
+ >=media-plugins/gst-plugins-meta-0.10-r2
+ aac? ( media-plugins/gst-plugins-faad )
+ cdda? ( || ( media-plugins/gst-plugins-cdio
+ media-plugins/gst-plugins-cdparanoia )
+ dev-python/cddb-py )
+ gnome? ( dev-python/gnome-python-base )
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ libnotify? ( dev-python/notify-python )
+ musepack? ( media-plugins/gst-plugins-musepack )
+ wavpack? ( media-plugins/gst-plugins-wavpack )"
+DEPEND="sys-devel/gettext"
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr \
+ install || die "emake install failed"
+ dodoc doc/ChangeLog || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Please read the Decibel guide at"
+ elog "http://www.gentoo.org/proj/en/desktop/sound/decibel.xml; it contains"
+ elog "information on how to enable various features and audio formats."
+}