summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-22 17:25:02 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-22 17:25:02 +0000
commitc41bb7b696046e0614b6061df1e6dfc1f66b55d9 (patch)
tree07c9cdfaf5c77dcca3f620594b8d4f89f683a770 /media-sound/awesfx/awesfx-0.5.1d.ebuild
parentRemasked php-5.2. Also masked ebuilds only available for 5.2 (diff)
downloadgentoo-2-c41bb7b696046e0614b6061df1e6dfc1f66b55d9.tar.gz
gentoo-2-c41bb7b696046e0614b6061df1e6dfc1f66b55d9.tar.bz2
gentoo-2-c41bb7b696046e0614b6061df1e6dfc1f66b55d9.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/awesfx/awesfx-0.5.1d.ebuild')
-rw-r--r--media-sound/awesfx/awesfx-0.5.1d.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/awesfx/awesfx-0.5.1d.ebuild b/media-sound/awesfx/awesfx-0.5.1d.ebuild
new file mode 100644
index 000000000000..2fa7c17b9e24
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.1d.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.1d.ebuild,v 1.1 2011/08/22 17:25:02 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="AWE32 Sound Driver Utility Programs"
+HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
+SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
+
+DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/usr/share/sounds/sf2/README-bank
+ newinitd "${FILESDIR}"/sfxload.initd sfxload
+ newconfd "${FILESDIR}"/sfxload.confd sfxload
+}
+
+pkg_postinst() {
+ elog "Copy your SoundFont files from the original CDROM"
+ elog "shipped with your soundcard to ${BANK_LOC}."
+}