summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-31 03:32:12 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-31 03:32:12 +0000
commit0071809a2e4f5db63d2af65903a8da0783fae1f0 (patch)
tree4042aceb9ea193fc301d11b526b07580b617f496 /media-sound/alsa-driver
parentAdded Slovak longdescription for net-mail category. (diff)
downloadgentoo-2-0071809a2e4f5db63d2af65903a8da0783fae1f0.tar.gz
gentoo-2-0071809a2e4f5db63d2af65903a8da0783fae1f0.tar.bz2
gentoo-2-0071809a2e4f5db63d2af65903a8da0783fae1f0.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.9_rc2.ebuild160
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.9_rc21
3 files changed, 168 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index c2a10abb6552..46f2d191e647 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.138 2005/03/31 00:28:18 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.139 2005/03/31 03:32:12 eradicator Exp $
+
+*alsa-driver-1.0.9_rc2 (31 Mar 2005)
+
+ 31 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +alsa-driver-1.0.9_rc2.ebuild:
+ Version bump.
30 Mar 2005; Daniel Ostrow <dostrow@gentoo.org> alsa-driver-1.0.8.ebuild:
Stable on ppc64
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.9_rc2.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.9_rc2.ebuild
new file mode 100644
index 000000000000..b58b2ab79487
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.9_rc2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9_rc2.ebuild,v 1.1 2005/03/31 03:32:12 eradicator Exp $
+
+IUSE="oss doc"
+inherit linux-mod flag-o-matic eutils
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/modutils
+ ~media-sound/alsa-headers-${PV}"
+
+DEPEND="${RDEPEND}
+ sys-devel/patch
+ virtual/linux-sources
+ >=sys-devel/autoconf-2.50
+ sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+ # By default, drivers for all supported cards will be compiled.
+ # If you want to only compile for specific card(s), set ALSA_CARDS
+ # environment to a space-separated list of drivers that you want to build.
+ # For example:
+ #
+ # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+ #
+ ALSA_CARDS=${ALSA_CARDS:-all}
+
+ # Which drivers need PNP
+ local PNP_DRIVERS="interwave interwave-stb"
+
+ CONFIG_CHECK="SOUND !SND !SOUND_PRIME"
+ SND_ERROR="ALSA is already compiled into the kernel."
+ SOUND_ERROR="Your kernel doesn't have sound support enabled."
+ SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
+ PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ if [[ "${ALSA_CARDS}" == "all" ]]; then
+ CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ else
+ for pnpdriver in ${PNP_DRIVERS}; do
+ hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ done
+ fi
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ convert_to_m ${S}/Makefile
+}
+
+src_compile() {
+ # Should fix bug #46901
+ is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+
+ econf `use_with oss` \
+ --with-kernel="${KV_DIR}" \
+ --with-build="${KV_OUT_DIR}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+ # linux-mod_src_compile doesn't work well with alsa
+
+ # -j1 : see bug #71028
+ set_arch_to_kernel
+ emake -j1 || die "Make Failed"
+ set_arch_to_portage
+
+ if use doc;
+ then
+ ebegin "Building Documentation"
+ cd ${S}/scripts
+ emake || die Failed making docs in ${S}/scripts
+
+ cd ${S}/doc/DocBook
+ emake || die Failed making docs in ${S}/doc/DocBook
+ eend $?
+ fi
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+
+ make DESTDIR=${D} install || die
+
+ # Provided by alsa-headers now
+ rm -rf ${D}/usr/include/sound
+
+ # We have our own scripts in alsa-utils
+ test -e ${D}/etc/init.d/alsasound && rm ${D}/etc/init.d/alsasound
+ test -e ${D}/etc/rc.d/init.d/alsasound && rm ${D}/etc/rc.d/init.d/alsasound
+
+ dodoc CARDS-STATUS INSTALL FAQ README WARNING TODO
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
+
+ docinto DocBook
+ dodoc doc/DocBook/*
+ rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
+
+ docinto Documentation
+ dodoc sound/Documentation/*
+ fi
+
+ if kernel_is 2 6; then
+ # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+ mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
+ rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+ einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+ einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+ einfo
+
+
+ linux-mod_pkg_postinst
+
+ einfo "Check out the ALSA installation guide availible at the following URL:"
+ einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+ if kernel_is 2 6; then
+ # Cleanup if they had older alsa installed
+ for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+ rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+ done
+
+ for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
+ rmdir ${dir}
+ done
+ fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.9_rc2 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.9_rc2
new file mode 100644
index 000000000000..1439d043f51f
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.9_rc2
@@ -0,0 +1 @@
+MD5 b21eac1d74c9fb7583e3c641629d5178 alsa-driver-1.0.9rc2.tar.bz2 1996086