summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-07 21:29:48 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-07 21:29:48 +0000
commitb393b7ca118905eddae739206398aa9108c9ba1e (patch)
tree494381ae6aeb617ee2aaa85f0ce031f920697d79 /media-plugins
parentVersion bump. Thanks to everyone in bug #126615. (diff)
downloadgentoo-2-b393b7ca118905eddae739206398aa9108c9ba1e.tar.gz
gentoo-2-b393b7ca118905eddae739206398aa9108c9ba1e.tar.bz2
gentoo-2-b393b7ca118905eddae739206398aa9108c9ba1e.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog8
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc4.ebuild78
-rw-r--r--media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc43
3 files changed, 88 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 3d78083ca7dc..52ac0f05b687 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.52 2007/05/01 09:55:51 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.53 2007/05/07 21:29:48 genstef Exp $
+
+*alsa-plugins-1.0.14_rc4 (07 May 2007)
+
+ 07 May 2007; Stefan Schweizer <genstef@gentoo.org>
+ +alsa-plugins-1.0.14_rc4.ebuild:
+ version bump
01 May 2007; Markus Rothe <corsair@gentoo.org>
alsa-plugins-1.0.14_rc2.ebuild:
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc4.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc4.ebuild
new file mode 100644
index 000000000000..6799fa375844
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc4.ebuild,v 1.1 2007/05/07 21:29:48 genstef Exp $
+
+WANT_AUTOMAKE=latest
+WANT_AUTOCONF=latest
+
+inherit libtool autotools eutils flag-o-matic
+
+MY_P="${P/_/}"
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="jack ffmpeg libsamplerate pulseaudio debug"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.12_rc1
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ ffmpeg? ( media-video/ffmpeg )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.14_rc1-automagic.patch"
+ epatch "${FILESDIR}/${PN}-1.0.14_rc1-init-ffmpeg.patch"
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ eautoreconf
+
+ elibtoolize
+}
+
+src_compile() {
+ use debug || append-flags -DNDEBUG
+
+ # D-Bus is used for Maemo SDK, that standing to the
+ # changelog is related to n770... disable it until
+ # someone ask for it explicitely, to be on the safe
+ # side.
+ econf \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable pulseaudio) \
+ --disable-dbus \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-pulse
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+}
diff --git a/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc4 b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc4
new file mode 100644
index 000000000000..2c3543a340f9
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc4
@@ -0,0 +1,3 @@
+MD5 9a03fb2cbf731853a4168f03acb5804c alsa-plugins-1.0.14rc4.tar.bz2 303246
+RMD160 702ee5962aa2dd098009e0cb05ebe7c698e9325c alsa-plugins-1.0.14rc4.tar.bz2 303246
+SHA256 4fc09d78e3bdfad7c04906415eb90c319b6bf836b89f29c50a50d7a998e3bf42 alsa-plugins-1.0.14rc4.tar.bz2 303246