summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-10-23 14:28:26 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-10-23 14:28:26 +0000
commit5db672ca898295705f637388b00cc484f8156d5f (patch)
tree34819cc523e91905a5587a17a1d50235fe5ebdaf /media-plugins
parentStable for HPPA (bug #287239). (diff)
downloadgentoo-2-5db672ca898295705f637388b00cc484f8156d5f.tar.gz
gentoo-2-5db672ca898295705f637388b00cc484f8156d5f.tar.bz2
gentoo-2-5db672ca898295705f637388b00cc484f8156d5f.zip
fixed compile for graphtft-fe
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog7
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff22
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff15
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild9
4 files changed, 45 insertions, 8 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 2a928eb75edc..a5dc6a768626 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.20 2009/10/22 15:46:59 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.21 2009/10/23 14:28:25 hd_brummy Exp $
+
+ 23 Oct 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-graphtft-0.3.2.24.ebuild, files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff,
+ files/vdr-graphtft-0.3.2.24_makefile.diff:
+ fixed compile for graphtft-fe
22 Oct 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
files/vdr-graphtft-0.3.2.24_makefile.diff:
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
index 90bc2405be3c..da23096138fe 100644
--- a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
@@ -48,3 +48,25 @@ diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/theme.c vdr-plugin-gr
{
tell(0, "Parsing of [%s] failed, missing bracket '}'", expression);
return fail;
+diff -Naur graphtft-24.orig/graphtft-fe/common.cc graphtft-24/graphtft-fe/common.cc
+--- graphtft-24.orig/graphtft-fe/common.cc 2009-10-23 15:10:20.000000000 +0200
++++ graphtft-24/graphtft-fe/common.cc 2009-10-23 15:11:11.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include <graphtft.hpp>
+
+diff -Naur graphtft-24.orig/graphtft-fe/graphtft.hpp graphtft-24/graphtft-fe/graphtft.hpp
+--- graphtft-24.orig/graphtft-fe/graphtft.hpp 2009-10-23 15:10:20.000000000 +0200
++++ graphtft-24/graphtft-fe/graphtft.hpp 2009-10-23 15:11:36.000000000 +0200
+@@ -16,6 +16,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #define __FRONTEND
+ #include <../common.h>
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
index 5e9c3e885f30..f638be630069 100644
--- a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
@@ -1,4 +1,5 @@
-Joerg Bornkessel <hd_brummy@g.o> 22 Aug 2009
+Joerg Bornkessel <hd_brummy@g.o> 22 Okt 2009
+Matthias Schwarzott <zzam@g.o> 23 Okt 2009
diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
+++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
@@ -52,3 +53,15 @@ diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefil
AR = ar
TARGET = graphtft-fe
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-23 16:20:43.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-23 16:21:20.000000000 +0200
+@@ -17,7 +17,7 @@
+
+ all:
+ echo Build graphTFT Frontend
+- @(make $(TARGET))
++ @$(MAKE) $(TARGET)
+
+
+ $(TARGET): $(OBJECTS)
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
index c69c7e3fa8d9..fe5d8c60acc0 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.2 2009/10/22 15:05:04 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.3 2009/10/23 14:28:25 hd_brummy Exp $
EAPI="2"
@@ -29,8 +29,7 @@ DEPEND=">=media-video/vdr-1.6.0_p2-r1[graphtft]
>=media-video/ffmpeg-0.4.8_p20090201
imagemagick? ( media-gfx/imagemagick[png,jpeg] )
directfb? ( dev-libs/DirectFB )
- graphtft-fe? ( x11-libs/qt-gui:4
- media-libs/imlib2[png,jpeg,X] )"
+ graphtft-fe? ( media-libs/imlib2[png,jpeg,X] )"
RDEPEND="${DEPEND}"
@@ -89,9 +88,7 @@ src_compile() {
if use graphtft-fe; then
cd "${S}"/graphtft-fe
- sed -i build.sh -e "s:qmake-qt4:qmake:"
- ./clean.sh
- ./build.sh || die "build.sh failed"
+ emake
fi
}