summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-04-07 01:36:55 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-04-07 01:36:55 +0000
commit3fa1c60d4be7dc7fece895db1fb957347dd9b4b7 (patch)
tree376d3311b94298d9b0bcf219715038a7da99cf07 /media-plugins
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-3fa1c60d4be7dc7fece895db1fb957347dd9b4b7.tar.gz
gentoo-2-3fa1c60d4be7dc7fece895db1fb957347dd9b4b7.tar.bz2
gentoo-2-3fa1c60d4be7dc7fece895db1fb957347dd9b4b7.zip
compilefix >=vdr-1.7.27
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog6
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-1.7.27.diff73
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild6
3 files changed, 83 insertions, 2 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index e816aa9b0f1d..67268bbf515a 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.29 2012/03/12 17:30:52 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.30 2012/04/07 01:36:55 hd_brummy Exp $
+
+ 07 Apr 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-graphtft-0.3.4.ebuild, +files/vdr-1.7.27.diff:
+ compilefix >=vdr-1.7.27
12 Mar 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
-vdr-graphtft-0.2.2-r1.ebuild, -files/vdr-graphtft-0.2.2-avutil50.patch,
diff --git a/media-plugins/vdr-graphtft/files/vdr-1.7.27.diff b/media-plugins/vdr-graphtft/files/vdr-1.7.27.diff
new file mode 100644
index 000000000000..9d8d499b5168
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-1.7.27.diff
@@ -0,0 +1,73 @@
+diff -Naur graphtft-30.orig/dspitems.c graphtft-30/dspitems.c
+--- graphtft-30.orig/dspitems.c 2012-04-07 03:09:26.000000000 +0200
++++ graphtft-30/dspitems.c 2012-04-07 03:11:03.000000000 +0200
+@@ -397,7 +397,7 @@
+ else if (strcasecmp(var, "Path") == 0)
+ return Str::notNull(recording->FileName());
+ else if (strcasecmp(var, "Time") == 0)
+- return formatDateTime(recording->start, fmt, buf, sizeof(buf));
++ return formatDateTime(recording->Start(), fmt, buf, sizeof(buf));
+ else if (strcasecmp(var, "EventID") == 0)
+ return Str::toStr(!recording->Info() ? na : (int)recording->Info()->EventID());
+ else if (strcasecmp(var, "SubTitle") == 0)
+diff -Naur graphtft-30.orig/graphtft.c graphtft-30/graphtft.c
+--- graphtft-30.orig/graphtft.c 2012-04-07 03:16:05.000000000 +0200
++++ graphtft-30/graphtft.c 2012-04-07 03:19:52.000000000 +0200
+@@ -311,7 +311,7 @@
+ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+- RegisterI18n(Phrases);
++// RegisterI18n(Phrases);
+ #endif
+
+ display = new cGraphTFTDisplay(THEMEVERSION);
+diff -Naur graphtft-30.orig/graphtft.h graphtft-30/graphtft.h
+--- graphtft-30.orig/graphtft.h 2012-04-07 03:16:05.000000000 +0200
++++ graphtft-30/graphtft.h 2012-04-07 03:21:04.000000000 +0200
+@@ -16,7 +16,7 @@
+ #include <vdr/config.h>
+
+ #if APIVERSNUM < 10507
+-# include "i18n.h"
++//# include "i18n.h"
+ # define trNOOP(s) (s)
+ #endif
+
+diff -Naur graphtft-30.orig/Makefile graphtft-30/Makefile
+--- graphtft-30.orig/Makefile 2012-04-07 03:16:05.000000000 +0200
++++ graphtft-30/Makefile 2012-04-07 03:18:44.000000000 +0200
+@@ -240,7 +240,7 @@
+ ### The object files (add further files here):
+
+ COMMONOBJS = $(PLUGIN).o dspitems.o display.o \
+- i18n.o setup.o osd.o scan.o theme.o common.o sysinfo.o \
++ setup.o osd.o scan.o theme.o common.o sysinfo.o \
+ touchthread.o
+
+ # transfer.o
+@@ -311,10 +311,10 @@
+
+ ### Targets:
+
+-all: libvdr-$(PLUGIN).so i18n
++all: libvdr-$(PLUGIN).so
+ @cp libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
+
+-alli: libvdr-$(PLUGIN).so i18n
++alli: libvdr-$(PLUGIN).so
+
+ libvdr-$(PLUGIN).so: $(COMMONOBJS) $(IMLIBOBJS) $(DFBOBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $^ $(LIBS) -o $@
+diff -Naur graphtft-30.orig/setup.h graphtft-30/setup.h
+--- graphtft-30.orig/setup.h 2012-04-07 03:16:05.000000000 +0200
++++ graphtft-30/setup.h 2012-04-07 03:21:41.000000000 +0200
+@@ -22,7 +22,7 @@
+ #include "theme.h"
+
+ #if APIVERSNUM < 10507
+-# include "i18n.h"
++//# include "i18n.h"
+ #endif
+
+ //***************************************************************************
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild
index 0ea92767ef32..96628c5d64da 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild,v 1.1 2012/03/12 17:22:31 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.4.ebuild,v 1.2 2012/04/07 01:36:55 hd_brummy Exp $
EAPI="4"
@@ -58,6 +58,10 @@ src_prepare() {
# UINT64_C is needed by ffmpeg headers
append-flags -D__STDC_CONSTANT_MACROS
+
+ if has_version ">=media-video/vdr-1.7.27"; then
+ epatch "${FILESDIR}/vdr-1.7.27.diff"
+ fi
}
src_compile() {