summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2014-01-06 14:52:20 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2014-01-06 14:52:20 +0000
commit3e8083f41c959baa045542fdd100258c0554a254 (patch)
tree0f0550709494b19421cd00d79fc3135d235d6726 /media-plugins/vdr-wirbelscan
parentsci-geosciences/foxtrotgps: Punt base.eclass (diff)
downloadgentoo-2-3e8083f41c959baa045542fdd100258c0554a254.tar.gz
gentoo-2-3e8083f41c959baa045542fdd100258c0554a254.tar.bz2
gentoo-2-3e8083f41c959baa045542fdd100258c0554a254.zip
eapi=5; vdr-plugin-2.eclass; ~amd64; compile fix; removed untransladed po files; new Makefile handling
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-wirbelscan')
-rw-r--r--media-plugins/vdr-wirbelscan/ChangeLog13
-rw-r--r--media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch46
-rw-r--r--media-plugins/vdr-wirbelscan/files/wirbelscan.mk123
-rw-r--r--media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.2.ebuild17
-rw-r--r--media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.3.ebuild21
-rw-r--r--media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.4a.ebuild19
-rw-r--r--media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild35
7 files changed, 215 insertions, 59 deletions
diff --git a/media-plugins/vdr-wirbelscan/ChangeLog b/media-plugins/vdr-wirbelscan/ChangeLog
index 69c00ce45574..d887edfd1185 100644
--- a/media-plugins/vdr-wirbelscan/ChangeLog
+++ b/media-plugins/vdr-wirbelscan/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-plugins/vdr-wirbelscan
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/ChangeLog,v 1.6 2011/09/15 14:18:25 hd_brummy Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/ChangeLog,v 1.7 2014/01/06 14:52:20 hd_brummy Exp $
+
+*vdr-wirbelscan-0.0.7-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org>
+ -vdr-wirbelscan-0.0.2.ebuild, -vdr-wirbelscan-0.0.3.ebuild,
+ -vdr-wirbelscan-0.0.4a.ebuild, +vdr-wirbelscan-0.0.7-r1.ebuild,
+ +files/receiver-api-fixes.patch, +files/wirbelscan.mk:
+ eapi=5; vdr-plugin-2.eclass; ~amd64; compile fix; removed untransladed po
+ files; new Makefile handling
*vdr-wirbelscan-0.0.7 (15 Sep 2011)
diff --git a/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch b/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch
new file mode 100644
index 000000000000..b801803afc9d
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch
@@ -0,0 +1,46 @@
+Index: vdr-plugin-wirbelscan-0.0.7/statemachine.c
+===================================================================
+--- vdr-plugin-wirbelscan-0.0.7.orig/statemachine.c 2011-03-24 16:48:43.000000000 +0100
++++ vdr-plugin-wirbelscan-0.0.7/statemachine.c 2012-04-03 19:51:08.813786243 +0200
+@@ -36,12 +36,12 @@
+ while (Running()) cCondWait::SleepMs(5);
+ }; /*TODO: check here periodically for lock and wether we got any data!*/
+ public:
+- cScanReceiver(tChannelID ChannelID, int AnyPid);
++ cScanReceiver(const cChannel* chan, int AnyPid);
+ virtual ~cScanReceiver() {cReceiver::Detach(); };
+ };
+
+-cScanReceiver::cScanReceiver(tChannelID ChannelID, int AnyPid) :
+- cReceiver(ChannelID, 99, AnyPid), cThread("dummy receiver") { }
++cScanReceiver::cScanReceiver(const cChannel* chan, int AnyPid) :
++ cReceiver(chan, 99), cThread("dummy receiver") { SetPids(NULL); AddPid(AnyPid); }
+
+ ///!-----------------------------------------------------------------
+ ///! v 0.0.5, store state in lastState if different and print state
+@@ -144,7 +144,7 @@
+ ScannedTransponders.Add(ScannedTransponder);
+
+ dev->SwitchChannel(Transponder, false);
+- aReceiver = new cScanReceiver(Transponder->GetChannelID(), 99);
++ aReceiver = new cScanReceiver(Transponder, 99);
+ dev->AttachReceiver(aReceiver);
+
+ cCondWait::SleepMs(1000);
+Index: vdr-plugin-wirbelscan-0.0.7/ttext.c
+===================================================================
+--- vdr-plugin-wirbelscan-0.0.7.orig/ttext.c 2011-03-24 19:29:59.000000000 +0100
++++ vdr-plugin-wirbelscan-0.0.7/ttext.c 2012-04-03 20:03:06.903786678 +0200
+@@ -374,9 +374,10 @@
+ }
+ }
+
+-cSwReceiver::cSwReceiver(cChannel * Channel) : cReceiver(Channel->GetChannelID(),
+- 100, Channel->Tpid()), cThread("ttext") {
++cSwReceiver::cSwReceiver(cChannel * Channel) : cReceiver(Channel, 100), cThread("ttext") {
+
++ SetPids(NULL);
++ AddPid(Channel->Tpid());
+ stopped = fuzzy = false;
+ channel = Channel;
+ buffer = new cRingBufferLinear(MEGABYTE(1),184);
diff --git a/media-plugins/vdr-wirbelscan/files/wirbelscan.mk b/media-plugins/vdr-wirbelscan/files/wirbelscan.mk
new file mode 100644
index 000000000000..be26afdbfb4a
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/files/wirbelscan.mk
@@ -0,0 +1,123 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id: wirbelscan.mk,v 1.1 2014/01/06 14:52:20 hd_brummy Exp $
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = wirbelscan
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o common.o frequencies.o menusetup.o satellites.o scanner.o dvb_wrapper.o
+OBJS += scanfilter.o caDescriptor.o statemachine.o countries.o ext_math.o ttext.o
+
+### The main target:
+
+all: $(SOFILE) i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.2.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.2.ebuild
deleted file mode 100644
index 946e74fefbf6..000000000000
--- a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.2.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.2.ebuild,v 1.4 2008/07/31 10:44:56 zzam Exp $
-
-inherit vdr-plugin
-
-DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
-HOMEPAGE="http://free.pages.at/wirbel4vdr/wirbelscan/index2.html"
-SRC_URI="http://free.pages.at/wirbel4vdr/wirbelscan/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="media-video/vdr
- !<media-tv/ivtv-0.8"
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.3.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.3.ebuild
deleted file mode 100644
index b23fe4bd7c52..000000000000
--- a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.3.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.3.ebuild,v 1.3 2008/07/31 10:44:56 zzam Exp $
-
-inherit vdr-plugin
-
-MY_P=${P}_20070903
-
-DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
-HOMEPAGE="http://free.pages.at/wirbel4vdr/wirbelscan/index2.html"
-SRC_URI="http://free.pages.at/wirbel4vdr/wirbelscan/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="media-video/vdr
- !<media-tv/ivtv-0.8"
-
-S="${WORKDIR}/${MY_P#vdr-}"
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.4a.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.4a.ebuild
deleted file mode 100644
index 579aa78193bb..000000000000
--- a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.4a.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.4a.ebuild,v 1.1 2008/07/31 10:44:56 zzam Exp $
-
-inherit vdr-plugin
-
-MY_P=${P}_20080515
-
-DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
-HOMEPAGE="http://wirbel.htpc-forum.de/wirbelscan/index2.html"
-SRC_URI="http://wirbel.htpc-forum.de/wirbelscan/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="media-video/vdr
- !<media-tv/ivtv-0.8"
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..4fc2465cb44d
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild,v 1.1 2014/01/06 14:52:20 hd_brummy Exp $
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
+HOMEPAGE="http://wirbel.htpc-forum.de/wirbelscan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/wirbelscan/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # remove untranslated po files
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,es_ES,el_GR,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ # new Makefile handling
+ cp "${FILESDIR}/wirbelscan.mk" "${S}/Makefile"
+
+ epatch "${FILESDIR}/receiver-api-fixes.patch"
+
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include scanfilter.h
+ fix_vdr_libsi_include scanfilter.c
+ fix_vdr_libsi_include caDescriptor.h
+}