summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-24 11:43:05 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-24 11:43:05 +0000
commit8d1f8deddcf7bd828eaaa3becd58ad86d236e4cf (patch)
tree25cb03f0402e89a057b6f7cb538cc2ec45206c46 /media-plugins/vdr-timeline
parentdev-tex/latex-beamer:lyx; bug #183030. (diff)
downloadgentoo-2-8d1f8deddcf7bd828eaaa3becd58ad86d236e4cf.tar.gz
gentoo-2-8d1f8deddcf7bd828eaaa3becd58ad86d236e4cf.tar.bz2
gentoo-2-8d1f8deddcf7bd828eaaa3becd58ad86d236e4cf.zip
Make it compile also with vdr-1.5.3 and up.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-plugins/vdr-timeline')
-rw-r--r--media-plugins/vdr-timeline/ChangeLog9
-rw-r--r--media-plugins/vdr-timeline/files/vdr-timeline-1.0.141_vdr-1.5.x.diff52
2 files changed, 55 insertions, 6 deletions
diff --git a/media-plugins/vdr-timeline/ChangeLog b/media-plugins/vdr-timeline/ChangeLog
index f27369497248..1c9b98cb1dce 100644
--- a/media-plugins/vdr-timeline/ChangeLog
+++ b/media-plugins/vdr-timeline/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-timeline
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-timeline/ChangeLog,v 1.11 2007/05/10 16:13:35 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-timeline/ChangeLog,v 1.12 2007/06/24 11:43:05 zzam Exp $
+
+ 24 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
+ files/vdr-timeline-1.0.141_vdr-1.5.x.diff:
+ Make it compile also with vdr-1.5.3 and up.
+
+ 24 Jun 2007; Matthias Schwarzott <zzam@gentoo.org> ChangeLog:
+ Make it compile also with vdr-1.5.3 and up.
10 May 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
+files/vdr-timeline-1.0.141_vdr-1.5.x.diff, vdr-timeline-1.0.141.ebuild:
diff --git a/media-plugins/vdr-timeline/files/vdr-timeline-1.0.141_vdr-1.5.x.diff b/media-plugins/vdr-timeline/files/vdr-timeline-1.0.141_vdr-1.5.x.diff
index 3cf33ce78861..6f6f1c550ff0 100644
--- a/media-plugins/vdr-timeline/files/vdr-timeline-1.0.141_vdr-1.5.x.diff
+++ b/media-plugins/vdr-timeline/files/vdr-timeline-1.0.141_vdr-1.5.x.diff
@@ -1,11 +1,53 @@
http://www.vdr-portal.de/board/thread.php?postid=565546#post565546
Joerg Bornkessel <hd_brummy@gentoo.org> 10 May 2007
+Matthias Schwarzott <zzam@gentoo.org> 24 Jun 2007
-diff -Naur timeline-1.0.141.orig/checkerOsd.c timeline-1.0.141/checkerOsd.c
---- timeline-1.0.141.orig/checkerOsd.c 2007-05-10 18:04:03.701564938 +0200
-+++ timeline-1.0.141/checkerOsd.c 2007-05-10 18:07:40.290012641 +0200
-@@ -338,9 +338,15 @@
+Index: timeline-1.0.141/checkerOsd.c
+===================================================================
+--- timeline-1.0.141.orig/checkerOsd.c
++++ timeline-1.0.141/checkerOsd.c
+@@ -246,7 +246,11 @@ void checkerOsd::genLines(int day,time_t
+ localtime_r(&start1t,&day1);
+ sprintf(line1,"%s %04d-%02d-%02d (%s):",tr("Conflict on"),day1.tm_year+1900,day1.tm_mon+1,day1.tm_mday,tr("same input device"));
+ sprintf(line2,"%02d:%02d-%02d:%02d, (P%d) %s: %s",ct1->Start()/100,ct1->Start()%100,ct1->Stop()/100,ct1->Stop()%100,ct1->Priority(),ch1->Name(),ct1->File());
++#if APIVERSNUM >= 10503
++ sprintf(line3,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct2->Start()/100,ct2->Start()%100,ct2->Stop()/100,ct2->Stop()%100,(const char *)ct2->PrintDay(ct2->Day(),ct2->WeekDays(),false),ct2->Priority(),ch2->Name(),ct2->File());
++#else
+ sprintf(line3,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct2->Start()/100,ct2->Start()%100,ct2->Stop()/100,ct2->Stop()%100,(const char *)ct2->PrintDay(ct2->Day(),ct2->WeekDays()),ct2->Priority(),ch2->Name(),ct2->File());
++#endif
+ }
+ }
+ else if (!ct1->IsSingleEvent() && ct2->IsSingleEvent())
+@@ -276,7 +280,11 @@ void checkerOsd::genLines(int day,time_t
+ {
+ localtime_r(&start1t,&day1);
+ sprintf(line1,"%s %04d-%02d-%02d (%s):",tr("Conflict on"),day1.tm_year+1900,day1.tm_mon+1,day1.tm_mday,tr("same input device"));
++#if APIVERSNUM >= 10503
++ sprintf(line2,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct1->Start()/100,ct1->Start()%100,ct1->Stop()/100,ct1->Stop()%100,(const char *)ct1->PrintDay(ct1->Day(),ct1->WeekDays(),false),ct1->Priority(),ch1->Name(),ct1->File());
++#else
+ sprintf(line2,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct1->Start()/100,ct1->Start()%100,ct1->Stop()/100,ct1->Stop()%100,(const char *)ct1->PrintDay(ct1->Day(),ct1->WeekDays()),ct1->Priority(),ch1->Name(),ct1->File());
++#endif
+ sprintf(line3,"%02d:%02d-%02d:%02d, (P%d) %s: %s",ct2->Start()/100,ct2->Start()%100,ct2->Stop()/100,ct2->Stop()%100,ct2->Priority(),ch2->Name(),ct2->File());
+ }
+ }
+@@ -313,9 +321,15 @@ void checkerOsd::genLines(int day,time_t
+ }
+ if (hasmatched)
+ {
++#if APIVERSNUM >= 10503
++ sprintf(line1,"%s %s (%s):",tr("Repeating conflict on"),(const char *)ct1->PrintDay(0,mdays,false),tr("same input device"));
++ sprintf(line2,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct1->Start()/100,ct1->Start()%100,ct1->Stop()/100,ct1->Stop()%100,(const char *)ct1->PrintDay(ct1->Day(),ct1->WeekDays(),false),ct1->Priority(),ch1->Name(),ct1->File());
++ sprintf(line3,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct2->Start()/100,ct2->Start()%100,ct2->Stop()/100,ct2->Stop()%100,(const char *)ct2->PrintDay(ct2->Day(),ct2->WeekDays(),false),ct2->Priority(),ch2->Name(),ct2->File());
++#else
+ sprintf(line1,"%s %s (%s):",tr("Repeating conflict on"),(const char *)ct1->PrintDay(0,mdays),tr("same input device"));
+ sprintf(line2,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct1->Start()/100,ct1->Start()%100,ct1->Stop()/100,ct1->Stop()%100,(const char *)ct1->PrintDay(ct1->Day(),ct1->WeekDays()),ct1->Priority(),ch1->Name(),ct1->File());
+ sprintf(line3,"%02d:%02d-%02d:%02d (%s), (P%d) %s: %s",ct2->Start()/100,ct2->Start()%100,ct2->Stop()/100,ct2->Stop()%100,(const char *)ct2->PrintDay(ct2->Day(),ct2->WeekDays()),ct2->Priority(),ch2->Name(),ct2->File());
++#endif
+ }
+ }
+ else // ct1->IsSingleEvent() && ct2->IsSingleEvent()
+@@ -338,9 +352,15 @@ void checkerOsd::genLines(int day,time_t
if (ch1->Frequency()!=ch2->Frequency())
{ // verschiedene Kanäle, genug Devices?
bool nofree=true;
@@ -14,7 +56,7 @@ diff -Naur timeline-1.0.141.orig/checkerOsd.c timeline-1.0.141/checkerOsd.c
+#if APIVERSNUM >= 10500
+ cDevice *cd1=cDevice::GetDevice(ch1,-1,false);
+ cDevice *cd2=cDevice::GetDevice(ch2,-1,false);
-+#else
++#else
cDevice *cd1=cDevice::GetDevice(ch1);
- cDevice *cd2=cDevice::GetDevice(ch2),*cdt;
+ cDevice *cd2=cDevice::GetDevice(ch2);