summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-02-06 14:35:53 +0000
committerMax Kalika <max@gentoo.org>2004-02-06 14:35:53 +0000
commitdad3a7437a962d0b6cd9cb327d7fa676dc869bb5 (patch)
tree42bb4301629db3ac5d52323219f0f52da8bb5c56 /media-plugins/mythdvd
parentBump to version 1.4.1. (Manifest recommit) (diff)
downloadgentoo-2-dad3a7437a962d0b6cd9cb327d7fa676dc869bb5.tar.gz
gentoo-2-dad3a7437a962d0b6cd9cb327d7fa676dc869bb5.tar.bz2
gentoo-2-dad3a7437a962d0b6cd9cb327d7fa676dc869bb5.zip
Ditch the postinst() message and don't attempt to install non-existant db files. Get rid of the alsa and lirc workarounds as they are no longer needed.
Diffstat (limited to 'media-plugins/mythdvd')
-rw-r--r--media-plugins/mythdvd/ChangeLog6
-rw-r--r--media-plugins/mythdvd/mythdvd-0.14.ebuild48
2 files changed, 13 insertions, 41 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index 386953049580..34879b5c5e60 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.8 2004/02/03 14:09:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.9 2004/02/06 14:35:53 max Exp $
+
+ 06 Feb 2004; Max Kalika <max@gentoo.org> mythdvd-0.14.ebuild:
+ Ditch the postinst() message and don't attempt to install non-existant db
+ files. Get rid of the alsa and lirc workarounds as they are no longer needed.
*mythdvd-0.14 (03 Feb 2004)
diff --git a/media-plugins/mythdvd/mythdvd-0.14.ebuild b/media-plugins/mythdvd/mythdvd-0.14.ebuild
index 829395919a13..c0bb0030c8f4 100644
--- a/media-plugins/mythdvd/mythdvd-0.14.ebuild
+++ b/media-plugins/mythdvd/mythdvd-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.14.ebuild,v 1.2 2004/02/06 14:35:53 max Exp $
inherit flag-o-matic
@@ -11,17 +11,17 @@ SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="alsa lirc transcode"
+IUSE="transcode"
-DEPEND="media-libs/libdvdread
- >=sys-apps/sed-4
+DEPEND=">=sys-apps/sed-4
>=media-plugins/mythvideo-${PV}
+ media-libs/libdvdread
transcode? ( media-video/transcode )
|| ( media-video/mplayer media-video/xine-ui media-video/ogle )
|| ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
src_unpack() {
- unpack ${A}
+ unpack ${A} && cd "${S}"
for i in `grep -lr "usr/local" "${S}"` ; do
sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
@@ -29,7 +29,8 @@ src_unpack() {
}
src_compile() {
- local myconf="--enable-vcd"
+ local myconf
+ myconf="--enable-vcd"
myconf="${myconf} `use_enable transcode`"
local cpu="`get-flag march || get-flag mcpu`"
@@ -39,44 +40,11 @@ src_compile() {
qmake -o "Makefile" "${PN}.pro"
- if [ "`use alsa`" ] ; then
- echo "CONFIG += using_alsa" >> settings.pro
- echo "EXTRA_LIBS += -lasound" >> settings.pro
- fi
- if [ "`use lirc`" ] ; then
- sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
- -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
- -i "settings.pro" || die "enable lirc sed failed"
- fi
-
econf ${myconf}
emake || die "compile problem"
}
src_install () {
einstall INSTALL_ROOT="${D}"
-
- insinto "/usr/share/mythtv/database/${PN}"
- doins dvddb/*.sql
-
- dodoc AUTHORS COPYING README UPGRADING
- newdoc dvddb/README README.db
-}
-
-pkg_postinst() {
- einfo "If this is the first time you install MythDVD,"
- einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
- einfo "to your MythTV database."
- einfo
- einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
- einfo
- einfo "If you're upgrading from an older version and for more"
- einfo "setup and usage instructions, please refer to:"
- einfo " /usr/share/doc/${PF}/README.gz"
- einfo " /usr/share/doc/${PF}/README.db.gz"
- einfo " /usr/share/doc/${PF}/UPGRADING.gz"
- ewarn "This part is important as there might be database changes"
- ewarn "which need to be performed or this package will not work"
- ewarn "properly."
- echo
+ dodoc AUTHORS COPYING README README-database UPGRADING
}