summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-01 19:08:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-01 19:08:34 +0000
commitf056d36bc276ce6dc2589e9f2aff0c2d562c6dc6 (patch)
tree8c897890d1d1a0c5545bc5f601b9dcbe5ebf220c /media-plugins/live
parentold (diff)
downloadgentoo-2-f056d36bc276ce6dc2589e9f2aff0c2d562c6dc6.tar.gz
gentoo-2-f056d36bc276ce6dc2589e9f2aff0c2d562c6dc6.tar.bz2
gentoo-2-f056d36bc276ce6dc2589e9f2aff0c2d562c6dc6.zip
version bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/ChangeLog7
-rw-r--r--media-plugins/live/live-2012.06.26.ebuild126
2 files changed, 132 insertions, 1 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index 2bf189bd7122..7c52013b7603 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.156 2012/06/15 13:31:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.157 2012/07/01 19:08:34 aballier Exp $
+
+*live-2012.06.26 (01 Jul 2012)
+
+ 01 Jul 2012; Alexis Ballier <aballier@gentoo.org> +live-2012.06.26.ebuild:
+ version bump
15 Jun 2012; Fabian Groffen <grobian@gentoo.org> live-2012.04.21.ebuild:
Fix building shared library on Darwin
diff --git a/media-plugins/live/live-2012.06.26.ebuild b/media-plugins/live/live-2012.06.26.ebuild
new file mode 100644
index 000000000000..c99ec62c2602
--- /dev/null
+++ b/media-plugins/live/live-2012.06.26.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2012.06.26.ebuild,v 1.1 2012/07/01 19:08:34 aballier Exp $
+
+EAPI=3
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+S="${WORKDIR}"
+
+# Alexis Ballier <aballier@gentoo.org>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+LIVE_ABI_VERSION=6
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-recursive2.patch"
+
+ if use static-libs ; then
+ cp -pPR live live-shared
+ mv live live-static
+ else
+ mv live live-shared
+ fi
+
+ use static-libs && cp "${FILESDIR}/config.gentoo" live-static
+ cp "${FILESDIR}/config.gentoo-so-r1" live-shared
+
+ case ${CHOST} in
+ *-solaris*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-static/config.gentoo \
+ || die ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-shared/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
+ live-static/config.gentoo \
+ || die static ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live-shared/config.gentoo-so-r1 \
+ || die shared
+ ;;
+ esac
+}
+
+src_configure() { :; }
+
+src_compile() {
+ tc-export CC CXX LD
+
+ # Still build the old synchronous interface as mplayer still needs it.
+ # Please drop me at some point!
+ append-flags '-DRTSPCLIENT_SYNCHRONOUS_INTERFACE'
+
+ if use static-libs ; then
+ cd "${WORKDIR}/live-static"
+
+ einfo "Beginning static library build"
+ ./genMakefiles gentoo
+ emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
+ fi
+
+ cd "${WORKDIR}/live-shared"
+ einfo "Beginning shared library build"
+ ./genMakefiles gentoo-so-r1
+ local suffix=$(get_libname ${LIVE_ABI_VERSION})
+ emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ pushd "${WORKDIR}/live-shared/${i}" > /dev/null
+ ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
+ popd > /dev/null
+ done
+
+ einfo "Beginning programs build"
+ for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
+ cd "${WORKDIR}/live-shared/${i}"
+ emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
+ done
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ use static-libs && dolib.a live-static/${library}/lib${library}.a
+ dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
+ dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
+
+ insinto /usr/include/${library}
+ doins live-shared/${library}/include/*h
+ done
+
+ # Should we really install these?
+ use examples && find live-shared/testProgs -type f -perm +111 -print0 | \
+ xargs -0 dobin
+
+ dobin live-shared/mediaServer/live555MediaServer
+ dobin live-shared/proxyServer/live555ProxyServer
+
+ # install docs
+ dodoc live-shared/README
+}