summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-01-07 17:22:19 +0000
committerSteve Dibb <beandog@gentoo.org>2010-01-07 17:22:19 +0000
commit7605e6e80e084ec6175dbe6335dc4e508e629a29 (patch)
treec0efa245222e13b03f3f9fe541ae793d779b4399 /media-plugins/alsa-plugins
parentAdded quotes (diff)
downloadgentoo-2-7605e6e80e084ec6175dbe6335dc4e508e629a29.tar.gz
gentoo-2-7605e6e80e084ec6175dbe6335dc4e508e629a29.tar.bz2
gentoo-2-7605e6e80e084ec6175dbe6335dc4e508e629a29.zip
Version bump, bug 297304
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/alsa-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog10
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild82
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch12
3 files changed, 102 insertions, 2 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 33c780c78ad6..bf180f743f18 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/alsa-plugins
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.114 2009/09/19 13:55:50 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.115 2010/01/07 17:22:18 beandog Exp $
+
+*alsa-plugins-1.0.22 (07 Jan 2010)
+
+ 07 Jan 2010; Steve Dibb <beandog@gentoo.org> +alsa-plugins-1.0.22.ebuild,
+ +files/alsa-plugins-1.0.22-automagic.patch:
+ Version bump, bug 297304
19 Sep 2009; Markus Meier <maekke@gentoo.org> alsa-plugins-1.0.20.ebuild:
arm stable, bug #280464
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild
new file mode 100644
index 000000000000..8893c8b9e339
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.22.ebuild,v 1.1 2010/01/07 17:22:18 beandog Exp $
+
+EAPI=2
+
+MY_P="${P/_/}"
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}[alsa_pcm_plugins_ioplug]
+ ffmpeg? ( media-video/ffmpeg
+ media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? (
+ media-libs/libsamplerate
+ media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
+ pulseaudio? ( media-sound/pulseaudio )
+ speex? ( media-libs/speex
+ media-libs/alsa-lib[alsa_pcm_plugins_rate,alsa_pcm_plugins_plug] )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ # Bug #256119
+ epatch "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
+
+ # Bug #278352
+ epatch "${FILESDIR}"/${P}-automagic.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-flags -DNDEBUG
+
+ local myspeex
+
+ if use speex; then
+ myspeex=lib
+ else
+ myspeex=no
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ --with-speex=${myspeex}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-pulse
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch
new file mode 100644
index 000000000000..f7d9e7dc437a
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.22-automagic.patch
@@ -0,0 +1,12 @@
+diff -ur alsa-plugins-1.0.21.orig/Makefile.am alsa-plugins-1.0.21/Makefile.am
+--- alsa-plugins-1.0.21.orig/Makefile.am 2009-05-06 10:07:28.000000000 +0300
++++ alsa-plugins-1.0.21/Makefile.am 2009-08-01 18:23:26.000000000 +0300
+@@ -17,7 +17,7 @@
+ if HAVE_PPH
+ SUBDIRS += pph
+ endif
+-if HAVE_SPEEXDSP
++if USE_LIBSPEEX
+ SUBDIRS += speex
+ endif
+