summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2004-06-24 22:48:09 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2004-06-24 22:48:09 +0000
commitfeb560d571462afc7b1d0ce7218f6631c5d95a70 (patch)
treee41eb74f52297a43ed338720e5349c836ae3aef9 /media-libs
parent(Manifest recommit) (diff)
downloadgentoo-2-feb560d571462afc7b1d0ce7218f6631c5d95a70.tar.gz
gentoo-2-feb560d571462afc7b1d0ce7218f6631c5d95a70.tar.bz2
gentoo-2-feb560d571462afc7b1d0ce7218f6631c5d95a70.zip
Fixed a compilation-error on PowerPC when using CFLAGS who don't allow Altivec-code.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog6
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc5.ebuild12
2 files changed, 14 insertions, 4 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 95d50d6a7ade..b1b76926b4bc 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.125 2004/06/24 14:40:29 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.126 2004/06/24 22:48:09 hansmi Exp $
+
+ 25 Jun 2004; Michael Hanselmann <hansmi@gentoo.org> xine-lib-1_rc5.ebuild:
+ Fixed a compilation-error on PowerPC when CFLAGS don't allow Altivec-code.
+ Uses USE-flag "altivec".
*xine-lib-1_rc5 (24 Jun 2004)
diff --git a/media-libs/xine-lib/xine-lib-1_rc5.ebuild b/media-libs/xine-lib/xine-lib-1_rc5.ebuild
index 7b6af4507918..5c5787d1060d 100644
--- a/media-libs/xine-lib/xine-lib-1_rc5.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc5.ebuild,v 1.1 2004/06/24 14:40:29 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc5.ebuild,v 1.2 2004/06/24 22:48:09 hansmi Exp $
inherit eutils flag-o-matic gcc libtool
@@ -78,7 +78,7 @@ src_unpack() {
}
src_compile() {
- filter-flags -maltivec -mabi=altivec -fstack-protector
+ filter-flags -fstack-protector
filter-flags -fPIC
filter-flags -fforce-addr
@@ -102,10 +102,16 @@ src_compile() {
use amd64 \
&& myconf="${myconf} --with-xv-path=/usr/X11R6/lib"
+ # Disable compiling of altivec-code if it's not in the
+ # USE-flags
+ use ppc && use altivec \
+ && myconf="${myconf} --enable-altivec" \
+ || CFLAGS="${CFLAGS} -U__ALTIVEC__"
+
# The default CFLAGS (-O) is the only thing working on hppa.
use hppa \
&& unset CFLAGS
-
+
econf \
`use_enable X x11` \
`use_enable esd` \